aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-03-07 20:06:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-03-07 20:14:14 +0000
commit4d180554716acbea77c23467e92a08b4e97ff39c (patch)
tree09d78350596b75264cb981bbcf1453f072342058
parent6fd379fdd2a68e6cce6cb1654d62e76d6e8ea7d3 (diff)
downloadports-4d180554716acbea77c23467e92a08b4e97ff39c.tar.gz
ports-4d180554716acbea77c23467e92a08b4e97ff39c.zip
science/py-trainstation: New port: Convenient training of linear models
-rw-r--r--science/Makefile1
-rw-r--r--science/py-trainstation/Makefile23
-rw-r--r--science/py-trainstation/distinfo3
-rw-r--r--science/py-trainstation/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 528822ddd742..9768ed6aaccb 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -339,6 +339,7 @@
SUBDIR += py-spglib
SUBDIR += py-tensorflow
SUBDIR += py-tobler
+ SUBDIR += py-trainstation
SUBDIR += py-veusz
SUBDIR += pybrain
SUBDIR += pynn
diff --git a/science/py-trainstation/Makefile b/science/py-trainstation/Makefile
new file mode 100644
index 000000000000..730fec45d628
--- /dev/null
+++ b/science/py-trainstation/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= trainstation
+DISTVERSION= 1.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Convenient training of linear models
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+xBUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>0:science/py-scikit-learn@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-trainstation/distinfo b/science/py-trainstation/distinfo
new file mode 100644
index 000000000000..39eb895ba02b
--- /dev/null
+++ b/science/py-trainstation/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646682358
+SHA256 (trainstation-1.0.tar.gz) = 00da4e99ffdf309d0f1a3d6a191d845002d49f478371a560019b6e22de55945d
+SIZE (trainstation-1.0.tar.gz) = 20216
diff --git a/science/py-trainstation/pkg-descr b/science/py-trainstation/pkg-descr
new file mode 100644
index 000000000000..c1b50cb6a53c
--- /dev/null
+++ b/science/py-trainstation/pkg-descr
@@ -0,0 +1,10 @@
+trainstation is a tool that allows the efficient construction of
+linear models. It provides supplementary functionality for handling
+data and model metrics and relies on the scikit-learn library for the
+actual training. trainstation has been originally developed to aid the
+construction of force constant and cluster expansions. Since it has
+proven to be valuable in more general contexts and to simplify the
+maintenance of the two aforementioned packages, the functionality has
+been moved into a separate package.
+
+WWW: https://trainstation.materialsmodeling.org/