aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-29 14:59:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-30 01:53:11 +0000
commit4d5f21187c5de2f1b31965846b89b225bf503f16 (patch)
treeaff1dd5b7fc1de4014fc3939107617144fe6e00a
parent6b2f34c72bac40fd1563764ec61ca1324497ed9c (diff)
downloadports-4d5f21187c5de2f1b31965846b89b225bf503f16.tar.gz
ports-4d5f21187c5de2f1b31965846b89b225bf503f16.zip
graphics/py-colorcet: New port: Useful perceptually uniform colormaps for plotting scientific data
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-colorcet/Makefile22
-rw-r--r--graphics/py-colorcet/distinfo3
-rw-r--r--graphics/py-colorcet/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index a8bc39977892..a9ab2a21d104 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -840,6 +840,7 @@
SUBDIR += py-cairosvg
SUBDIR += py-cartopy
SUBDIR += py-cogdumper
+ SUBDIR += py-colorcet
SUBDIR += py-colour
SUBDIR += py-descartes
SUBDIR += py-django-easy-thumbnails
diff --git a/graphics/py-colorcet/Makefile b/graphics/py-colorcet/Makefile
new file mode 100644
index 000000000000..a0e1739d3f71
--- /dev/null
+++ b/graphics/py-colorcet/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= colorcet
+DISTVERSION= 3.0.0
+CATEGORIES= graphics science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Useful perceptually uniform colormaps for plotting scientific data
+WWW= https://colorcet.holoviz.org/
+
+LICENSE= CC-BY-4.0
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}param>=1.7.0:devel/py-param@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyct>=0.4.4:misc/py-pyct@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist pytest
+
+.include <bsd.port.mk>
diff --git a/graphics/py-colorcet/distinfo b/graphics/py-colorcet/distinfo
new file mode 100644
index 000000000000..f84e284dffd3
--- /dev/null
+++ b/graphics/py-colorcet/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1664489331
+SHA256 (colorcet-3.0.0.tar.gz) = 21c522346a7aa81a603729f2996c22ac3f7822f4c8c303c59761e27d2dfcf3db
+SIZE (colorcet-3.0.0.tar.gz) = 3029130
diff --git a/graphics/py-colorcet/pkg-descr b/graphics/py-colorcet/pkg-descr
new file mode 100644
index 000000000000..43d35403e259
--- /dev/null
+++ b/graphics/py-colorcet/pkg-descr
@@ -0,0 +1,3 @@
+Colorcet is a collection of perceptually acccurate 256-color colormaps for use
+with Python plotting programs like Bokeh, Matplotlib, HoloViews, and
+Datashader.