aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:30:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:59:34 +0000
commit4d98b344a91a4b5db62dbb75ea1364470387f1f2 (patch)
treee4b1c70974e0e88fbf59057b91c7562ef982400b
parentf4f22f4009577fa8f33b7afef3119a64c0f1b5b4 (diff)
downloadports-4d98b344a91a4b5db62dbb75ea1364470387f1f2.tar.gz
ports-4d98b344a91a4b5db62dbb75ea1364470387f1f2.zip
audio/py-speechrecognition: Update to 3.9.0
- Update PORTNAME: use lowercase - Change MASTER_SITES from GitHub to PYPI - Update version requirement of RUN_DEPENDS - Take maintainership Changes: https://github.com/Uberi/speech_recognition/releases
-rw-r--r--audio/py-speechrecognition/Makefile24
-rw-r--r--audio/py-speechrecognition/distinfo6
-rw-r--r--textproc/py-textract/Makefile2
3 files changed, 16 insertions, 16 deletions
diff --git a/audio/py-speechrecognition/Makefile b/audio/py-speechrecognition/Makefile
index 063d91b7f77f..18dc914bd995 100644
--- a/audio/py-speechrecognition/Makefile
+++ b/audio/py-speechrecognition/Makefile
@@ -1,27 +1,27 @@
-PORTNAME= SpeechRecognition
-PORTVERSION= 3.8.1
+PORTNAME= speechrecognition
+PORTVERSION= 3.9.0
+MASTER_SITES= PYPI
CATEGORIES= audio python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= SpeechRecognition-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python Library for performing speech recognition
WWW= https://github.com/Uberi/speech_recognition
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USE_GITHUB= yes
-GH_ACCOUNT= Uberi
-GH_PROJECT= speech_recognition
-
RUN_DEPENDS= flac:audio/flac \
- ${PYTHON_PKGNAMEPREFIX}pyaudio>0:audio/py-pyaudio@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pyaudio>=0.2.11:audio/py-pyaudio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.26.0:www/py-requests@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-USES= python:3.6+
-USE_PYTHON= distutils autoplist
-post-extract:
- @cd ${WRKSRC}/speech_recognition && ${RM} flac-*
+post-patch:
+ @${RM} ${WRKSRC}/speech_recognition/flac-*
.include <bsd.port.mk>
diff --git a/audio/py-speechrecognition/distinfo b/audio/py-speechrecognition/distinfo
index 6af9e9ab4181..7edf222045ae 100644
--- a/audio/py-speechrecognition/distinfo
+++ b/audio/py-speechrecognition/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513498129
-SHA256 (Uberi-speech_recognition-3.8.1_GH0.tar.gz) = 82d3313db383409ddaf3e42625fb0c3518231a1feb5e2ed5473b10b3d5ece7bd
-SIZE (Uberi-speech_recognition-3.8.1_GH0.tar.gz) = 125426650
+TIMESTAMP = 1674065871
+SHA256 (SpeechRecognition-3.9.0.tar.gz) = a2f992acda6314a3fa574bf84c2e075ce75f2b4c143b4435d7cbc98f66565ee7
+SIZE (SpeechRecognition-3.9.0.tar.gz) = 32851748
diff --git a/textproc/py-textract/Makefile b/textproc/py-textract/Makefile
index 34b88b77997e..efd02bbf58b2 100644
--- a/textproc/py-textract/Makefile
+++ b/textproc/py-textract/Makefile
@@ -62,7 +62,7 @@ POCKETSPHINX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pocketsphinx>0:audio/py-pockets
PPTX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-pptx>=0.6.18:textproc/py-python-pptx@${PY_FLAVOR}
PS_RUN_DEPENDS= pstotext>0:print/pstotext
SOX_RUN_DEPENDS= sox>0:audio/sox
-SPEECH_RECOGNITION_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}SpeechRecognition>=3.8.1:audio/py-speechrecognition@${PY_FLAVOR}
+SPEECH_RECOGNITION_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}speechrecognition>=3.8.1:audio/py-speechrecognition@${PY_FLAVOR}
SPREADSHEET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlrd>=1.2.0:textproc/py-xlrd@${PY_FLAVOR}
TESSERACT_RUN_DEPENDS= tesseract>0:graphics/tesseract
UNRTF_RUN_DEPENDS= unrtf>0:textproc/unrtf