aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDerek Schrock <dereks@lifeofadishwasher.com>2021-06-14 04:49:13 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-06-14 21:44:30 +0000
commit4de7b118bcc2c06c4ec41fa7213e530884f9131e (patch)
treedc0f00560103606870f2e3aff0925853ae881763
parentb7cb940a80454e72725f393ba654aade6f61ee4b (diff)
mail/mutt: Update to 2.1.0
- Update to 2.1.0 [1] - Remove patch-browser upstream now ignores .. [1] http://www.mutt.org/relnotes/2.1/ PR: 256609
-rw-r--r--mail/mutt/Makefile12
-rw-r--r--mail/mutt/distinfo6
-rw-r--r--mail/mutt/files/extra-patch-ifdef10
-rw-r--r--mail/mutt/files/extra-patch-maildir-mtime10
-rw-r--r--mail/mutt/files/extra-patch-reverse_reply18
-rw-r--r--mail/mutt/files/extra-patch-smartdate6
-rw-r--r--mail/mutt/files/extra-smime-sender10
-rw-r--r--mail/mutt/files/patch-browser.c67
-rw-r--r--mail/mutt/files/patch-date-conditional10
-rw-r--r--mail/mutt/files/patch-dgc-deepif6
10 files changed, 42 insertions, 113 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index b3c04d915882..8f53078a28e5 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -1,7 +1,7 @@
# Created by: Udo Schweigert
PORTNAME= mutt
-DISTVERSION= 2.0.7
+DISTVERSION= 2.1.0
CATEGORIES+= mail
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
https://bitbucket.org/mutt/mutt/downloads/ \
@@ -137,12 +137,12 @@ GSSAPI_MIT_CONFIGURE_ON= ${GSSAPI_CONFIGURE_ARGS} \
GSSAPI_NONE_CONFIGURE_ON= --without-gss
HCACHE_NONE_CONFIGURE_ON= --disable-hcache
-HCACHE_NONE_CONFIGURE_OFF= --enable-hcache \
- --without-gdbm \
- --without-qdbm
+HCACHE_NONE_CONFIGURE_OFF= --enable-hcache
HCACHE_BDB_CONFIGURE_WITH= bdb=${LOCALBASE}
HCACHE_BDB_USES= bdb:42+
+HCACHE_BDB_VARS= CFLAGS+=-I${BDB_INCLUDE_DIR} \
+ LDFLAGS+=-L${BDB_LIB_DIR}
HCACHE_TOKYOCABINET_CONFIGURE_WITH= tokyocabinet=${LOCALBASE}
HCACHE_TOKYOCABINET_LIB_DEPENDS= libtokyocabinet.so:databases/tokyocabinet
@@ -208,10 +208,6 @@ pre-configure::
@${REINPLACE_CMD} -e 's#$$(docdir)/samples#${EXAMPLESDIR}#g' \
${WRKSRC}/contrib/Makefile.in
-pre-configure-HCACHE_BDB-on:
- @${REINPLACE_CMD} -E -e 's/BDB_VERSIONS="/&${BDB_LIB_NAME} db${BDB_VER} /' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
# Undo some dist. installed files
post-stage::
@${MV} ${STAGEDIR}/${LOCALBASE}/etc/Muttrc.dist \
diff --git a/mail/mutt/distinfo b/mail/mutt/distinfo
index e44c60fda433..3d9eddc76027 100644
--- a/mail/mutt/distinfo
+++ b/mail/mutt/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1620172336
-SHA256 (mutt/mutt-2.0.7.tar.gz) = 957688c6a521561992d4f2f27cf9feb239c7c6c0042c6061c0e474a7dd26cc91
-SIZE (mutt/mutt-2.0.7.tar.gz) = 5299366
+TIMESTAMP = 1623620472
+SHA256 (mutt/mutt-2.1.0.tar.gz) = 80835bbcce920bccf4fc99676eda9e83f03a929b4022eada931d721ede330d37
+SIZE (mutt/mutt-2.1.0.tar.gz) = 5405519
SHA256 (mutt/mutt-2.0.6.vc.greeting) = dbf9602a153acb5410d22d1fe7a478df74f40ba1b203c8a4bdb7eab2f876bdb5
SIZE (mutt/mutt-2.0.6.vc.greeting) = 1971
SHA256 (mutt/patch-1.13.0.vvv.initials.xz) = 8b25ad6596bd57d94f6551e7e73ceb8da620468e96fb507b2f51545d5b3eaa02
diff --git a/mail/mutt/files/extra-patch-ifdef b/mail/mutt/files/extra-patch-ifdef
index dd19fa374d6c..c0416b81c705 100644
--- a/mail/mutt/files/extra-patch-ifdef
+++ b/mail/mutt/files/extra-patch-ifdef
@@ -1,8 +1,8 @@
---- PATCHES.orig 2021-01-23 01:39:53 UTC
+--- PATCHES.orig 2021-06-13 21:49:46 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.4.cd.ifdef.1
---- init.c.orig 2021-01-21 20:23:24 UTC
+--- init.c.orig 2021-05-26 22:40:56 UTC
+++ init.c
@@ -678,6 +678,52 @@ static mbchar_table *parse_mbchar_table (const char *s
return t;
@@ -57,9 +57,9 @@
static int parse_unignore (BUFFER *buf, BUFFER *s, union pointer_long_t udata, BUFFER *err)
{
do
---- init.h.orig 2021-01-23 01:39:53 UTC
+--- init.h.orig 2021-06-13 21:49:46 UTC
+++ init.h
-@@ -4705,6 +4705,7 @@ static int parse_lists (BUFFER *, BUFFER *, union poin
+@@ -4787,6 +4787,7 @@ static int parse_lists (BUFFER *, BUFFER *, union poin
static int parse_unlists (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_alias (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_unalias (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
@@ -67,7 +67,7 @@
static int parse_echo (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_ignore (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_unignore (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
-@@ -4772,6 +4773,7 @@ const struct command_t Commands[] = {
+@@ -4854,6 +4855,7 @@ const struct command_t Commands[] = {
{ "hdr_order", parse_list, {.p=&HeaderOrderList} },
#ifdef HAVE_ICONV
{ "iconv-hook", mutt_parse_hook, {.l=MUTT_ICONVHOOK} },
diff --git a/mail/mutt/files/extra-patch-maildir-mtime b/mail/mutt/files/extra-patch-maildir-mtime
index f86a177c2787..722eb952383a 100644
--- a/mail/mutt/files/extra-patch-maildir-mtime
+++ b/mail/mutt/files/extra-patch-maildir-mtime
@@ -1,8 +1,8 @@
---- PATCHES.orig 2020-11-08 20:52:49 UTC
+--- PATCHES.orig 2021-06-13 21:49:47 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.7.ust.maildir-mtime.2
---- browser.c.orig 2020-11-03 17:50:37 UTC
+--- browser.c.orig 2021-05-23 18:20:50 UTC
+++ browser.c
@@ -32,6 +32,7 @@
#ifdef USE_IMAP
@@ -12,7 +12,7 @@
#include <stdlib.h>
#include <dirent.h>
-@@ -430,6 +431,21 @@ static void init_state (struct browser_state *state, M
+@@ -531,6 +532,21 @@ static void init_state (struct browser_state *state, M
menu->data = state->entry;
}
@@ -34,7 +34,7 @@
static int examine_directory (MUTTMENU *menu, struct browser_state *state,
const char *d, const char *prefix)
{
-@@ -496,6 +512,7 @@ static int examine_directory (MUTTMENU *menu, struct b
+@@ -597,6 +613,7 @@ static int examine_directory (MUTTMENU *menu, struct b
tmp = Incoming;
while (tmp && mutt_strcmp (mutt_b2s (full_path), mutt_b2s (tmp->pathbuf)))
tmp = tmp->next;
@@ -42,7 +42,7 @@
if (tmp && Context && !tmp->nopoll &&
!mutt_strcmp (tmp->realpath, Context->realpath))
{
-@@ -579,6 +596,7 @@ static int examine_mailboxes (MUTTMENU *menu, struct b
+@@ -680,6 +697,7 @@ static int examine_mailboxes (MUTTMENU *menu, struct b
s.st_mtime = st2.st_mtime;
}
diff --git a/mail/mutt/files/extra-patch-reverse_reply b/mail/mutt/files/extra-patch-reverse_reply
index 2c950c03af2e..ada407240849 100644
--- a/mail/mutt/files/extra-patch-reverse_reply
+++ b/mail/mutt/files/extra-patch-reverse_reply
@@ -1,10 +1,10 @@
---- PATCHES.orig 2021-01-23 01:39:53 UTC
+--- PATCHES.orig 2021-06-13 21:49:47 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.6.cb.reverse_reply.2
---- init.h.orig 2021-01-23 01:39:53 UTC
+--- init.h.orig 2021-06-13 21:49:46 UTC
+++ init.h
-@@ -3191,6 +3191,13 @@ struct option_t MuttVars[] = {
+@@ -3322,6 +3322,13 @@ struct option_t MuttVars[] = {
** In either case, a missing real name will be filled in afterwards
** using the value of $$realname.
*/
@@ -18,9 +18,9 @@
{ "rfc2047_parameters", DT_BOOL, R_NONE, {.l=OPTRFC2047PARAMS}, {.l=0} },
/*
** .pp
---- mutt.h.orig 2021-01-23 01:39:53 UTC
+--- mutt.h.orig 2021-06-13 21:49:46 UTC
+++ mutt.h
-@@ -522,6 +522,7 @@ enum
+@@ -525,6 +525,7 @@ enum
OPTREVALIAS,
OPTREVNAME,
OPTREVREAL,
@@ -28,7 +28,7 @@
OPTRFC2047PARAMS,
OPTSAVEADDRESS,
OPTSAVEEMPTY,
---- protos.h.orig 2021-01-21 20:23:24 UTC
+--- protos.h.orig 2021-05-23 18:20:51 UTC
+++ protos.h
@@ -85,6 +85,7 @@ char* mutt_extract_message_id (const char *, const cha
ADDRESS *mutt_get_address (ENVELOPE *, char **);
@@ -38,7 +38,7 @@
ADDRESS *mutt_expand_aliases (ADDRESS *);
ADDRESS *mutt_parse_adrlist (ADDRESS *, const char *);
---- send.c.orig 2021-01-21 20:23:24 UTC
+--- send.c.orig 2021-05-28 19:33:58 UTC
+++ send.c
@@ -739,6 +739,10 @@ void mutt_fix_reply_recipients (ENVELOPE *env)
/* the CC field can get cluttered, especially with lists */
@@ -51,9 +51,9 @@
env->cc = mutt_remove_xrefs (env->to, env->cc);
if (env->cc && !env->to)
---- sendlib.c.orig 2021-01-21 20:23:24 UTC
+--- sendlib.c.orig 2021-05-23 18:20:51 UTC
+++ sendlib.c
-@@ -3012,6 +3012,35 @@ static void set_noconv_flags (BODY *b, short flag)
+@@ -3044,6 +3044,35 @@ static void set_noconv_flags (BODY *b, short flag)
}
}
diff --git a/mail/mutt/files/extra-patch-smartdate b/mail/mutt/files/extra-patch-smartdate
index cc6360a0e825..4b707194df7e 100644
--- a/mail/mutt/files/extra-patch-smartdate
+++ b/mail/mutt/files/extra-patch-smartdate
@@ -1,4 +1,4 @@
---- hdrline.c.orig 2020-11-08 20:52:48 UTC
+--- hdrline.c.orig 2021-06-13 21:49:46 UTC
+++ hdrline.c
@@ -249,6 +249,89 @@ static char *apply_subject_mods (ENVELOPE *env)
* %Y = `x-label:' field (if present, tree unfolded, and != parent's x-label)
@@ -105,9 +105,9 @@
if (!do_locales)
setlocale (LC_TIME, "");
---- mutt.h.orig 2020-11-08 20:52:49 UTC
+--- mutt.h.orig 2021-06-13 21:49:47 UTC
+++ mutt.h
-@@ -169,6 +169,16 @@ typedef enum
+@@ -168,6 +168,16 @@ typedef enum
MUTT_WRITE_HEADER_MIME
} mutt_write_header_mode;
diff --git a/mail/mutt/files/extra-smime-sender b/mail/mutt/files/extra-smime-sender
index c44952a9a7e6..243fdc38f030 100644
--- a/mail/mutt/files/extra-smime-sender
+++ b/mail/mutt/files/extra-smime-sender
@@ -1,4 +1,4 @@
---- commands.c.orig 2020-11-06 20:53:46 UTC
+--- commands.c.orig 2021-05-23 18:20:50 UTC
+++ commands.c
@@ -302,7 +302,7 @@ int mutt_display_message (HEADER *cur)
{
@@ -9,9 +9,9 @@
mutt_message ( _("S/MIME signature successfully verified."));
else
mutt_error ( _("S/MIME certificate owner does not match sender."));
---- init.h.orig 2020-11-08 20:52:49 UTC
+--- init.h.orig 2021-06-13 21:49:47 UTC
+++ init.h
-@@ -3688,6 +3688,15 @@ struct option_t MuttVars[] = {
+@@ -3819,6 +3819,15 @@ struct option_t MuttVars[] = {
** to determine the key to use. It will ask you to supply a key, if it can't find one.
** (S/MIME only)
*/
@@ -27,9 +27,9 @@
{ "smime_self_encrypt_as", DT_SYN, R_NONE, {.p="smime_default_key"}, {.p=0} },
{ "smime_default_key", DT_STR, R_NONE, {.p=&SmimeDefaultKey}, {.p=0} },
/*
---- mutt.h.orig 2020-11-08 20:52:49 UTC
+--- mutt.h.orig 2021-06-13 21:49:47 UTC
+++ mutt.h
-@@ -606,6 +606,7 @@ enum
+@@ -609,6 +609,7 @@ enum
OPTSMIMEISDEFAULT,
OPTSMIMESELFENCRYPT,
OPTASKCERTLABEL,
diff --git a/mail/mutt/files/patch-browser.c b/mail/mutt/files/patch-browser.c
deleted file mode 100644
index c46dda57a60a..000000000000
--- a/mail/mutt/files/patch-browser.c
+++ /dev/null
@@ -1,67 +0,0 @@
---- browser.c.orig 2020-11-08 20:52:49 UTC
-+++ browser.c
-@@ -87,6 +87,12 @@ static int browser_compare_subject (const void *a, con
- struct folder_file *pa = (struct folder_file *) a;
- struct folder_file *pb = (struct folder_file *) b;
-
-+ /* Always keep '..' in first menu position */
-+ if (!strncmp(pa->display_name, "..", 2))
-+ return(-1);
-+ if (!strncmp(pb->display_name, "..", 2))
-+ return(1);
-+
- int r = mutt_strcoll (pa->display_name, pb->display_name);
-
- return ((BrowserSort & SORT_REVERSE) ? -r : r);
-@@ -97,6 +103,12 @@ static int browser_compare_date (const void *a, const
- struct folder_file *pa = (struct folder_file *) a;
- struct folder_file *pb = (struct folder_file *) b;
-
-+ /* Always keep '..' in first menu position */
-+ if (!strncmp(pa->display_name, "..", 2))
-+ return(-1);
-+ if (!strncmp(pb->display_name, "..", 2))
-+ return(1);
-+
- int r = pa->mtime - pb->mtime;
-
- return ((BrowserSort & SORT_REVERSE) ? -r : r);
-@@ -107,6 +119,12 @@ static int browser_compare_size (const void *a, const
- struct folder_file *pa = (struct folder_file *) a;
- struct folder_file *pb = (struct folder_file *) b;
-
-+ /* Always keep '..' in first menu position */
-+ if (!strncmp(pa->display_name, "..", 2))
-+ return(-1);
-+ if (!strncmp(pb->display_name, "..", 2))
-+ return(1);
-+
- int r = pa->size - pb->size;
-
- return ((BrowserSort & SORT_REVERSE) ? -r : r);
-@@ -117,6 +135,12 @@ static int browser_compare_count (const void *a, const
- struct folder_file *pa = (struct folder_file *) a;
- struct folder_file *pb = (struct folder_file *) b;
-
-+ /* Always keep '..' in first menu position */
-+ if (!strncmp(pa->display_name, "..", 2))
-+ return(-1);
-+ if (!strncmp(pb->display_name, "..", 2))
-+ return(1);
-+
- int r = pa->msg_count - pb->msg_count;
-
- return ((BrowserSort & SORT_REVERSE) ? -r : r);
-@@ -126,6 +150,12 @@ static int browser_compare_unread (const void *a, cons
- {
- struct folder_file *pa = (struct folder_file *) a;
- struct folder_file *pb = (struct folder_file *) b;
-+
-+ /* Always keep '..' in first menu position */
-+ if (!strncmp(pa->display_name, "..", 2))
-+ return(-1);
-+ if (!strncmp(pb->display_name, "..", 2))
-+ return(1);
-
- int r = pa->msg_unread - pb->msg_unread;
-
diff --git a/mail/mutt/files/patch-date-conditional b/mail/mutt/files/patch-date-conditional
index 67fe9c0e35d2..3144ba5bf621 100644
--- a/mail/mutt/files/patch-date-conditional
+++ b/mail/mutt/files/patch-date-conditional
@@ -1,8 +1,8 @@
---- PATCHES.orig 2020-11-08 20:52:50 UTC
+--- PATCHES.orig 2021-06-13 21:49:47 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.0.ats.date_conditional.1
---- hdrline.c.orig 2020-11-08 20:52:49 UTC
+--- hdrline.c.orig 2021-06-13 21:49:47 UTC
+++ hdrline.c
@@ -428,6 +428,53 @@ hdr_format_str (char *dest,
const char *cp;
@@ -58,9 +58,9 @@
p = dest;
---- muttlib.c.orig 2020-11-06 22:10:26 UTC
+--- muttlib.c.orig 2021-05-23 18:20:51 UTC
+++ muttlib.c
-@@ -1764,7 +1764,16 @@ void mutt_FormatString (char *dest, /* output buffer
+@@ -1677,7 +1677,16 @@ void mutt_FormatString (char *dest, /* output buffer
if (*src == '?')
{
flags |= MUTT_FORMAT_OPTIONAL;
@@ -78,7 +78,7 @@
}
else
{
-@@ -1780,12 +1789,12 @@ void mutt_FormatString (char *dest, /* output buffer
+@@ -1693,12 +1702,12 @@ void mutt_FormatString (char *dest, /* output buffer
count++;
}
*cp = 0;
diff --git a/mail/mutt/files/patch-dgc-deepif b/mail/mutt/files/patch-dgc-deepif
index c89ae940b13f..7f1515b6aefe 100644
--- a/mail/mutt/files/patch-dgc-deepif
+++ b/mail/mutt/files/patch-dgc-deepif
@@ -1,6 +1,6 @@
---- muttlib.c.orig 2020-11-08 20:52:50 UTC
+--- muttlib.c.orig 2021-06-13 21:49:47 UTC
+++ muttlib.c
-@@ -1807,6 +1807,12 @@ void mutt_FormatString (char *dest, /* output buffer
+@@ -1720,6 +1720,12 @@ void mutt_FormatString (char *dest, /* output buffer
count = 0;
while (count < sizeof (ifstring) && *src && *src != '?' && *src != '&')
{
@@ -13,7 +13,7 @@
*cp++ = *src++;
count++;
}
-@@ -1819,7 +1825,13 @@ void mutt_FormatString (char *dest, /* output buffer
+@@ -1732,7 +1738,13 @@ void mutt_FormatString (char *dest, /* output buffer
count = 0;
while (count < sizeof (elsestring) && *src && *src != '?')
{