aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiguel Gocobachi <miguel@gocobachi.dev>2021-08-15 06:29:57 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-08-15 06:29:57 +0000
commit4e043393f374bfd88ba26d65767b48f7c87bd9bc (patch)
tree32e77d6f61142a157ce378de22a852db9a04e2c8
parent7f5d5cff7076a426981f674bb4137768a099074d (diff)
downloadports-4e043393f374bfd88ba26d65767b48f7c87bd9bc.tar.gz
ports-4e043393f374bfd88ba26d65767b48f7c87bd9bc.zip
editors/elementary-code: Update to 6.0.0
PR: 257822
-rw-r--r--editors/elementary-code/Makefile13
-rw-r--r--editors/elementary-code/distinfo6
-rw-r--r--editors/elementary-code/pkg-plist8
3 files changed, 14 insertions, 13 deletions
diff --git a/editors/elementary-code/Makefile b/editors/elementary-code/Makefile
index 3c1fe8640e07..0ceb0a3fc67e 100644
--- a/editors/elementary-code/Makefile
+++ b/editors/elementary-code/Makefile
@@ -1,6 +1,5 @@
PORTNAME= elementary-code
-DISTVERSION= 3.4.1
-PORTREVISION= 3
+DISTVERSION= 6.0.0
CATEGORIES= editors
MAINTAINER= miguel@gocobachi.dev
@@ -10,29 +9,29 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:lang/vala
+RUN_DEPENDS= droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf \
+ pkcheck:sysutils/polkit
LIB_DEPENDS= libatk-1.0.so:accessibility/atk \
libeditorconfig.so:editors/editorconfig-core-c \
libfontconfig.so:x11-fonts/fontconfig \
libgee-0.8.so:devel/libgee \
libgit2-glib-1.0.so:devel/libgit2-glib \
libgranite.so:x11-toolkits/granite \
- libgtksourceview-3.0.so:x11-toolkits/gtksourceview3 \
libgtkspell3-3.so:textproc/gtkspell3 \
+ libhandy-1.so:x11-toolkits/libhandy \
libpeas-1.0.so:devel/libpeas \
libpeas-gtk-1.0.so:devel/libpeas \
libsoup-2.4.so:devel/libsoup \
libvala-0.48.so:lang/vala \
- libvte-2.91.so:x11-toolkits/vte3 \
- libvterm.so:devel/libvterm \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
libzeitgeist-2.0.so:sysutils/zeitgeist
USES= compiler:c++11-lang desktop-file-utils gettext gnome meson \
- ninja pkgconfig python:build xorg
+ ninja pkgconfig python:3.6+,build xorg
USE_GITHUB= yes
GH_ACCOUNT= elementary
GH_PROJECT= code
-USE_GNOME= cairo glib20 gtk30 gtksourceview3 pango
+USE_GNOME= cairo glib20 gtk30 gtksourceview4 pango vte3
GLIB_SCHEMAS= io.elementary.code.gschema.xml \
io.elementary.code.plugins.spell.gschema.xml \
io.elementary.code.plugins.terminal.gschema.xml
diff --git a/editors/elementary-code/distinfo b/editors/elementary-code/distinfo
index 9c7e82a9793f..42f3c1d99506 100644
--- a/editors/elementary-code/distinfo
+++ b/editors/elementary-code/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1593319458
-SHA256 (elementary-code-3.4.1_GH0.tar.gz) = d84b38193b72cd93995aae604358c83c5b6976d8472ce985027b947cfed990bf
-SIZE (elementary-code-3.4.1_GH0.tar.gz) = 1468212
+TIMESTAMP = 1628896888
+SHA256 (elementary-code-6.0.0_GH0.tar.gz) = c58b33db512e1c031f6870eb62b035dea764dbdd7c54b8e19c434af8ccd3a384
+SIZE (elementary-code-6.0.0_GH0.tar.gz) = 1303421
diff --git a/editors/elementary-code/pkg-plist b/editors/elementary-code/pkg-plist
index 326696d107a6..8841554e8ba1 100644
--- a/editors/elementary-code/pkg-plist
+++ b/editors/elementary-code/pkg-plist
@@ -2,14 +2,14 @@ bin/io.elementary.code
include/codecore.h
lib/io.elementary.code/plugins/brackets-completion/brackets-completion.plugin
lib/io.elementary.code/plugins/brackets-completion/libbrackets-completion.so
-lib/io.elementary.code/plugins/browser-preview/browser-preview.plugin
-lib/io.elementary.code/plugins/browser-preview/libbrowser-preview.so
lib/io.elementary.code/plugins/detect-indent/detect-indent.plugin
lib/io.elementary.code/plugins/detect-indent/libdetect-indent.so
lib/io.elementary.code/plugins/editorconfig/editorconfig.plugin
lib/io.elementary.code/plugins/editorconfig/libeditorconfig.so
lib/io.elementary.code/plugins/highlight-word-selection/highlight-word-selection.plugin
lib/io.elementary.code/plugins/highlight-word-selection/libhighlight-word-selection.so
+lib/io.elementary.code/plugins/markdown-actions/libmarkdown-actions.so
+lib/io.elementary.code/plugins/markdown-actions/markdown-actions.plugin
lib/io.elementary.code/plugins/outline/liboutline.so
lib/io.elementary.code/plugins/outline/outline.plugin
lib/io.elementary.code/plugins/pastebin/libpastebin.so
@@ -68,6 +68,7 @@ share/locale/bo/LC_MESSAGES/io.elementary.code.mo
share/locale/br/LC_MESSAGES/io.elementary.code.mo
share/locale/bs/LC_MESSAGES/io.elementary.code.mo
share/locale/ca/LC_MESSAGES/io.elementary.code.mo
+share/locale/ca@valencia/LC_MESSAGES/io.elementary.code.mo
share/locale/ce/LC_MESSAGES/io.elementary.code.mo
share/locale/ch/LC_MESSAGES/io.elementary.code.mo
share/locale/ckb/LC_MESSAGES/io.elementary.code.mo
@@ -155,7 +156,6 @@ share/locale/mi/LC_MESSAGES/io.elementary.code.mo
share/locale/mk/LC_MESSAGES/io.elementary.code.mo
share/locale/ml/LC_MESSAGES/io.elementary.code.mo
share/locale/mn/LC_MESSAGES/io.elementary.code.mo
-share/locale/mo/LC_MESSAGES/io.elementary.code.mo
share/locale/mr/LC_MESSAGES/io.elementary.code.mo
share/locale/ms/LC_MESSAGES/io.elementary.code.mo
share/locale/mt/LC_MESSAGES/io.elementary.code.mo
@@ -186,6 +186,7 @@ share/locale/qu/LC_MESSAGES/io.elementary.code.mo
share/locale/rm/LC_MESSAGES/io.elementary.code.mo
share/locale/rn/LC_MESSAGES/io.elementary.code.mo
share/locale/ro/LC_MESSAGES/io.elementary.code.mo
+share/locale/ro_MD/LC_MESSAGES/io.elementary.code.mo
share/locale/ru/LC_MESSAGES/io.elementary.code.mo
share/locale/rue/LC_MESSAGES/io.elementary.code.mo
share/locale/rw/LC_MESSAGES/io.elementary.code.mo
@@ -242,5 +243,6 @@ share/locale/zh_HK/LC_MESSAGES/io.elementary.code.mo
share/locale/zh_TW/LC_MESSAGES/io.elementary.code.mo
share/locale/zu/LC_MESSAGES/io.elementary.code.mo
share/metainfo/io.elementary.code.appdata.xml
+share/polkit-1/actions/io.elementary.code.policy
share/vala/vapi/codecore.deps
share/vala/vapi/codecore.vapi