aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-12-04 08:17:44 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 09:53:46 +0000
commit4e4149d6d88132b9c536ac66e32b8accc6bd1f20 (patch)
tree99af6842442f8578e4d082035c01affd4eed71ae
parentf727ae28aad85b8545ca5e2ee1752c006d63aa47 (diff)
downloadports-4e4149d6d88132b9c536ac66e32b8accc6bd1f20.tar.gz
ports-4e4149d6d88132b9c536ac66e32b8accc6bd1f20.zip
print/freetype2: update to 2.11.1
Changelog: CHANGES BETWEEN 2.11.0 and 2.11.1 I. IMPORTANT CHANGES - Some fields in the `CID_FaceDictRec`, `CID_FaceInfoRec`, and `FT_Data` structures have been changed from signed to unsigned type, which better reflects the actual usage. It is also an additional means to protect against malformed input. II. MISCELLANEOUS - Cmake support has been further improved. To do that various backward-incompatible changes were necessary; please see file `CMakeLists.txt` for more details. - Since version 2.11.0, a C99 compiler is necessary to compile FreeType. - The experimental 'COLR' v1 API has been updated to the latest OpenType standard 1.9. - The `apinames` tool got a new option `-wV` to output an OpenVMS Linker Option File. - VMS support was updated. - MS Visual Studio support was added to build the demo programs. PR: 260202 Exp-run by: antoine
-rw-r--r--print/freetype2/Makefile18
-rw-r--r--print/freetype2/distinfo6
-rw-r--r--print/freetype2/pkg-plist2
3 files changed, 12 insertions, 14 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index 75e6d892122f..8a27cf57fccd 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -1,7 +1,7 @@
# Created by: jseger@FreeBSD.org
PORTNAME= freetype2
-DISTVERSION= 2.11.0
+DISTVERSION= 2.11.1
CATEGORIES= print
MASTER_SITES= SAVANNAH/${PORTNAME:S/2//} \
SF/freetype/${PORTNAME}/${DISTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}/
@@ -24,11 +24,9 @@ CPE_VENDOR= freetype
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS \
- FT_WITH_BZIP2 \
- CMAKE_DISABLE_FIND_PACKAGE_HarfBuzz \
- FT_WITH_ZLIB
-
-CMAKE_OFF= FT_WITH_HARFBUZZ
+ FT_REQUIRE_BZIP2 \
+ FT_REQUIRE_ZLIB \
+ FT_DISABLE_HARFBUZZ
SUB_FILES= pkg-message
@@ -60,12 +58,12 @@ FIX_SIZE_METRICS_DESC= Fix metrics on size request for scalable fonts (alternati
TT_SIZE_METRICS_DESC= TrueType-like size metrics for 'light' auto-hinting
BROTLI_LIB_DEPENDS= libbrotlidec.so:archivers/brotli
-BROTLI_CMAKE_BOOL= FT_WITH_BROTLI
-BROTLI_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_BrotliDec
+BROTLI_CMAKE_BOOL= FT_REQUIRE_BROTLI
+BROTLI_CMAKE_BOOL_OFF= FT_DISABLE_BROTLI
PNG_LIB_DEPENDS= libpng.so:graphics/png
-PNG_CMAKE_BOOL= FT_WITH_PNG
-PNG_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_PNG
+PNG_CMAKE_BOOL= FT_REQUIRE_PNG
+PNG_CMAKE_BOOL_OFF= FT_DISABLE_PNG
LCD_FILTERING_CFLAGS= -DFT_CONFIG_OPTION_SUBPIXEL_RENDERING
diff --git a/print/freetype2/distinfo b/print/freetype2/distinfo
index 176b6623c026..9de170a62db8 100644
--- a/print/freetype2/distinfo
+++ b/print/freetype2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1627838448
-SHA256 (freetype-2.11.0.tar.xz) = 8bee39bd3968c4804b70614a0a3ad597299ad0e824bc8aad5ce8aaf48067bde7
-SIZE (freetype-2.11.0.tar.xz) = 2256640
+TIMESTAMP = 1638605794
+SHA256 (freetype-2.11.1.tar.xz) = 3333ae7cfda88429c97a7ae63b7d01ab398076c3b67182e960e5684050f2c5c8
+SIZE (freetype-2.11.1.tar.xz) = 2270728
diff --git a/print/freetype2/pkg-plist b/print/freetype2/pkg-plist
index 449bc1db8e9c..30ad31f7f347 100644
--- a/print/freetype2/pkg-plist
+++ b/print/freetype2/pkg-plist
@@ -59,5 +59,5 @@ lib/cmake/freetype/freetype-config-version.cmake
lib/cmake/freetype/freetype-config.cmake
lib/libfreetype.so
lib/libfreetype.so.6
-lib/libfreetype.so.6.18.0
+lib/libfreetype.so.6.18.1
libdata/pkgconfig/freetype2.pc