aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-02-09 10:12:00 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-14 14:27:53 +0000
commit4eb405985d1273cf020c98b4fd8784341d8a9ecb (patch)
tree24ec9224a0cb889978c6dac220a04dda21f7b3e4
parent01ef0a96665e6c379aed31910dfbdea184fd1e9b (diff)
downloadports-4eb405985d1273cf020c98b4fd8784341d8a9ecb.tar.gz
ports-4eb405985d1273cf020c98b4fd8784341d8a9ecb.zip
x11/swayimg: add new port
Now you can view images directly in the current terminal window! The program uses Sway IPC to determine the geometry of the currently focused container. This data is used to calculate the position and size of the new "overlay" window that will be used to draw the image. In the next step, swayimg adds two Sway rules for the self window: "floating enable" and "move position". Then it creates a new Wayland window and draws the image from the specified file. https://github.com/artemsen/swayimg
-rw-r--r--x11/Makefile1
-rw-r--r--x11/swayimg/Makefile68
-rw-r--r--x11/swayimg/distinfo7
-rw-r--r--x11/swayimg/pkg-descr10
4 files changed, 86 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 9b6516b4e665..511f969cca39 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -350,6 +350,7 @@
SUBDIR += swaybg
SUBDIR += swayfloatingswitcher
SUBDIR += swayidle
+ SUBDIR += swayimg
SUBDIR += swaylock
SUBDIR += swaylock-effects
SUBDIR += swaync
diff --git a/x11/swayimg/Makefile b/x11/swayimg/Makefile
new file mode 100644
index 000000000000..f3710b94b8ae
--- /dev/null
+++ b/x11/swayimg/Makefile
@@ -0,0 +1,68 @@
+PORTNAME= swayimg
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.6
+CATEGORIES= x11
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 96c78f97731c.patch:-p1 # https://github.com/artemsen/swayimg/pull/23
+PATCHFILES+= d12f10e9ebbd.patch:-p1 # https://github.com/artemsen/swayimg/pull/24
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Image viewer for Sway/Wayland
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libjson-c.so:devel/json-c \
+ libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= gnome meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= artemsen
+USE_GNOME= cairo
+MESON_ARGS= -Dversion="${DISTVERSIONFULL}"
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz \
+ man/man5/${PORTNAME}rc.5.gz \
+ share/applications/${PORTNAME}.desktop \
+ share/icons/hicolor/64x64/apps/${PORTNAME}.png \
+ ${NULL}
+
+OPTIONS_DEFINE= AVIF BASH GIF JPEG JXL LIBEXIF LIBRSVG2 PNG WEBP
+OPTIONS_DEFAULT=AVIF BASH GIF JPEG LIBEXIF LIBRSVG2 PNG WEBP
+OPTIONS_EXCLUDE=${LIBRSVG2_DEFAULT:Mlegacy:C/.+/LIBRSVG2/}
+
+AVIF_DESC= AV1 Image File Format via libavif
+AVIF_LIB_DEPENDS= libavif.so:graphics/libavif
+AVIF_MESON_ENABLED= avif
+
+BASH_BUILD_DEPENDS= bash-completion>0:shells/bash-completion
+BASH_MESON_ENABLED= bash
+BASH_PLIST_FILES= share/bash-completion/completions/${PORTNAME}
+
+GIF_LIB_DEPENDS= libgif.so:graphics/giflib
+GIF_USES= localbase:ldflags
+GIF_MESON_ENABLED= gif
+
+JPEG_USES= jpeg
+JPEG_MESON_ENABLED= jpeg
+
+JXL_DESC= JPEG XL image format via libjxl
+JXL_LIB_DEPENDS= libjxl.so:graphics/libjxl
+JXL_MESON_ENABLED= jxl
+
+LIBEXIF_LIB_DEPENDS= libexif.so:graphics/libexif
+LIBEXIF_MESON_ENABLED= exif
+
+LIBRSVG2_USE= GNOME=librsvg2
+LIBRSVG2_MESON_ENABLED= svg
+
+PNG_LIB_DEPENDS= libpng.so:graphics/png
+PNG_MESON_ENABLED= png
+
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+WEBP_MESON_ENABLED= webp
+
+.include <bsd.port.mk>
diff --git a/x11/swayimg/distinfo b/x11/swayimg/distinfo
new file mode 100644
index 000000000000..7d2e51b757f4
--- /dev/null
+++ b/x11/swayimg/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1644401520
+SHA256 (artemsen-swayimg-v1.6_GH0.tar.gz) = 944ad0c547c7fa45f26001431305529f75a8685f47e939c20442a7c16a6b22c0
+SIZE (artemsen-swayimg-v1.6_GH0.tar.gz) = 74037
+SHA256 (96c78f97731c.patch) = 33ef179a08f024de0dc1084bf03a3b9c048e32f497bfa8cd1bf2c58bcfe444bb
+SIZE (96c78f97731c.patch) = 889
+SHA256 (d12f10e9ebbd.patch) = 682a8889be251a91f4d70d9091de880a458651a9b32788b974a1ddb4f496a27c
+SIZE (d12f10e9ebbd.patch) = 973
diff --git a/x11/swayimg/pkg-descr b/x11/swayimg/pkg-descr
new file mode 100644
index 000000000000..eee8851bb4ae
--- /dev/null
+++ b/x11/swayimg/pkg-descr
@@ -0,0 +1,10 @@
+Now you can view images directly in the current terminal window!
+
+The program uses Sway IPC to determine the geometry of the currently
+focused container. This data is used to calculate the position and
+size of the new "overlay" window that will be used to draw the image.
+In the next step, swayimg adds two Sway rules for the self window:
+"floating enable" and "move position". Then it creates a new Wayland
+window and draws the image from the specified file.
+
+WWW: https://github.com/artemsen/swayimg