aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-04 03:40:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-04 06:48:23 +0000
commit4f870b7bbc6a9dcb2d57bd1094551b281eed46c7 (patch)
tree149b616dc3a0882c05c4d015fc0c394155a5e00d
parentb41577a705c45eeab937a34fe4a0f97d1b2d9e12 (diff)
downloadports-4f870b7bbc6a9dcb2d57bd1094551b281eed46c7.tar.gz
ports-4f870b7bbc6a9dcb2d57bd1094551b281eed46c7.zip
devel/py-ubelt: Update 1.2.2 -> 1.2.3
Reported by: portscout
-rw-r--r--devel/py-ubelt/Makefile4
-rw-r--r--devel/py-ubelt/distinfo6
-rw-r--r--devel/py-ubelt/files/patch-ubelt_util__platform.py33
3 files changed, 13 insertions, 30 deletions
diff --git a/devel/py-ubelt/Makefile b/devel/py-ubelt/Makefile
index 67426965b085..64ea03e7c85b 100644
--- a/devel/py-ubelt/Makefile
+++ b/devel/py-ubelt/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ubelt
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.2
+DISTVERSION= 1.2.3
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,7 +21,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}codecov>=2.0.15:devel/py-codecov@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}xxhash>0:devel/py-xxhash@${PY_FLAVOR}
USES= python:3.6+
-USE_PYTHON= distutils autoplist pytest # 1 test fails, see https://github.com/Erotemic/ubelt/issues/127#issuecomment-1238953686
+USE_PYTHON= distutils autoplist pytest # 1 test fails, see https://github.com/Erotemic/ubelt/issues/135
USE_GITHUB= yes
GH_ACCOUNT= Erotemic
diff --git a/devel/py-ubelt/distinfo b/devel/py-ubelt/distinfo
index 595d7a469e12..665571747a36 100644
--- a/devel/py-ubelt/distinfo
+++ b/devel/py-ubelt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1662531079
-SHA256 (Erotemic-ubelt-v1.2.2_GH0.tar.gz) = c456fef8cd9eb41297b09f54e338fa1b447307f228afe3f568f0bb96704e742b
-SIZE (Erotemic-ubelt-v1.2.2_GH0.tar.gz) = 303629
+TIMESTAMP = 1670124649
+SHA256 (Erotemic-ubelt-v1.2.3_GH0.tar.gz) = 1eb441dbbf6c8f2bc9426dcd1c740f98ec0cf9ed5ce9ca1311b2d9f56c97bacb
+SIZE (Erotemic-ubelt-v1.2.3_GH0.tar.gz) = 324632
diff --git a/devel/py-ubelt/files/patch-ubelt_util__platform.py b/devel/py-ubelt/files/patch-ubelt_util__platform.py
index 23f3cecb0861..c783ff1fdedf 100644
--- a/devel/py-ubelt/files/patch-ubelt_util__platform.py
+++ b/devel/py-ubelt/files/patch-ubelt_util__platform.py
@@ -1,4 +1,4 @@
---- ubelt/util_platform.py.orig 2022-08-10 01:18:14 UTC
+--- ubelt/util_platform.py.orig 2022-12-03 05:15:05 UTC
+++ ubelt/util_platform.py
@@ -42,7 +42,7 @@ from os.path import exists, join, isdir, expanduser, n
@@ -9,38 +9,21 @@
'find_exe', 'find_path',
'ensure_app_cache_dir', 'ensure_app_config_dir', 'ensure_app_data_dir',
'get_app_cache_dir', 'get_app_config_dir', 'get_app_data_dir',
-@@ -52,6 +52,7 @@ __all__ = [
- # References:
- # https://stackoverflow.com/questions/446209/possible-values-from-sys-platform
- WIN32 = sys.platform == 'win32' # type: bool
-+FREEBSD = sys.platform.startswith('freebsd') # type: bool
- LINUX = sys.platform.startswith('linux') # type: bool
- DARWIN = sys.platform == 'darwin' # type: bool
- POSIX = 'posix' in sys.builtin_module_names # type: bool
-@@ -66,6 +67,8 @@ def platform_data_dir():
+@@ -67,6 +67,8 @@ def platform_data_dir():
"""
- if LINUX: # nocover
+ if POSIX: # nocover
dpath_ = os.environ.get('XDG_DATA_HOME', '~/.local/share')
+ elif FREEBSD: # nocover
+ dpath_ = os.environ.get('XDG_DATA_HOME', '~/.local/share')
elif DARWIN: # nocover
dpath_ = '~/Library/Application Support'
elif WIN32: # nocover
-@@ -86,6 +89,8 @@ def platform_config_dir():
- """
- if LINUX: # nocover
- dpath_ = os.environ.get('XDG_CONFIG_HOME', '~/.config')
-+ elif FREEBSD: # nocover
-+ dpath_ = os.environ.get('XDG_CONFIG_HOME', '~/.config')
- elif DARWIN: # nocover
- dpath_ = '~/Library/Application Support'
- elif WIN32: # nocover
-@@ -105,6 +110,8 @@ def platform_cache_dir():
+@@ -86,6 +88,8 @@ def platform_config_dir():
str : path to the cache dir used by the current operating system
"""
- if LINUX: # nocover
-+ dpath_ = os.environ.get('XDG_CACHE_HOME', '~/.cache')
+ if POSIX: # nocover
++ dpath_ = os.environ.get('XDG_CONFIG_HOME', '~/.config')
+ elif FREEBSD: # nocover
- dpath_ = os.environ.get('XDG_CACHE_HOME', '~/.cache')
+ dpath_ = os.environ.get('XDG_CONFIG_HOME', '~/.config')
elif DARWIN: # nocover
- dpath_ = '~/Library/Caches'
+ dpath_ = '~/Library/Application Support'