aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2022-05-22 20:08:53 +0000
committerDima Panov <fluffy@FreeBSD.org>2022-05-22 20:17:15 +0000
commit4f921333e664ce1571f840423b680298202380ba (patch)
tree2b9f41d6ad3cc82eadad21efd1aa569787eb8e94
parent25c5203f02adbc14e623576647d9e59721f769c3 (diff)
downloadports-4f921333e664ce1571f840423b680298202380ba.tar.gz
ports-4f921333e664ce1571f840423b680298202380ba.zip
lang/solidity: mark as BROKEN after recent boost upgrade
PR: 246106
-rw-r--r--lang/solidity/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index b327015520fc..a53e7676869b 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -14,6 +14,8 @@ LICENSE= GPLv3
NOT_FOR_ARCHS= powerpc powerpc64 powerpcspe sparc64
NOT_FOR_ARCHS_REASON= solidity currently does not support big endian systems
+BROKEN= error: implicit conversion loses integer precision: 'typename std::enable_if<number_category<cpp_int_backend<0, 0, boost::multiprecision::signed_magnitude, boost::multiprecision::unchecked, allocator<unsigned long long>>>::value == number_kind_integer, std::size_t>::type' (aka 'unsigned long') to 'unsigned int'
+
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs \
libfmt>=0:devel/libfmt \
range-v3>=0:devel/range-v3