aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2024-05-30 12:06:58 +0000
committerMatthias Andree <mandree@FreeBSD.org>2024-05-30 12:07:46 +0000
commit5027adffbba0858aa74e4b5886498ebe6ad368c7 (patch)
tree4c5b5d2d7415de506741e0595c34a1a7e289a0b7
parentc7d90c65422d0b64ab00ece9237c2c4431d3ee23 (diff)
*/e2fsprogs*: update to 1.47.1
-rw-r--r--sysutils/e2fsprogs-core/Makefile21
-rw-r--r--sysutils/e2fsprogs-core/distinfo6
-rw-r--r--sysutils/e2fsprogs-core/files/patch-e2fsck__unix.c8
-rw-r--r--sysutils/e2fsprogs-core/files/patch-lib__uuid__gen_uuid.c10
-rw-r--r--sysutils/e2fsprogs-core/files/patch-lib_support_sort__r.h15
-rw-r--r--sysutils/e2fsprogs-core/pkg-plist1
-rw-r--r--sysutils/e2fsprogs/Makefile4
7 files changed, 32 insertions, 33 deletions
diff --git a/sysutils/e2fsprogs-core/Makefile b/sysutils/e2fsprogs-core/Makefile
index c180a563b874..a71b125694e9 100644
--- a/sysutils/e2fsprogs-core/Makefile
+++ b/sysutils/e2fsprogs-core/Makefile
@@ -1,6 +1,6 @@
PORTNAME= e2fsprogs
-PORTVERSION= 1.47.0
-PORTREVISION?= 1 # NOTE: when bumping PORTREVISION, also bump ../e2fsprogs/Makefile!
+PORTVERSION= 1.47.1
+PORTREVISION?= 0 # NOTE: when bumping PORTREVISION, also bump ../e2fsprogs/Makefile!
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
@@ -39,9 +39,8 @@ CONFIGURE_ARGS?=--disable-fsck \
--with-root-prefix='${PREFIX}' \
LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib -Wl,--rpath -Wl,${LOCALBASE}/lib/e2fsprogs'
CONFIGURE_ENV?= LIBS='-Wl,--as-needed ${LIBS} -lexecinfo -lelf'
-# apparently HAVE_PTHREAD_H checks go missing if the FUSEFS option is unset, force it:
-CPPFLAGS+= -I${WRKSRC}/lib -I${LOCALBASE}/include # -D_EXT2_USE_C_VERSIONS
-CFLAGS+= -Wno-unused-command-line-argument
+CPPFLAGS+= ${_FUSEFS_CFLAGS} -I${WRKSRC}/lib -I${LOCALBASE}/include
+CFLAGS+= -Wno-unused-command-line-argument # -D_FILE_OFFSET_BITS=64 # the latter for fuse-libs
MAKE_ARGS+= pkgconfigdir='${PREFIX}/libdata/pkgconfig'
MAKE_ENV+= CHECK_CMD=@true
@@ -70,7 +69,10 @@ BASHTESTS_DESC= Enable tests that require the GNU bash shell
LIBUNWIND_DESC= Backtrace with libunwind (do set WITH_DEBUG_PORTS+=${PKGORIGIN}!)
FUSEFS_CONFIGURE_ENABLE= fuse2fs
-FUSEFS_USES= fuse
+FUSEFS_USES= fuse:3
+# we can't use FUSEFS_CFLAGS, see below for workaround
+FUSEFS_LIBS= -Wl,--as-needed -lfuse3 -lpthread
+FUSEFS_LDFLAGS= -L${LOCALBASE}/lib
NLS_USES= gettext iconv:build
@@ -106,6 +108,13 @@ MAKE_ARGS+= V=1
PKGNAMESUFFIX= -core
.endif
+.if !empty(PORT_OPTIONS:MFUSEFS)
+# this dance is required becuse the -I must go before the default -I${LOCALBASE}/include, so we can't use FUSEFS_CFLAGS
+_FUSEFS_CFLAGS= -I${LOCALBASE}/include/fuse3
+.else
+_FUSEFS_CFLAGS=
+.endif
+
. if ! empty(ARCH:Mpowerpc*)
# Fix powerpc64/powerpc SIGSEGV,
# see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231570 (ppc64)
diff --git a/sysutils/e2fsprogs-core/distinfo b/sysutils/e2fsprogs-core/distinfo
index 1af95baa8677..fba31cb081b8 100644
--- a/sysutils/e2fsprogs-core/distinfo
+++ b/sysutils/e2fsprogs-core/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1675890715
-SHA256 (e2fsprogs-1.47.0.tar.xz) = 144af53f2bbd921cef6f8bea88bb9faddca865da3fbc657cc9b4d2001097d5db
-SIZE (e2fsprogs-1.47.0.tar.xz) = 7059372
+TIMESTAMP = 1717066777
+SHA256 (e2fsprogs-1.47.1.tar.xz) = 5a33dc047fd47284bca4bb10c13cfe7896377ae3d01cb81a05d406025d99e0d1
+SIZE (e2fsprogs-1.47.1.tar.xz) = 7271444
diff --git a/sysutils/e2fsprogs-core/files/patch-e2fsck__unix.c b/sysutils/e2fsprogs-core/files/patch-e2fsck__unix.c
index 19e4659d2d9b..fe98d8988b57 100644
--- a/sysutils/e2fsprogs-core/files/patch-e2fsck__unix.c
+++ b/sysutils/e2fsprogs-core/files/patch-e2fsck__unix.c
@@ -2,7 +2,7 @@
// remove the #define _XOPEN_SOURCE 600
// It would hide all non-POSIX declarations, including SIGINFO.
---- e2fsck/unix.c.orig 2021-01-29 22:02:31 UTC
+--- e2fsck/unix.c.orig 2024-05-21 02:52:47 UTC
+++ e2fsck/unix.c
@@ -9,8 +9,6 @@
* %End-Header%
@@ -22,7 +22,7 @@
#endif
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
-@@ -602,6 +600,24 @@ static int e2fsck_update_progress(e2fsck_t ctx, int pa
+@@ -608,6 +606,24 @@ static int e2fsck_update_progress(e2fsck_t ctx, int pa
return 0;
}
@@ -47,7 +47,7 @@
#define PATH_SET "PATH=/sbin"
/*
-@@ -635,6 +651,17 @@ static void signal_progress_on(int sig EXT2FS_ATTR((un
+@@ -641,6 +657,17 @@ static void signal_progress_on(int sig EXT2FS_ATTR((un
ctx->progress = e2fsck_update_progress;
}
@@ -65,7 +65,7 @@
static void signal_progress_off(int sig EXT2FS_ATTR((unused)))
{
e2fsck_t ctx = e2fsck_global_ctx;
-@@ -1120,6 +1147,10 @@ static errcode_t PRS(int argc, char *argv[], e2fsck_t
+@@ -1127,6 +1154,10 @@ static errcode_t PRS(int argc, char *argv[], e2fsck_t
sigaction(SIGUSR1, &sa, 0);
sa.sa_handler = signal_progress_off;
sigaction(SIGUSR2, &sa, 0);
diff --git a/sysutils/e2fsprogs-core/files/patch-lib__uuid__gen_uuid.c b/sysutils/e2fsprogs-core/files/patch-lib__uuid__gen_uuid.c
index f9d65b3597c6..13e7b8c2f6b5 100644
--- a/sysutils/e2fsprogs-core/files/patch-lib__uuid__gen_uuid.c
+++ b/sysutils/e2fsprogs-core/files/patch-lib__uuid__gen_uuid.c
@@ -1,6 +1,6 @@
---- lib/uuid/gen_uuid.c.orig 2020-03-21 04:24:04 UTC
+--- lib/uuid/gen_uuid.c.orig 2024-05-21 02:52:47 UTC
+++ lib/uuid/gen_uuid.c
-@@ -94,6 +94,7 @@
+@@ -92,6 +92,7 @@
#ifdef HAVE_SYS_RESOURCE_H
#include <sys/resource.h>
#endif
@@ -8,7 +8,7 @@
#include "uuidP.h"
#include "uuidd.h"
-@@ -300,6 +301,28 @@ static int get_node_id(unsigned char *node_id)
+@@ -288,6 +289,28 @@ static int get_node_id(unsigned char *node_id)
}
}
close(sd);
@@ -37,7 +37,7 @@
#endif
return 0;
}
-@@ -484,7 +507,7 @@ static void close_all_fds(void)
+@@ -472,7 +495,7 @@ static void close_all_fds(void)
}
#endif /* defined(USE_UUIDD) && defined(HAVE_SYS_UN_H) */
@@ -46,7 +46,7 @@
#pragma GCC diagnostic push
#if !defined(USE_UUIDD) || !defined(HAVE_SYS_UN_H)
#pragma GCC diagnostic ignored "-Wunused-parameter"
-@@ -572,7 +595,7 @@ fail:
+@@ -560,7 +583,7 @@ fail:
#endif
return -1;
}
diff --git a/sysutils/e2fsprogs-core/files/patch-lib_support_sort__r.h b/sysutils/e2fsprogs-core/files/patch-lib_support_sort__r.h
index 499a385bc1a3..c01a084feb6b 100644
--- a/sysutils/e2fsprogs-core/files/patch-lib_support_sort__r.h
+++ b/sysutils/e2fsprogs-core/files/patch-lib_support_sort__r.h
@@ -1,6 +1,6 @@
---- lib/support/sort_r.h.orig 2021-12-30 05:54:33 UTC
+--- lib/support/sort_r.h.orig 2024-05-21 02:52:47 UTC
+++ lib/support/sort_r.h
-@@ -234,10 +234,6 @@ static _SORT_R_INLINE void sort_r_simple(void *base, s
+@@ -238,10 +238,6 @@ static _SORT_R_INLINE void sort_r_simple(void *base, s
#if defined _SORT_R_BSD
@@ -11,14 +11,3 @@
#endif
-@@ -262,10 +258,6 @@ static _SORT_R_INLINE void sort_r_simple(void *base, s
-
- #if defined _SORT_R_LINUX
-
-- typedef int(* __compar_d_fn_t)(const void *, const void *, void *);
-- extern void qsort_r(void *base, size_t nel, size_t width,
-- __compar_d_fn_t __compar, void *arg)
-- __attribute__((nonnull (1, 4)));
-
- #endif
-
diff --git a/sysutils/e2fsprogs-core/pkg-plist b/sysutils/e2fsprogs-core/pkg-plist
index 71ab4cd1d662..369ce002d590 100644
--- a/sysutils/e2fsprogs-core/pkg-plist
+++ b/sysutils/e2fsprogs-core/pkg-plist
@@ -116,6 +116,7 @@ sbin/tune2fs
%%NLS%%share/locale/nl/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/pl/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/pt/LC_MESSAGES/e2fsprogs.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/sr/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/sv/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/tr/LC_MESSAGES/e2fsprogs.mo
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index ed7eaaf3965f..4c00a386ca64 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -1,7 +1,7 @@
PORTNAME= e2fsprogs
CATEGORIES= sysutils
-PORTVERSION= 1.47.0
-PORTREVISION= 1
+PORTVERSION= 1.47.1
+PORTREVISION= 0
BUILD_DEPENDS= e2fsprogs-core=${PORTVERSION}${${PORTREVISION} > 0:?_${PORTREVISION}:}:sysutils/e2fsprogs-core
RUN_DEPENDS= ${BUILD_DEPENDS}
DISTFILES= # empty