aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:11:20 +0000
commit5088c7b2d177b08823a3fc9c024d3cd5c168b19e (patch)
tree99fb077679c6595ec2efbfaa737ac9e7065837e7
parent339c6a9b46fc1553ec86ec5b0cac6f9cd861c083 (diff)
downloadports-5088c7b2d177b08823a3fc9c024d3cd5c168b19e.tar.gz
ports-5088c7b2d177b08823a3fc9c024d3cd5c168b19e.zip
japanese/edict: include errno.h for errno
errno must be accessed by a macro from errno.h. While here, remove seemingly defunct mirror.
-rw-r--r--japanese/edict/Makefile6
-rw-r--r--japanese/edict/files/patch-xjdclient.c18
-rw-r--r--japanese/edict/files/patch-xjdserver.c19
3 files changed, 39 insertions, 4 deletions
diff --git a/japanese/edict/Makefile b/japanese/edict/Makefile
index b2d7f2f87a20..dce3c5b8251a 100644
--- a/japanese/edict/Makefile
+++ b/japanese/edict/Makefile
@@ -1,10 +1,8 @@
PORTNAME= edict
PORTVERSION= 19990714
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese
-MASTER_SITES= \
- http://japanology.arts.kuleuven.ac.be/mirrors/monash/ \
- http://ftp.edrdg.org/pub/Nihongo/
+MASTER_SITES= http://ftp.edrdg.org/pub/Nihongo/
DISTFILES= ${DICTFILES} ${SRCFILES} ${DOCFILES}
DIST_SUBDIR= edict
EXTRACT_ONLY= ${SRCFILES}
diff --git a/japanese/edict/files/patch-xjdclient.c b/japanese/edict/files/patch-xjdclient.c
new file mode 100644
index 000000000000..58c749a9ffd0
--- /dev/null
+++ b/japanese/edict/files/patch-xjdclient.c
@@ -0,0 +1,18 @@
+--- xjdclient.c.orig 2024-09-30 19:41:16.980011000 +0100
++++ xjdclient.c 2024-09-30 19:42:00.456457000 +0100
+@@ -26,6 +26,7 @@
+
+ #include <stdio.h>
+ #include <ctype.h>
++#include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+@@ -40,7 +41,6 @@
+
+ #define CVERBOSE 0
+ int chk_cnt=0;
+-extern int errno;
+ unsigned char host[51] = {"localhost"};
+ unsigned char yn[2];
+ unsigned int portno = XJ_PORTNO;
diff --git a/japanese/edict/files/patch-xjdserver.c b/japanese/edict/files/patch-xjdserver.c
new file mode 100644
index 000000000000..3e1727c7ae28
--- /dev/null
+++ b/japanese/edict/files/patch-xjdserver.c
@@ -0,0 +1,19 @@
+--- xjdserver.c.orig 2024-09-30 19:42:21.985134000 +0100
++++ xjdserver.c 2024-09-30 19:42:39.088405000 +0100
+@@ -20,6 +20,7 @@
+
+ #include <stdio.h>
+ #include <ctype.h>
++#include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+@@ -55,8 +56,6 @@
+ int jiver = 14;
+ int thisdic = 0;
+ int DicNum;
+-
+-extern int errno;
+
+ extern unsigned char Dnamet[10][100],XJDXnamet[10][100];
+ extern unsigned char *dicbufft[10];