aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-07-13 20:35:27 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-07-13 20:35:27 +0000
commit508ee9f10341ac65eac121671fac7728585f18a4 (patch)
tree23dbaf0779048d865f2af41364dfb84f5e983031
parent7369e3c58b238303e09d6a79e79f91c51b8b0ec7 (diff)
downloadports-508ee9f10341ac65eac121671fac7728585f18a4.tar.gz
ports-508ee9f10341ac65eac121671fac7728585f18a4.zip
net/rubygem-omniauth-oauth2: Fix runtime of www/gitlab-ce
- Bump PORTREVISION for package change Allow omniauth 1.9.* to fix bundler check when gitlab starts.
-rw-r--r--net/rubygem-omniauth-oauth2/Makefile3
-rw-r--r--net/rubygem-omniauth-oauth2/files/patch-gemspec15
2 files changed, 17 insertions, 1 deletions
diff --git a/net/rubygem-omniauth-oauth2/Makefile b/net/rubygem-omniauth-oauth2/Makefile
index b2983383c0a9..80215b7af972 100644
--- a/net/rubygem-omniauth-oauth2/Makefile
+++ b/net/rubygem-omniauth-oauth2/Makefile
@@ -1,5 +1,6 @@
PORTNAME= omniauth-oauth2
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -10,7 +11,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= rubygem-oauth2>=1.4<3:net/rubygem-oauth2 \
- rubygem-omniauth>=2.0<3:security/rubygem-omniauth
+ rubygem-omniauth>=1.9<3:security/rubygem-omniauth
USES= gem
USE_RUBY= yes
diff --git a/net/rubygem-omniauth-oauth2/files/patch-gemspec b/net/rubygem-omniauth-oauth2/files/patch-gemspec
new file mode 100644
index 000000000000..e11300d78ced
--- /dev/null
+++ b/net/rubygem-omniauth-oauth2/files/patch-gemspec
@@ -0,0 +1,15 @@
+Fix runtime of www/gitlab-ce
+
+Allow omniauth 1.9.* to fix bundler check when gitlab starts.
+
+--- omniauth-oauth2.gemspec.orig 2022-07-11 15:00:59 UTC
++++ omniauth-oauth2.gemspec
+@@ -24,7 +24,7 @@ Gem::Specification.new do |s|
+
+ if s.respond_to? :add_runtime_dependency then
+ s.add_runtime_dependency(%q<oauth2>.freeze, [">= 1.4", "< 3"])
+- s.add_runtime_dependency(%q<omniauth>.freeze, ["~> 2.0"])
++ s.add_runtime_dependency(%q<omniauth>.freeze, [">= 1.9", "< 3"])
+ s.add_development_dependency(%q<bundler>.freeze, ["~> 2.0"])
+ else
+ s.add_dependency(%q<oauth2>.freeze, [">= 1.4", "< 3"])