aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Roome <steve.roome@gmail.com>2022-08-04 11:23:14 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-08-05 05:25:23 +0000
commit50964af9333cb62250c52ef6849a47b7dd5f7baa (patch)
tree267bb08c4fb8a4a32ed79cfada64a5b5117837fb
parent522dbcf83c046ec7e8ce433a1a75e89282bbf196 (diff)
downloadports-50964af9333cb62250c52ef6849a47b7dd5f7baa.tar.gz
ports-50964af9333cb62250c52ef6849a47b7dd5f7baa.zip
audio/gnupod: fix deprecated use of defined(@array)
Submitter becomes maintainer. First port to be maintained by submitter. PR: 265018 Reported by: steve.roome@gmail.com MFH: 2022Q3
-rw-r--r--audio/gnupod/Makefile2
-rw-r--r--audio/gnupod/files/patch-to-fix-gnupod.txt35
2 files changed, 36 insertions, 1 deletions
diff --git a/audio/gnupod/Makefile b/audio/gnupod/Makefile
index 2c137226670b..17849a622aea 100644
--- a/audio/gnupod/Makefile
+++ b/audio/gnupod/Makefile
@@ -5,7 +5,7 @@ CATEGORIES= audio perl5
MASTER_SITES= SAVANNAH \
http://www.blinkenlights.ch/gnupod-dist/stable/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= steve.roome@gmail.com
COMMENT= Set of Perl scripts for using an Apple iPod
LICENSE= GPLv3+
diff --git a/audio/gnupod/files/patch-to-fix-gnupod.txt b/audio/gnupod/files/patch-to-fix-gnupod.txt
new file mode 100644
index 000000000000..96ad7116fdc9
--- /dev/null
+++ b/audio/gnupod/files/patch-to-fix-gnupod.txt
@@ -0,0 +1,35 @@
+--- src/ext/FileMagic.pm.orig 2009-07-11 00:20:05.000000000 +0100
++++ src/ext/FileMagic.pm 2022-07-03 22:22:24.750066000 +0100
+@@ -362,7 +362,7 @@
+ foreach (keys(%{$in})) {
+ my $kvp = __flatten($_, $exclude); # key
+ next if !defined($kvp);
+- my $v = __flatten(%{$in}->{$_}, $exclude); # value
++ my $v = __flatten({$in->{$_}}, $exclude); # value
+ $kvp .= " : ".$v if (defined($v) && ("$v" ne ""));
+ push @out, $kvp;
+ }
+@@ -418,9 +418,9 @@
+ my $case = "check";
+
+ if (ref($options) eq "HASH") {
+- $joinby = %{$options}->{joinby} if defined(%{$options}->{joinby});
+- $wspace = lc(%{$options}->{wspace}) if defined(%{$options}->{wspace});
+- $case = lc(%{$options}->{case}) if defined(%{$options}->{case});
++ $joinby = $options->{joinby} if $options->{joinby};
++ $wspace = lc($options->{wspace}) if $options->{wspace};
++ $case = lc($options->{case}) if $options->{case};
+ }
+ my $merged = "";
+
+--- src/ext/XMLhelper.pm.orig 2009-07-11 00:20:05.000000000 +0100
++++ src/ext/XMLhelper.pm 2022-07-03 22:22:34.918120000 +0100
+@@ -359,7 +359,7 @@
+ print OUT " </smartplaylist>\n";
+ }
+ elsif(my $phr = get_plpref($current_plname)) { #plprefs found..
+- if (defined(@{$XDAT->{playlists}->{data}->{$current_plname}})) { #the playlist is not empty
++ if (@{$XDAT->{playlists}->{data}->{$current_plname}}) { #the playlist is not empty
+ print OUT "\n ".mkfile({playlist=>$phr}, {return=>1,noend=>1})."\n";
+ foreach(@{$XDAT->{playlists}->{data}->{$current_plname}}) {
+ print OUT " $_\n";