aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-03-18 22:54:47 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-03-18 22:58:58 +0000
commit50f4335ec42ceae09987be6266b6ff52e00a9df4 (patch)
treec1b0b44c06ba2a9176108ca941b184b113b9462b
parent6550bcd8f8168813620c21f6a6b416b1d2bbad69 (diff)
downloadports-50f4335ec42ceae09987be6266b6ff52e00a9df4.tar.gz
ports-50f4335ec42ceae09987be6266b6ff52e00a9df4.zip
graphics/libgnomecanvas: unbreak bulk -t build, add missing deps
To fix these poudriere build errors: [00:01:05] ====> Running Q/A tests (stage-qa) [00:01:05] Error: /usr/local/lib/libgnomecanvas-2.so.0.3000.3 is linked to /usr/local/lib/libcairo.so.2 from graphics/cairo but it is not declared as a dependency [00:01:05] Warning: you need USE_GNOME+=cairo [00:01:05] Error: /usr/local/lib/libgnomecanvas-2.so.0.3000.3 is linked to /usr/local/lib/libgdk_pixbuf-2.0.so.0 from graphics/gdk-pixbuf2 but it is not declared as a dependency [00:01:05] Warning: you need USE_GNOME+=gdkpixbuf2 [00:01:06] Error: /usr/local/lib/libgnomecanvas-2.so.0.3000.3 is linked to /usr/local/lib/libharfbuzz.so.0 from print/harfbuzz but it is not declared as a dependency [00:01:06] Warning: you need LIB_DEPENDS+=libharfbuzz.so:print/harfbuzz [00:01:06] Error: /usr/local/lib/libgnomecanvas-2.so.0.3000.3 is linked to /usr/local/lib/libfontconfig.so.1 from x11-fonts/fontconfig but it is not declared as a dependency [00:01:06] Warning: you need LIB_DEPENDS+=libfontconfig.so:x11-fonts/fontconfig [00:01:06] Error: /usr/local/lib/libgnomecanvas-2.so.0.3000.3 is linked to /usr/local/lib/libfreetype.so.6 from print/freetype2 but it is not declared as a dependency [00:01:06] Warning: you need LIB_DEPENDS+=libfreetype.so:print/freetype2 [00:01:06] ====> Checking for pkg-plist issues (check-plist) [00:01:06] ===> Parsing plist [00:01:06] ===> Checking for items in STAGEDIR missing from pkg-plist [00:01:06] Error: Orphaned: @dir lib/libglade/2.0 Approved by: portmgr@ (blanket)
-rw-r--r--graphics/libgnomecanvas/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/graphics/libgnomecanvas/Makefile b/graphics/libgnomecanvas/Makefile
index 638804d25223..3afc70124e57 100644
--- a/graphics/libgnomecanvas/Makefile
+++ b/graphics/libgnomecanvas/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgnomecanvas
PORTVERSION= 2.30.3
-PORTREVISION?= 5
+PORTREVISION?= 6
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -11,15 +11,21 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Graphics library for GNOME
-USES+= tar:bzip2
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
-USES+= gettext gmake gnome libtool localbase pathfix pkgconfig
+USES+= gettext gmake gnome libtool localbase pathfix pkgconfig tar:bzip2
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk20 intltool libartlgpl2 pango
USE_LDCONFIG= yes
-USE_GNOME= intltool libartlgpl2 gtk20 glib20 pango
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-glade \
--disable-gtk-doc
INSTALL_TARGET= install-strip
+post-install:
+ ${RMDIR} ${STAGEDIR}${PREFIX}/lib/libglade/2.0
+ ${RMDIR} ${STAGEDIR}${PREFIX}/lib/libglade
+
.include <bsd.port.mk>