aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-12 17:35:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-12 17:37:13 +0000
commit5114fbd567a30499953b95d2e7f480832652d218 (patch)
tree1cc8e2e29152ce910c007210b84faff0c04d54d3
parenta845d74f33f9d580da7d72d1c89c007d80c21e91 (diff)
downloadports-5114fbd567a30499953b95d2e7f480832652d218.tar.gz
ports-5114fbd567a30499953b95d2e7f480832652d218.zip
astro/siril: Fix libcurl dysfunction by adding the CURL option and enabling it properly
Reported by: Andreas Kempe <kempe@lysator.liu.se> (via e-mail)
-rw-r--r--astro/siril/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/astro/siril/Makefile b/astro/siril/Makefile
index 48b9cc18eb56..531f581a3300 100644
--- a/astro/siril/Makefile
+++ b/astro/siril/Makefile
@@ -1,5 +1,6 @@
PORTNAME= siril
DISTVERSION= 0.99.10.1
+PORTREVISION= 1
CATEGORIES= astro graphics
MASTER_SITES= https://free-astro.org/download/
@@ -15,7 +16,6 @@ BUILD_DEPENDS= cmake:devel/cmake
LIB_DEPENDS= libavformat.so:multimedia/ffmpeg \
libcfitsio.so:astro/cfitsio \
libconfig.so:devel/libconfig \
- libcurl.so:ftp/curl \
libexiv2.so:graphics/exiv2 \
libffms2.so:multimedia/ffms2 \
libfftw3.so:math/fftw3 \
@@ -41,9 +41,10 @@ INSTALLS_ICONS= yes
BINARY_ALIAS= git=false
-OPTIONS_DEFINE= OPENMP
-OPTIONS_DEFAULT= OPENMP
+OPTIONS_DEFINE= CURL OPENMP
+OPTIONS_DEFAULT= CURL OPENMP
-OPENMP_MESON_OFF= -Dopenmp=false
+CURL_MESON_YES= enable-libcurl
+CURL_LIB_DEPENDS= libcurl.so:ftp/curl
.include <bsd.port.mk>