aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof <ports@bsdserwis.com>2025-02-03 18:22:24 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2025-02-03 18:32:02 +0000
commit515051c82ccbc69fa40b35797d2bc6eefa6932a8 (patch)
treef8c25a0c4304d65fb8296da1ed859a3615f9f838
parent4fe0b26f595e920718527c6e0038d081f1870302 (diff)
security/mailzu: Fix support php83 and minor patches
PR: 284535 MFH: 2025Q1 (cherry picked from commit af1aff8f87166d72ddefcbbcbc8c464573d7a291)
-rw-r--r--security/mailzu/Makefile3
-rw-r--r--security/mailzu/files/patch-messagesPendingAdmin.php11
-rw-r--r--security/mailzu/files/patch-templates_viewmail.template.php16
3 files changed, 25 insertions, 5 deletions
diff --git a/security/mailzu/Makefile b/security/mailzu/Makefile
index c80c527092e2..7a2c9271de78 100644
--- a/security/mailzu/Makefile
+++ b/security/mailzu/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mailzu
DISTVERSION= 0.8rc3
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/MailZu%200.8RC3
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -21,7 +21,6 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/amavisd:security/amavisd-new \
USES= php:flavors,web
USE_PHP= sockets
-IGNORE_WITH_PHP= 83
NO_ARCH= yes
NO_BUILD= yes
diff --git a/security/mailzu/files/patch-messagesPendingAdmin.php b/security/mailzu/files/patch-messagesPendingAdmin.php
new file mode 100644
index 000000000000..c17e1fbe9d12
--- /dev/null
+++ b/security/mailzu/files/patch-messagesPendingAdmin.php
@@ -0,0 +1,11 @@
+--- messagesPendingAdmin.php.orig 2007-06-14 19:00:15 UTC
++++ messagesPendingAdmin.php
+@@ -36,6 +36,8 @@ $_SESSION['sessionNav'] = "Site Pending Requests";
+ // Get current page number
+ $requestedPage = CmnFns::getGlobalVar('page', GET);
+
++global $content_type;
++
+ $db = new DBEngine();
+
+ $t = new Template(translate('Site Quarantine'));
diff --git a/security/mailzu/files/patch-templates_viewmail.template.php b/security/mailzu/files/patch-templates_viewmail.template.php
index 64f4c1e50b21..612560763fdc 100644
--- a/security/mailzu/files/patch-templates_viewmail.template.php
+++ b/security/mailzu/files/patch-templates_viewmail.template.php
@@ -27,7 +27,17 @@
}
/**
-@@ -81,7 +81,9 @@ function MsgPrintHeader($struct,$hdr_list) {
+@@ -50,7 +50,8 @@ function endMessage() {
+ * $param The mime structure object and the specific header name
+ */
+ function MsgPrintHeader($struct,$hdr_list) {
+-
++ global $header_value;
++
+ foreach ($hdr_list as $hdr) {
+ $header_value = $struct->headers[strtolower($hdr)];
+ if (is_array($header_value)) {
+@@ -81,7 +82,9 @@ function MsgPrintHeader($struct,$hdr_list) {
function MsgPrintHeaderFull($struct,$hdr_list) {
foreach ($hdr_list as $hdr) {
@@ -38,7 +48,7 @@
if (!$header_value) continue;
if (is_array($header_value)) {
$value_array = $header_value;
-@@ -116,17 +118,17 @@ function MsgDisplayOptions($mail_id, $recip_email) {
+@@ -116,17 +119,17 @@ function MsgDisplayOptions($mail_id, $recip_email) {
<table class="stdFont" width="100%">
<tr>
<td align="left">
@@ -60,7 +70,7 @@
}
/**
-@@ -138,14 +140,14 @@ function MsgOriginalOptions() {
+@@ -138,14 +141,14 @@ function MsgOriginalOptions() {
<table width="100%">
<tr>
<td class="stdFont" align="right">