aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-02-28 02:38:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-02-28 04:08:08 +0000
commit51acdbc1482680f0f9b60f49c951d00edb6946fe (patch)
tree0ed988c6a190276f3a371897a7a374a71ca8fc81
parent45ec9fc6063eb947952150c38b0b6ec57dca0024 (diff)
downloadports-51acdbc1482680f0f9b60f49c951d00edb6946fe.tar.gz
ports-51acdbc1482680f0f9b60f49c951d00edb6946fe.zip
misc/py-onnx: Update 1.10.2 -> 1.11.0
Reported by: portscout
-rw-r--r--misc/py-onnx/Makefile2
-rw-r--r--misc/py-onnx/distinfo6
-rw-r--r--misc/py-onnx/files/patch-CMakeLists.txt20
-rw-r--r--misc/py-onnx/files/patch-setup.py38
4 files changed, 33 insertions, 33 deletions
diff --git a/misc/py-onnx/Makefile b/misc/py-onnx/Makefile
index 9951326f792a..e1af059d5c57 100644
--- a/misc/py-onnx/Makefile
+++ b/misc/py-onnx/Makefile
@@ -1,5 +1,5 @@
PORTNAME= onnx
-DISTVERSION= 1.10.2
+DISTVERSION= 1.11.0
CATEGORIES= misc # machine-learning
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/misc/py-onnx/distinfo b/misc/py-onnx/distinfo
index 418d1039fc28..82010e9b37ad 100644
--- a/misc/py-onnx/distinfo
+++ b/misc/py-onnx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1636361426
-SHA256 (onnx-1.10.2.tar.gz) = 24d73ca7dfd7e6c7339944f89554b4010719899337924fca1447d8f1b5db50d6
-SIZE (onnx-1.10.2.tar.gz) = 9872041
+TIMESTAMP = 1646015263
+SHA256 (onnx-1.11.0.tar.gz) = eca224c7c2c8ee4072a0743e4898a84a9bdf8297b5e5910a2632e4c4182ffb2a
+SIZE (onnx-1.11.0.tar.gz) = 9907888
diff --git a/misc/py-onnx/files/patch-CMakeLists.txt b/misc/py-onnx/files/patch-CMakeLists.txt
index e77008ab5907..6273f7b3bb82 100644
--- a/misc/py-onnx/files/patch-CMakeLists.txt
+++ b/misc/py-onnx/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2021-02-01 05:41:35 UTC
+--- CMakeLists.txt.orig 2022-02-07 19:42:24 UTC
+++ CMakeLists.txt
-@@ -18,7 +18,7 @@ project(onnx C CXX)
- option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
- option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag " OFF)
-
--option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
-+option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
- option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
- option(ONNX_WERROR "Build with Werror" OFF)
- option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
+@@ -18,7 +18,7 @@ project(onnx C CXX)
+ option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
+ option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag and Protobuf_USE_STATIC_LIBS. " OFF)
+
+-option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
++option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
+ option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
+ option(ONNX_WERROR "Build with Werror" OFF)
+ option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
diff --git a/misc/py-onnx/files/patch-setup.py b/misc/py-onnx/files/patch-setup.py
index abdc4806c19b..d3e574b68c07 100644
--- a/misc/py-onnx/files/patch-setup.py
+++ b/misc/py-onnx/files/patch-setup.py
@@ -1,20 +1,20 @@
---- setup.py.orig 2021-01-29 23:31:55 UTC
+--- setup.py.orig 2022-02-07 19:42:28 UTC
+++ setup.py
-@@ -56,11 +56,12 @@ COVERAGE = bool(os.getenv('COVERAGE'))
- # Version
- ################################################################################
-
--try:
-- git_version = subprocess.check_output(['git', 'rev-parse', 'HEAD'],
-- cwd=TOP_DIR).decode('ascii').strip()
--except (OSError, subprocess.CalledProcessError):
-- git_version = None
-+#try:
-+# git_version = subprocess.check_output(['git', 'rev-parse', 'HEAD'],
-+# cwd=TOP_DIR).decode('ascii').strip()
-+#except (OSError, subprocess.CalledProcessError):
-+# git_version = None
-+git_version = None
-
- with open(os.path.join(TOP_DIR, 'VERSION_NUMBER')) as version_file:
- VersionInfo = namedtuple('VersionInfo', ['version', 'git_version'])(
+@@ -61,11 +61,12 @@ COVERAGE = bool(os.getenv('COVERAGE', '0') == '1')
+ # Version
+ ################################################################################
+
+-try:
+- git_version = subprocess.check_output(['git', 'rev-parse', 'HEAD'],
+- cwd=TOP_DIR).decode('ascii').strip()
+-except (OSError, subprocess.CalledProcessError):
+- git_version = None
++#try:
++# git_version = subprocess.check_output(['git', 'rev-parse', 'HEAD'],
++# cwd=TOP_DIR).decode('ascii').strip()
++#except (OSError, subprocess.CalledProcessError):
++# git_version = None
++git_version = None
+
+ with open(os.path.join(TOP_DIR, 'VERSION_NUMBER')) as version_file:
+ VERSION_NUMBER = version_file.read().strip()