aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-10-01 07:10:08 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-10-01 07:13:09 +0000
commit525e857368c8c2de355ca00b0c35008be6ee8a3c (patch)
tree5715012b28ede49cbd196ad2f3fe96a7c872f129
parent17f1bb50e42a45dc64fc898cd9cae905d7262bda (diff)
downloadports-525e857368c8c2de355ca00b0c35008be6ee8a3c.tar.gz
ports-525e857368c8c2de355ca00b0c35008be6ee8a3c.zip
sysutils/e2fsprogs: revert bogus qsort_r() patch.
delphij@ and the upstream maintainer were working on a autoconf-based solution, and this patch was not approved. Remove it and mark port BROKEN on systems that changed qsort_r() for the GNU-like API. PR: 266227
-rw-r--r--sysutils/e2fsprogs/Makefile6
-rw-r--r--sysutils/e2fsprogs/files/patch-lib_support_sort__r.h21
2 files changed, 5 insertions, 22 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 9a89d8de14f6..1205caa9179a 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -13,7 +13,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.46.5
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
@@ -142,6 +142,10 @@ USE_PERL5= build
.include <bsd.port.pre.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400072
+BROKEN= incompatible qsort_r() API. Upstream working on a autoconf-based fix.
+.endif
+
.if ${PORT_OPTIONS:MNLS}
. if empty(ICONV_LIB)
libintl= ${LOCALBASE}/lib/libintl.a
diff --git a/sysutils/e2fsprogs/files/patch-lib_support_sort__r.h b/sysutils/e2fsprogs/files/patch-lib_support_sort__r.h
deleted file mode 100644
index dec89ce8ef9a..000000000000
--- a/sysutils/e2fsprogs/files/patch-lib_support_sort__r.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- lib/support/sort_r.h.orig 2021-12-30 05:54:33 UTC
-+++ lib/support/sort_r.h
-@@ -25,7 +25,8 @@ void sort_r(void *base, size_t nel, size_t width,
- #define _SORT_R_INLINE inline
-
- #if (defined __gnu_hurd__ || defined __GNU__ || \
-- defined __linux__ || defined __MINGW32__ || defined __GLIBC__)
-+ defined __linux__ || defined __MINGW32__ || defined __GLIBC__ || \
-+ defined qsort_r)
- # define _SORT_R_LINUX
- #elif (defined __APPLE__ || defined __MACH__ || defined __DARWIN__ || \
- defined __FreeBSD__ || defined __DragonFly__)
-@@ -263,7 +264,7 @@ static _SORT_R_INLINE void sort_r_simple(void *base, s
- #if defined _SORT_R_LINUX
-
- typedef int(* __compar_d_fn_t)(const void *, const void *, void *);
-- extern void qsort_r(void *base, size_t nel, size_t width,
-+ extern void (qsort_r)(void *base, size_t nel, size_t width,
- __compar_d_fn_t __compar, void *arg)
- __attribute__((nonnull (1, 4)));
-