aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-07-21 15:16:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-10-21 16:55:10 +0000
commit52a593f2e72d722d4f3fd84ad7466c52c121d788 (patch)
tree09e567efe35d95f95f824ae6327736afd1aa4e19
parent5bf6281030ab74d69ef70212893fa891adf63155 (diff)
downloadports-52a593f2e72d722d4f3fd84ad7466c52c121d788.tar.gz
ports-52a593f2e72d722d4f3fd84ad7466c52c121d788.zip
games/pioneer: take maintainership and update to 20210723
-rw-r--r--games/pioneer/Makefile57
-rw-r--r--games/pioneer/distinfo6
-rw-r--r--games/pioneer/files/patch-src_scenegraph_Serializer.h24
-rw-r--r--games/pioneer/pkg-descr2
-rw-r--r--games/pioneer/pkg-plist4
5 files changed, 28 insertions, 65 deletions
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
index 3096e47d738f..2d54a1267134 100644
--- a/games/pioneer/Makefile
+++ b/games/pioneer/Makefile
@@ -1,30 +1,26 @@
# Created by: lightside <lightside@gmx.com>
PORTNAME= pioneer
-DISTVERSION= 0.0.${GH_TAGNAME}
-PORTREVISION= 2
+DISTVERSION= 20210723
CATEGORIES= games
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Space adventure game set in the Milky Way galaxy
-LICENSE= APACHE20 BSD2CLAUSE CC-BY-SA-3.0 DejaVu GLEW GPLv3 IUP \
+LICENSE= APACHE20 BSD2CLAUSE CC-BY-SA-3.0 DejaVu GPLv3 IUP \
MIT SIL ZLIB
LICENSE_COMB= multi
LICENSE_NAME_DejaVu= Bitstream Vera and Arev fonts license
-LICENSE_NAME_GLEW= The OpenGL Extension Wrangler Library license
LICENSE_NAME_IUP= Galaxy colour image use policy
LICENSE_NAME_SIL= SIL open font license version 1.1
LICENSE_FILE_APACHE20= ${WRKSRC}/licenses/Apache-2.0.txt
LICENSE_FILE_BSD2CLAUSE= ${WRKSRC}/licenses/LZ4.txt
LICENSE_FILE_CC-BY-SA-3.0= ${WRKSRC}/licenses/CC-BY-SA-3.0.txt
LICENSE_FILE_DejaVu= ${WRKSRC}/licenses/DejaVu-license.txt
-LICENSE_FILE_GLEW= ${WRKSRC}/licenses/GLEW.txt
LICENSE_FILE_GPLv3= ${WRKSRC}/licenses/GPL-3.txt
LICENSE_FILE_IUP= ${WRKSRC}/licenses/Image\ Use\ Policy\ -\ NASA\ Spitzer\ Space\ Telescope.html
LICENSE_FILE_SIL= ${WRKSRC}/licenses/SIL-1.1.txt
LICENSE_PERMS_DejaVu= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LICENSE_PERMS_GLEW= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_IUP= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_SIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
@@ -38,16 +34,14 @@ LIB_DEPENDS= libassimp.so:multimedia/assimp \
libsigc-2.0.so:devel/libsigc++20 \
libvorbisfile.so:audio/libvorbis
-USES= cmake compiler:c++11-lib gl gnome pkgconfig sdl
+USES= cmake compiler:c++17-lang gl gnome lua:52 pkgconfig sdl
USE_GITHUB= yes
-GH_ACCOUNT= pioneerspacesim
-GH_TAGNAME= 20191009
-USE_GL= gl glu
+USE_GL= gl glu glew
USE_SDL= image2 sdl2
-
+GH_ACCOUNT= pioneerspacesim
+ALL_TARGET= all build-data
CMAKE_ARGS= -DPIONEER_DATA_DIR:PATH="${DATADIR}/data"
-EXTRACT_AFTER_ARGS= --no-same-owner --no-same-permissions --exclude \
- .gitignore
+CMAKE_ON= USE_SYSTEM_LIBGLEW USE_SYSTEM_LIBLUA
PORTDATA= data
PORTDOCS= AUTHORS.txt Changelog.txt Modelviewer.txt Quickstart.txt \
@@ -55,38 +49,31 @@ PORTDOCS= AUTHORS.txt Changelog.txt Modelviewer.txt Quickstart.txt \
SUB_FILES= pkg-message
-OPTIONS_DEFINE= DOCS EXTERNAL_GLEW EXTERNAL_LUA NOGPUJOBS PROFILER
-OPTIONS_DEFAULT= EXTERNAL_GLEW EXTERNAL_LUA
+OPTIONS_DEFINE= DOCS NOGPUJOBS PROFILER
-EXTERNAL_GLEW_DESC= Use external libglew from graphics/glew
-EXTERNAL_LUA_DESC= Use external liblua from lang/lua52
NOGPUJOBS_DESC= Disable EnableGPUJobs for config.ini by default
PROFILER_DESC= Build with internal profiler
-DOCS_SUB_LIST= QUICKSTART_PATH="${DOCSDIR}"
-DOCS_SUB_LIST_OFF= QUICKSTART_PATH="https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/${GH_TAGNAME}"
-EXTERNAL_GLEW_CMAKE_BOOL= USE_SYSTEM_LIBGLEW
-EXTERNAL_GLEW_VARS_OFF= LICENSE+=GLEW
-EXTERNAL_GLEW_USE= GL=glew
-EXTERNAL_LUA_CMAKE_BOOL= USE_SYSTEM_LIBLUA
-EXTERNAL_LUA_USES= lua:52
-PROFILER_CMAKE_BOOL= PROFILER_ENABLED
-
-post-patch: .SILENT
- ${REINPLACE_CMD} -e '/^include(FindGit/d ; \
+DOCS_SUB_LIST= QUICKSTART_PATH="${DOCSDIR}"
+DOCS_SUB_LIST_OFF= QUICKSTART_PATH="https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/${GH_TAGNAME}"
+PROFILER_CMAKE_BOOL= PROFILER_ENABLED
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^include(FindGit/d ; \
/TIMESTAMP PROJECT_VERSION/s|.*|set(PROJECT_VERSION "${GH_TAGNAME}")|' \
${WRKSRC}/CMakeLists.txt
-post-patch-NOGPUJOBS-on: .SILENT
+post-patch-NOGPUJOBS-on:
# Revert 41272a856d9072404efbfdb10f0e3c9e4f96bb4d commit, in case of
# GL_OUT_OF_MEMORY OpenGL error, when turning to gas giant planet
- ${REINPLACE_CMD} -e '/EnableGPUJobs/s|1|0|' \
+ @${REINPLACE_CMD} -e '/EnableGPUJobs/s|1|0|' \
${WRKSRC}/src/GameConfig.cpp
-post-patch-PROFILER-off: .SILENT
- ${REINPLACE_CMD} -i '.profiler' -e '/contrib\/profiler/d ; /profiler$$/d ; \
+post-patch-PROFILER-off:
+ @${REINPLACE_CMD} -i '.profiler' -e '/contrib\/profiler/d ; /profiler$$/d ; \
/target_link_libraries(savegamedump/s| profiler||' \
- ${WRKSRC}/CMakeLists.txt
+ ${WRKSRC}/CMakeLists.txt \
+ ${WRKSRC}/src/core/CMakeLists.txt
post-install:
.for f in modelcompiler savegamedump
@@ -95,6 +82,6 @@ post-install:
.endfor
post-install-DOCS-on:
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/games/pioneer/distinfo b/games/pioneer/distinfo
index 0a20d3ec501b..2a9e1e38f856 100644
--- a/games/pioneer/distinfo
+++ b/games/pioneer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1570621744
-SHA256 (pioneerspacesim-pioneer-0.0.20191009-20191009_GH0.tar.gz) = 54ffa99b5dad6334e75f21deab6e9afa48164d5ea474753c6ccda1a742c22cd6
-SIZE (pioneerspacesim-pioneer-0.0.20191009-20191009_GH0.tar.gz) = 360730481
+TIMESTAMP = 1634828737
+SHA256 (pioneerspacesim-pioneer-20210723_GH0.tar.gz) = 5f5d794d3095079e629980a6a3285d83b95b97e6c9b6058c73531cd06f8d082d
+SIZE (pioneerspacesim-pioneer-20210723_GH0.tar.gz) = 413969783
diff --git a/games/pioneer/files/patch-src_scenegraph_Serializer.h b/games/pioneer/files/patch-src_scenegraph_Serializer.h
deleted file mode 100644
index 2be72c87e15b..000000000000
--- a/games/pioneer/files/patch-src_scenegraph_Serializer.h
+++ /dev/null
@@ -1,24 +0,0 @@
-# pioneerLib.dir/src/CollMesh.cpp does not compile on i686 arch
-# https://github.com/pioneerspacesim/pioneer/issues/4691#issuecomment-540114463
-
---- src/scenegraph/Serializer.h.orig 2019-10-09 11:49:04 UTC
-+++ src/scenegraph/Serializer.h
-@@ -23,14 +23,14 @@
- // where possible, prefer serializing state information via JSON instead.
- namespace Serializer {
- static_assert((sizeof(Uint32) == 4 && alignof(Uint32) == 4), "Int32 is sized differently on this platform and will not serialize properly.");
-- static_assert((sizeof(Uint64) == 8 && alignof(Uint64) == 8), "Int64 is sized differently on this platform and will not serialize properly.");
-+ static_assert((sizeof(Uint64) == 8 && alignof(Uint64) <= 8), "Int64 is sized differently on this platform and will not serialize properly.");
- static_assert((sizeof(Color) == 4 && alignof(Color) == 1), "Color is padded differently on this platform and will not serialize properly.");
- static_assert((sizeof(vector2f) == 8 && alignof(vector2f) == 4), "Vector2f is padded differently on this platform and will not serialize properly.");
-- static_assert((sizeof(vector2d) == 16 && alignof(vector2d) == 8), "Vector2d is padded differently on this platform and will not serialize properly.");
-+ static_assert((sizeof(vector2d) == 16 && alignof(vector2d) <= 8), "Vector2d is padded differently on this platform and will not serialize properly.");
- static_assert((sizeof(vector3f) == 12 && alignof(vector3f) == 4), "Vector3f is padded differently on this platform and will not serialize properly.");
-- static_assert((sizeof(vector3d) == 24 && alignof(vector3d) == 8), "Vector3d is padded differently on this platform and will not serialize properly.");
-+ static_assert((sizeof(vector3d) == 24 && alignof(vector3d) <= 8), "Vector3d is padded differently on this platform and will not serialize properly.");
- static_assert((sizeof(Quaternionf) == 16 && alignof(Quaternionf) == 4), "Quaternionf is padded differently on this platform and will not serialize properly.");
-- static_assert((sizeof(Aabb) == 56 && alignof(Aabb) == 8), "Aabb is padded differently on this platform and will not serialize properly.");
-+ static_assert((sizeof(Aabb) == 56 && alignof(Aabb) <= 8), "Aabb is padded differently on this platform and will not serialize properly.");
-
- class Writer {
- public:
diff --git a/games/pioneer/pkg-descr b/games/pioneer/pkg-descr
index d8ac851884f6..9375dcc9a173 100644
--- a/games/pioneer/pkg-descr
+++ b/games/pioneer/pkg-descr
@@ -9,4 +9,4 @@ burn yourself to a crisp flying between binary star systems. You can try your
hand at piracy, make your fortune trading between systems, or do missions for
the various factions fighting for power, freedom or self-determination.
-WWW: http://pioneerspacesim.net
+WWW: https://pioneerspacesim.net/
diff --git a/games/pioneer/pkg-plist b/games/pioneer/pkg-plist
index 49fca64750b7..7001b6072aba 100644
--- a/games/pioneer/pkg-plist
+++ b/games/pioneer/pkg-plist
@@ -12,6 +12,6 @@ share/icons/hicolor/32x32/apps/net.pioneerspacesim.Pioneer.png
share/icons/hicolor/40x40/apps/net.pioneerspacesim.Pioneer.png
share/icons/hicolor/48x48/apps/net.pioneerspacesim.Pioneer.png
share/icons/hicolor/64x64/apps/net.pioneerspacesim.Pioneer.png
-@dir %%DATADIR%%/data/music/core/docked
-@dir %%DATADIR%%/data/music/core/near-planet
@dir %%DATADIR%%/data/music/core/undocked
+@dir %%DATADIR%%/data/music/core/near-planet
+@dir %%DATADIR%%/data/music/core/docked