aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-06-26 06:44:32 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-06-26 06:44:32 +0000
commit5330db110d320cf854d903428d8e9add129a4bf9 (patch)
treed34519c92edfe564abd84ce28a6e66f1255183ed
parent5c9dad462436f60113aef5adf87688609f675853 (diff)
downloadports-5330db110d320cf854d903428d8e9add129a4bf9.tar.gz
ports-5330db110d320cf854d903428d8e9add129a4bf9.zip
graphics/iec16022: Update to 0.3.1
- Use upstream release archive - Pacify portlint - Pacify portfmt/portclippy - Remove now obsolete patches PR: 264606
-rw-r--r--graphics/iec16022/Makefile18
-rw-r--r--graphics/iec16022/distinfo6
-rw-r--r--graphics/iec16022/files/patch-image.c11
3 files changed, 8 insertions, 27 deletions
diff --git a/graphics/iec16022/Makefile b/graphics/iec16022/Makefile
index 983fbfa9ece0..b2b284f7f955 100644
--- a/graphics/iec16022/Makefile
+++ b/graphics/iec16022/Makefile
@@ -1,9 +1,9 @@
# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
PORTNAME= iec16022
-PORTVERSION= 0.3.0
-DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.1
CATEGORIES= graphics
+MASTER_SITES= https://github.com/rdoeffinger/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Create 2D barcodes, also known as DataMatrix
@@ -12,20 +12,12 @@ LICENSE= GPLv2
LIB_DEPENDS= libpopt.so:devel/popt
-USE_GITHUB= yes
-GH_ACCOUNT= rdoeffinger
-
-GNU_CONFIGURE= yes
+USES= gmake libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
-USES= autoreconf gmake libtool pathfix pkgconfig
-
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -fPIC
+GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-post-patch:
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/iec16022.c \
- ${WRKSRC}/iec16022ecc200.c ${WRKSRC}/reedsol.c ${WRKSRC}/image.c
- @${REINPLACE_CMD} -e '/-Wno-unused-result/d' ${WRKSRC}/Makefile.am
+CFLAGS+= -fPIC
.include <bsd.port.mk>
diff --git a/graphics/iec16022/distinfo b/graphics/iec16022/distinfo
index 9a641eb76b54..365ad7308f75 100644
--- a/graphics/iec16022/distinfo
+++ b/graphics/iec16022/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499334495
-SHA256 (rdoeffinger-iec16022-v0.3.0_GH0.tar.gz) = e7fb5c1963587e4abcf5fa041d61d64a8c495e3c8d054f2b2b8dfa1882d14869
-SIZE (rdoeffinger-iec16022-v0.3.0_GH0.tar.gz) = 30847
+TIMESTAMP = 1654900509
+SHA256 (iec16022-0.3.1.tar.xz) = 5a83dbab402390695367cf1ea456140e51ff68171cbc0352ceba4be227715e07
+SIZE (iec16022-0.3.1.tar.xz) = 258276
diff --git a/graphics/iec16022/files/patch-image.c b/graphics/iec16022/files/patch-image.c
deleted file mode 100644
index 02870327a0a7..000000000000
--- a/graphics/iec16022/files/patch-image.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- image.c.orig 2017-07-05 23:29:56 UTC
-+++ image.c
-@@ -32,6 +32,8 @@ static inline unsigned htonl(unsigned i)
- #endif
- #include "image.h"
-
-+#include <unistd.h>
-+
- #define INTERLACE
- #define CLEAR
- #define USEZLIB