aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2023-05-01 15:52:33 +0000
committerThomas Zander <riggs@FreeBSD.org>2023-05-01 15:57:18 +0000
commit5348dafc8864fb387609b408a94568bb844a7ead (patch)
treec81a665f08a1efc5b0c7cc80cf2dfec67df98aef
parent2ff56353f782ba1269ea87577498ba314663f70a (diff)
multimedia/{mplayer|mencoder} Add missing CFLAGS for ffmpeg4 headers
Details: This was missed in the previous commit. Ensure the ffmpeg4 headers are included, not the ffmpeg 6 ones. PR: 270569 Reported by: diizzy Tested by: george@m5p.com, riggs
-rw-r--r--multimedia/mencoder/Makefile2
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/Makefile.common2
3 files changed, 4 insertions, 2 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index 7f6b82aa9894..f355d289e2ef 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia audio
MAINTAINER= riggs@FreeBSD.org
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 35ae0eca59ca..f9fce65ff92c 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia audio
MAINTAINER= riggs@FreeBSD.org
diff --git a/multimedia/mplayer/Makefile.common b/multimedia/mplayer/Makefile.common
index 7638a799c473..25522f9fd955 100644
--- a/multimedia/mplayer/Makefile.common
+++ b/multimedia/mplayer/Makefile.common
@@ -53,6 +53,8 @@ CONFIGURE_ARGS= --cc="${CC}" \
MAKE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
+CFLAGS+= -I${LOCALBASE}/ffmpeg4/include
+
common-post-patch:
@${REINPLACE_CMD} \
-e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|; \