aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2024-02-24 10:37:59 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-02-24 10:42:26 +0000
commit53cd4c7ad9ac8b27a455a933ebe2cd92a4f76e6d (patch)
treef94c8f158019dc22575e434f25c070c4a418b852
parent31bd6d3e7934ea7ccb12b36f113b0d3f64185396 (diff)
downloadports-53cd4c7ad9ac8b27a455a933ebe2cd92a4f76e6d.tar.gz
ports-53cd4c7ad9ac8b27a455a933ebe2cd92a4f76e6d.zip
graphics/glfw: Update to 3.4
- Switch PLATFORM single -> multi option since upstream supports both X11 and WAYLAND on by default (keeping X11 default). ChangeLog: https://github.com/glfw/glfw/releases/tag/3.4
-rw-r--r--graphics/glfw/Makefile34
-rw-r--r--graphics/glfw/distinfo6
2 files changed, 22 insertions, 18 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index a5fcadac768b..871d6429eb71 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -1,5 +1,5 @@
PORTNAME= glfw
-DISTVERSION= 3.3.10
+DISTVERSION= 3.4
CATEGORIES= graphics
MASTER_SITES= https://github.com/glfw/glfw/releases/download/${DISTVERSION}/
@@ -14,31 +14,34 @@ USES= cmake:insource localbase zip
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= GLFW_BUILD_DOCS
CONFLICTS_INSTALL= glfw2
-PLIST_SUB= MAJVER=${DISTVERSION:R:R} \
- VERSION=${DISTVERSION:R}
+PLIST_SUB= MAJVER=${DISTVERSION:R} \
+ VERSION=${DISTVERSION}
PORTDOCS= *
PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS EXAMPLES
-OPTIONS_DEFAULT= X11
-OPTIONS_SINGLE= PLATFORM
-OPTIONS_SINGLE_PLATFORM= WAYLAND X11
-PLATFORM_DESC= Window creation platform
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFAULT= X11
+OPTIONS_MULTI= PLATFORM
+OPTIONS_MULTI_PLATFORM= WAYLAND X11
+PLATFORM_DESC= Window creation platform
+
+EXAMPLES_CMAKE_BOOL= GLFW_BUILD_EXAMPLES GLFW_BUILD_TESTS
WAYLAND_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
libxkbcommon>0:x11/libxkbcommon \
wayland-protocols>=0:graphics/wayland-protocols
-WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
- libwayland-egl.so:graphics/wayland
+WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim
WAYLAND_USES= kde:5 pkgconfig
WAYLAND_USE= KDE=ecm
-WAYLAND_CMAKE_BOOL= GLFW_USE_WAYLAND
+WAYLAND_CMAKE_BOOL= GLFW_BUILD_WAYLAND
X11_USES= xorg
X11_USE= XORG=x11,xcursor,xi,xinerama,xrandr,xxf86vm
+X11_CMAKE_BOOL= GLFW_BUILD_X11
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/docs/html/search
@@ -51,12 +54,13 @@ do-install-DOCS-on:
do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/tests
cd ${WRKSRC}/examples && ${INSTALL_PROGRAM} \
- boing gears heightmap particles simple splitview wave \
+ boing gears heightmap offscreen particles sharing splitview \
+ triangle-opengl triangle-opengles wave windows \
${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/tests && ${INSTALL_PROGRAM} \
- clipboard cursor empty events gamma glfwinfo iconify \
- joysticks monitors msaa reopen tearing \
- threads title windows \
+ allocator clipboard cursor empty events gamma glfwinfo icon \
+ iconify inputlag joysticks monitors msaa reopen tearing threads \
+ timeout title triangle-vulkan window \
${STAGEDIR}${EXAMPLESDIR}/tests
.include <bsd.port.mk>
diff --git a/graphics/glfw/distinfo b/graphics/glfw/distinfo
index f84fb88c5fb9..4f0ac8f18c37 100644
--- a/graphics/glfw/distinfo
+++ b/graphics/glfw/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1708588237
-SHA256 (glfw-3.3.10.zip) = e8433ef817f7b8199aab4868390639701b6b26f535ec1a6598bcf82019d1bdb8
-SIZE (glfw-3.3.10.zip) = 1467690
+TIMESTAMP = 1708762289
+SHA256 (glfw-3.4.zip) = b5ec004b2712fd08e8861dc271428f048775200a2df719ccf575143ba749a3e9
+SIZE (glfw-3.4.zip) = 1653725