aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-09-10 22:54:03 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-09-10 22:54:03 +0000
commit5402e0dd8685d3badfc8ca20610434d54778dccd (patch)
treec78970ca2c2943c4e8f3350a0af81434ec5b7ce5
parent05b638699cfaf5a3d12d958f6f50f802d1e308de (diff)
downloadports-5402e0dd8685d3badfc8ca20610434d54778dccd.tar.gz
ports-5402e0dd8685d3badfc8ca20610434d54778dccd.zip
games/SRB2: 3D Sonic the Hedgehog fangame
Sonic Robo Blast 2 is a 3D open-source Sonic the Hedgehog fangame built using a modified version of the Doom Legacy port of Doom. SRB2 is closely inspired by the original Sonic games from the Sega Genesis, and attempts to recreate the design in 3D. While SRB2 isn't fully completed, it already features tons of levels, enemies, speed, and quite a lot of the fun that the original Sonic games provided. WWW: https://www.srb2.org/
-rw-r--r--games/Makefile1
-rw-r--r--games/SRB2/Makefile46
-rw-r--r--games/SRB2/distinfo5
-rw-r--r--games/SRB2/pkg-descr8
-rw-r--r--games/SRB2/pkg-plist6
5 files changed, 66 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 74ccd9d71f34..90865e6d006d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -18,6 +18,7 @@
SUBDIR += OpenDiablo2
SUBDIR += OpenLara
SUBDIR += OpenTomb
+ SUBDIR += SRB2
SUBDIR += abbayedesmorts
SUBDIR += abe
SUBDIR += abstreet
diff --git a/games/SRB2/Makefile b/games/SRB2/Makefile
new file mode 100644
index 000000000000..6a653decd012
--- /dev/null
+++ b/games/SRB2/Makefile
@@ -0,0 +1,46 @@
+PORTNAME= SRB2
+PORTVERSION= 2.2.9
+DISTVERSIONPREFIX= SRB2_release_
+CATEGORIES= games
+MASTER_SITES= https://github.com/STJr/SRB2/releases/download/SRB2_release_${PORTVERSION}/:assets
+DISTFILES+= SRB2-v${PORTVERSION:C/\.//g}-Full.zip:assets
+EXTRACT_ONLY= STJr-SRB2-SRB2_release_${PORTVERSION}_GH0.tar.gz
+
+MAINTAINER= pkubaj@FreeBSD.org
+COMMENT= 3D Sonic the Hedgehog fangame
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libgme.so:audio/libgme \
+ libopenmpt.so:audio/libopenmpt \
+ libpng.so:graphics/png
+
+USES= cmake sdl
+
+USE_GITHUB= yes
+GH_ACCOUNT= STJr
+
+USE_SDL= mixer2 sdl2
+
+CXXFLAGS+= -DDEFAULTWADLOCATION5=${DATADIR}
+LDFLAGS+= -lexecinfo -lm
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/assets/installer
+ @cd ${WRKSRC}/assets/installer && ${UNZIP_NATIVE_CMD} ${DISTDIR}/SRB2-v229-Full.zip srb2.pk3
+ @cd ${WRKSRC}/assets/installer && ${UNZIP_NATIVE_CMD} ${DISTDIR}/SRB2-v229-Full.zip player.dta
+ @cd ${WRKSRC}/assets/installer && ${UNZIP_NATIVE_CMD} ${DISTDIR}/SRB2-v229-Full.zip zones.pk3
+ @cd ${WRKSRC}/assets/installer && ${UNZIP_NATIVE_CMD} ${DISTDIR}/SRB2-v229-Full.zip patch.pk3
+
+post-install:
+ @${MKDIR} ${STAGEDIR}/${DATADIR}
+ @${MV} ${STAGEDIR}/${PREFIX}/srb2.pk3 ${STAGEDIR}/${DATADIR}
+ @${MV} ${STAGEDIR}/${PREFIX}/player.dta ${STAGEDIR}/${DATADIR}
+ @${MV} ${STAGEDIR}/${PREFIX}/zones.pk3 ${STAGEDIR}/${DATADIR}
+ @${MV} ${STAGEDIR}/${PREFIX}/patch.pk3 ${STAGEDIR}/${DATADIR}
+ @${MV} ${STAGEDIR}/${PREFIX}/srb2 ${STAGEDIR}/${PREFIX}/bin
+ @${MV} ${STAGEDIR}/${PREFIX}/srb2-${PORTVERSION} ${STAGEDIR}/${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/SRB2/distinfo b/games/SRB2/distinfo
new file mode 100644
index 000000000000..788670fa6553
--- /dev/null
+++ b/games/SRB2/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1631304306
+SHA256 (SRB2-v229-Full.zip) = 48e644604bed81b5ce6b12ef23a2f4042d0118d0ba70f18c534dfe86ebe6f37d
+SIZE (SRB2-v229-Full.zip) = 195309133
+SHA256 (STJr-SRB2-SRB2_release_2.2.9_GH0.tar.gz) = 5f7eeb08e90323e28cdcb02ad25c904eef25ce75316720609b995a1e4ffd154a
+SIZE (STJr-SRB2-SRB2_release_2.2.9_GH0.tar.gz) = 59265756
diff --git a/games/SRB2/pkg-descr b/games/SRB2/pkg-descr
new file mode 100644
index 000000000000..68b4e87dd092
--- /dev/null
+++ b/games/SRB2/pkg-descr
@@ -0,0 +1,8 @@
+Sonic Robo Blast 2 is a 3D open-source Sonic the Hedgehog fangame built using
+a modified version of the Doom Legacy port of Doom. SRB2 is closely inspired by
+the original Sonic games from the Sega Genesis, and attempts to recreate
+the design in 3D. While SRB2 isn't fully completed, it already features
+tons of levels, enemies, speed, and quite a lot of the fun that the original
+Sonic games provided.
+
+WWW: https://www.srb2.org/
diff --git a/games/SRB2/pkg-plist b/games/SRB2/pkg-plist
new file mode 100644
index 000000000000..384bfd0c0cf8
--- /dev/null
+++ b/games/SRB2/pkg-plist
@@ -0,0 +1,6 @@
+bin/srb2
+bin/srb2-2.2.9
+%%DATADIR%%/patch.pk3
+%%DATADIR%%/player.dta
+%%DATADIR%%/srb2.pk3
+%%DATADIR%%/zones.pk3