aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-10 14:46:10 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-10 14:47:37 +0000
commit5407477bf71d072b0387a53ffd284759b2e5e8d9 (patch)
treeddd0a1b78370789683460cddd7fdaad953b92b71
parent1e3bd4139d3d43690148d71046073810503ebcad (diff)
downloadports-5407477bf71d072b0387a53ffd284759b2e5e8d9.tar.gz
ports-5407477bf71d072b0387a53ffd284759b2e5e8d9.zip
graphics/p5-ming: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
-rw-r--r--graphics/p5-ming/Makefile4
-rw-r--r--graphics/p5-ming/files/patch-configure.in13
2 files changed, 16 insertions, 1 deletions
diff --git a/graphics/p5-ming/Makefile b/graphics/p5-ming/Makefile
index 7214e5e5e84d..4163403a6b47 100644
--- a/graphics/p5-ming/Makefile
+++ b/graphics/p5-ming/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libming.so:graphics/ming \
libpng.so:graphics/png
-USES= autoreconf bison gmake libtool localbase perl5 shebangfix
+USES= autoreconf bison gmake libtool localbase perl5 pkgconfig shebangfix
CONFIGURE_ARGS= --enable-perl
GNU_CONFIGURE= yes
@@ -38,6 +38,8 @@ SHEBANG_FILES= perl_ext/examples/*.cgi
OPTIONS_DEFINE= EXAMPLES
+BINARY_ALIAS= freetype-config=true
+
post-patch:
@${REINPLACE_CMD} -e '/ming_is_compiled()/ s|^|#|; /LIBS/d' ${WRKSRC}/perl_ext/Makefile.PL
@${REINPLACE_CMD} -e 's|\.3pm|.3|g' ${WRKSRC}/perl_ext/Makefile.PL ${WRKSRC}/perl_ext/mkdoc
diff --git a/graphics/p5-ming/files/patch-configure.in b/graphics/p5-ming/files/patch-configure.in
new file mode 100644
index 000000000000..0c3332359d41
--- /dev/null
+++ b/graphics/p5-ming/files/patch-configure.in
@@ -0,0 +1,13 @@
+--- configure.in.orig 2021-08-10 14:43:41 UTC
++++ configure.in
+@@ -272,8 +272,8 @@ if test "$freetype_support" = "yes"; then
+ ft_config="$freetype_config"
+ fi
+
+- FREETYPE_CFLAGS="`$ft_config --cflags`"
+- FREETYPE_LIBS="`$ft_config --libs`"
++ FREETYPE_CFLAGS="`pkg-config freetype2 --cflags`"
++ FREETYPE_LIBS="`pkg-config freetype2 --libs`"
+
+ AC_SUBST(FREETYPE_LIBS)
+ AC_SUBST(FREETYPE_CFLAGS)