aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2024-06-20 04:24:47 +0000
committerRomain Tartière <romain@FreeBSD.org>2024-06-20 04:37:30 +0000
commit54077862aca25c61abf8bdf39956966b7b278d16 (patch)
tree067963650549e991c24d533805b19b6bccadd815
parentdd4acbc5107bcde3cda06c8885ea7ada9216cb30 (diff)
devel/rubygem-wisper2: New port
This is a copy of devel/rubygem-wisper but with which tracks version 2.x.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-wisper2/Makefile20
-rw-r--r--devel/rubygem-wisper2/distinfo3
-rw-r--r--devel/rubygem-wisper2/pkg-descr9
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 567475ca9544..d3ef97a20da3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7785,6 +7785,7 @@
SUBDIR += rubygem-will_paginate
SUBDIR += rubygem-windows_error
SUBDIR += rubygem-wisper
+ SUBDIR += rubygem-wisper2
SUBDIR += rubygem-with_advisory_lock61
SUBDIR += rubygem-with_env
SUBDIR += rubygem-wmi-lite
diff --git a/devel/rubygem-wisper2/Makefile b/devel/rubygem-wisper2/Makefile
new file mode 100644
index 000000000000..a291ca3efe42
--- /dev/null
+++ b/devel/rubygem-wisper2/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= wisper
+PORTVERSION= 2.0.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 2
+
+MAINTAINER= romain@FreeBSD.org
+COMMENT= Library for Ruby objects with Publish-Subscribe capabilities
+WWW= https://github.com/krisleech/wisper
+
+LICENSE= MIT
+
+USES= gem
+
+NO_ARCH= yes
+
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/bin/console ${STAGEDIR}${PREFIX}/bin/setup
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-wisper2/distinfo b/devel/rubygem-wisper2/distinfo
new file mode 100644
index 000000000000..e45248ff9d61
--- /dev/null
+++ b/devel/rubygem-wisper2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1718856355
+SHA256 (rubygem/wisper-2.0.1.gem) = ce17bc5c3a166f241a2e6613848b025c8146fce2defba505920c1d1f3f88fae6
+SIZE (rubygem/wisper-2.0.1.gem) = 26112
diff --git a/devel/rubygem-wisper2/pkg-descr b/devel/rubygem-wisper2/pkg-descr
new file mode 100644
index 000000000000..f982c3898a8c
--- /dev/null
+++ b/devel/rubygem-wisper2/pkg-descr
@@ -0,0 +1,9 @@
+Wisper is a micro library providing Ruby objects with Publish-Subscribe
+capabilities.
+
+It supports:
+- Decouple core business logic from external concerns in Hexagonal style
+ architectures.
+- Use as an alternative to ActiveRecord callbacks and Observers in Rails apps.
+- Connect objects based on context without permanence.
+- Publish events synchronously or asynchronously.