aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2024-08-20 12:52:47 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2024-09-04 14:31:01 +0000
commit546dc44194b4f9e7c62d71e140d8279243c7ec38 (patch)
tree80f8d67c4d52531a6f93a02eebd03b4385631d41
parent7efae4b7a9e888020765ce3477f1239fe0a471bd (diff)
downloadports-546dc44194b4f9e7c62d71e140d8279243c7ec38.tar.gz
ports-546dc44194b4f9e7c62d71e140d8279243c7ec38.zip
lang/gcc13: Update to 13.3.0
Changes: https://gcc.gnu.org/gcc-13/changes.html#13.3 PR: 281091 Tested by: exp-run (antoine)
-rw-r--r--lang/gcc13/Makefile3
-rw-r--r--lang/gcc13/distinfo6
-rw-r--r--lang/gcc13/files/patch-gcc_configure22
-rw-r--r--lang/gcc13/files/patch-gcc_system.h42
-rw-r--r--lang/gcc13/files/patch-libcc1_libcc1plugin.cc19
-rw-r--r--lang/gcc13/files/patch-libcc1_libcp1plugin.cc19
6 files changed, 26 insertions, 85 deletions
diff --git a/lang/gcc13/Makefile b/lang/gcc13/Makefile
index 3c0a3841de61..0f51ab5ac4d6 100644
--- a/lang/gcc13/Makefile
+++ b/lang/gcc13/Makefile
@@ -1,6 +1,5 @@
PORTNAME= gcc
-PORTVERSION= 13.2.0
-PORTREVISION= 4
+PORTVERSION= 13.3.0
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}
diff --git a/lang/gcc13/distinfo b/lang/gcc13/distinfo
index e4267f08bad6..e9112970e8fe 100644
--- a/lang/gcc13/distinfo
+++ b/lang/gcc13/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1692015565
-SHA256 (gcc-13.2.0.tar.xz) = e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da
-SIZE (gcc-13.2.0.tar.xz) = 87858592
+TIMESTAMP = 1724158317
+SHA256 (gcc-13.3.0.tar.xz) = 0845e9621c9543a13f484e94584a49ffc0129970e9914624235fc1d061a0c083
+SIZE (gcc-13.3.0.tar.xz) = 87909952
diff --git a/lang/gcc13/files/patch-gcc_configure b/lang/gcc13/files/patch-gcc_configure
new file mode 100644
index 000000000000..cc60593ba6f7
--- /dev/null
+++ b/lang/gcc13/files/patch-gcc_configure
@@ -0,0 +1,22 @@
+Enable support for .init_array and .fini_array, which FreeBSD supports
+since commit 83aa9cc00c2d83d05a0efe7a1496d8aab4a153bb in the src
+repository.
+
+There __FreeBSD_version is 1000009, so we start enabling the support
+from __FreeBSD_version == 1000010.
+--- gcc/configure.orig 2023-05-11 22:33:34 UTC
++++ gcc/configure
+@@ -24214,6 +24214,13 @@ EOF
+ #else
+ # if defined __sun__ && defined __svr4__
+ /* Solaris ld.so.1 supports .init_array/.fini_array since Solaris 8. */
++# elif defined __FreeBSD__
++# include <sys/param.h>
++# if __FreeBSD_version >= 1000010
++ /* FreeBSD supports .init_array/.fini_array since FreeBSD 10. */
++# else
++# error The C library not known to support .init_array/.fini_array
++# endif
+ # else
+ # error The C library not known to support .init_array/.fini_array
+ # endif
diff --git a/lang/gcc13/files/patch-gcc_system.h b/lang/gcc13/files/patch-gcc_system.h
deleted file mode 100644
index d31fb72931b5..000000000000
--- a/lang/gcc13/files/patch-gcc_system.h
+++ /dev/null
@@ -1,42 +0,0 @@
---- gcc/system.h.orig 2023-04-26 07:09:40 UTC
-+++ gcc/system.h
-@@ -203,19 +203,6 @@ extern int fprintf_unlocked (FILE *, const char *, ...
- #endif
- #endif
-
--/* There are an extraordinary number of issues with <ctype.h>.
-- The last straw is that it varies with the locale. Use libiberty's
-- replacement instead. */
--#include "safe-ctype.h"
--
--#include <sys/types.h>
--
--#include <errno.h>
--
--#if !defined (errno) && defined (HAVE_DECL_ERRNO) && !HAVE_DECL_ERRNO
--extern int errno;
--#endif
--
- #ifdef __cplusplus
- #if defined (INCLUDE_ALGORITHM) || !defined (HAVE_SWAP_IN_UTILITY)
- # include <algorithm>
-@@ -243,6 +230,19 @@ extern int errno;
- # include <new>
- # include <utility>
- # include <type_traits>
-+#endif
-+
-+/* There are an extraordinary number of issues with <ctype.h>.
-+ The last straw is that it varies with the locale. Use libiberty's
-+ replacement instead. */
-+#include "safe-ctype.h"
-+
-+#include <sys/types.h>
-+
-+#include <errno.h>
-+
-+#if !defined (errno) && defined (HAVE_DECL_ERRNO) && !HAVE_DECL_ERRNO
-+extern int errno;
- #endif
-
- /* Some of glibc's string inlines cause warnings. Plus we'd rather
diff --git a/lang/gcc13/files/patch-libcc1_libcc1plugin.cc b/lang/gcc13/files/patch-libcc1_libcc1plugin.cc
deleted file mode 100644
index d54adddb021b..000000000000
--- a/lang/gcc13/files/patch-libcc1_libcc1plugin.cc
+++ /dev/null
@@ -1,19 +0,0 @@
---- libcc1/libcc1plugin.cc.orig 2023-07-27 08:13:07 UTC
-+++ libcc1/libcc1plugin.cc
-@@ -32,6 +32,7 @@
- #undef PACKAGE_VERSION
-
- #define INCLUDE_MEMORY
-+#define INCLUDE_VECTOR
- #include "gcc-plugin.h"
- #include "system.h"
- #include "coretypes.h"
-@@ -68,8 +69,6 @@
- #include "rpc.hh"
- #include "gcc-c-interface.h"
- #include "context.hh"
--
--#include <vector>
-
- using namespace cc1_plugin;
-
diff --git a/lang/gcc13/files/patch-libcc1_libcp1plugin.cc b/lang/gcc13/files/patch-libcc1_libcp1plugin.cc
deleted file mode 100644
index 0f3d2d161404..000000000000
--- a/lang/gcc13/files/patch-libcc1_libcp1plugin.cc
+++ /dev/null
@@ -1,19 +0,0 @@
---- libcc1/libcp1plugin.cc.orig 2023-07-27 08:13:07 UTC
-+++ libcc1/libcp1plugin.cc
-@@ -33,6 +33,7 @@
- #undef PACKAGE_VERSION
-
- #define INCLUDE_MEMORY
-+#define INCLUDE_VECTOR
- #include "gcc-plugin.h"
- #include "system.h"
- #include "coretypes.h"
-@@ -70,8 +71,6 @@
- #include "marshall-cp.hh"
- #include "rpc.hh"
- #include "context.hh"
--
--#include <vector>
-
- using namespace cc1_plugin;
-