aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2023-01-23 20:19:23 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2023-01-23 21:41:08 +0000
commit54a7681acb21dc2e1254d2f0e60772dce3f4ebbe (patch)
treeecba73112bf354204a4507d6cb372e872eed8cea
parent647b0f6f8f0d9103a15a361f023bc2235c6fe65a (diff)
downloadports-54a7681acb21dc2e1254d2f0e60772dce3f4ebbe.tar.gz
ports-54a7681acb21dc2e1254d2f0e60772dce3f4ebbe.zip
net-im/neochat: (and quaternion) update for libquotient 0.7
Quaternion is broken. Although it's the same upstream people, there is no release compatible with 0.7 yet. NeoChat does like the newer library. Since Quaternion is more a proof-of-something client than a shiny tool, mark it broken for now -- there is some upstream work to get it to work.
-rw-r--r--net-im/neochat/Makefile2
-rw-r--r--net-im/quaternion/Makefile9
-rw-r--r--net-im/quaternion/distinfo6
3 files changed, 9 insertions, 8 deletions
diff --git a/net-im/neochat/Makefile b/net-im/neochat/Makefile
index 7c7aa741e8b3..d2efc206f4b9 100644
--- a/net-im/neochat/Makefile
+++ b/net-im/neochat/Makefile
@@ -1,6 +1,6 @@
PORTNAME= neochat
DISTVERSION= 22.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= KDE/stable/plasma-mobile/${DISTVERSION}
diff --git a/net-im/quaternion/Makefile b/net-im/quaternion/Makefile
index 7c8f8535b938..195b4211efb3 100644
--- a/net-im/quaternion/Makefile
+++ b/net-im/quaternion/Makefile
@@ -1,18 +1,19 @@
PORTNAME= Quaternion
-DISTVERSION= 0.0.95-beta3
-PORTREVISION= 4
+DISTVERSION= 0.0.95.1
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
COMMENT= Matrix IM client based on Qt technologies
-WWW= https://github.com/QMatrixClient/Quaternion
+WWW= https://github.com/quotient-im/Quaternion/
+
+BROKEN= No upstream release compatible with libquotient 0.7 yet
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libqt5keychain.so:security/qtkeychain@qt5 \
libsecret-1.so:security/libsecret
-BUILD_DEPENDS= libquotient>=0.6.11:net-im/libquotient
+BUILD_DEPENDS= libquotient>=0.7:net-im/libquotient
# Quotient is a static lib, doesn't need to be in RUN_DEPENDS
USES= cmake compiler:c++17-lang gettext-runtime gnome \
diff --git a/net-im/quaternion/distinfo b/net-im/quaternion/distinfo
index a196c9337bc5..2d654c352d3d 100644
--- a/net-im/quaternion/distinfo
+++ b/net-im/quaternion/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1612052128
-SHA256 (quotient-im-Quaternion-0.0.95-beta3_GH0.tar.gz) = 47ae076ce2a23b396e764119066697dad6171d36447211c52bdb0e9cdbab1c75
-SIZE (quotient-im-Quaternion-0.0.95-beta3_GH0.tar.gz) = 1160612
+TIMESTAMP = 1674504277
+SHA256 (quotient-im-Quaternion-0.0.95.1_GH0.tar.gz) = 69f034241dddc8d9436a895bb76b022e492e61e2f49d9a80ed8d79ab12b63a0e
+SIZE (quotient-im-Quaternion-0.0.95.1_GH0.tar.gz) = 1224589