aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-01 00:43:51 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-01 00:43:51 +0000
commit54ce503f0ae9a084b169e9ee24347b250db1fc06 (patch)
tree47e0d87829b4efba26bb6e6096806b9ba1d16f52
parent726250273be646cc4144ea97ed9a60e6ecf40404 (diff)
downloadports-54ce503f0ae9a084b169e9ee24347b250db1fc06.tar.gz
ports-54ce503f0ae9a084b169e9ee24347b250db1fc06.zip
databases/firebird30-*: Fix consumers build
After firebird25-* was removed from the tree firebird30-* bacem the new default. And some consumers of firebird started failing to build with the error "/usr/local/include/ibase.h:6:10: fatal error: '../jrd/ibase.h' file not found". In previous the src headers files were installed which were not sanitized and required other header files from the source tree. This patch properly installs the sanitized header files and fixes the consumer builds. While I am here fix the patches to be makepatch compatible. Approved by: portmgr(just-fix-it)
-rw-r--r--databases/firebird30-server/Makefile12
-rw-r--r--databases/firebird30-server/files/patch-builds_install_misc_firebird.conf.in5
-rw-r--r--databases/firebird30-server/files/patch-builds_posix_Makefile.in (renamed from databases/firebird30-server/files/patch-builds-posix_Makefile.in)19
-rw-r--r--databases/firebird30-server/files/patch-builds_posix_Makefile.in.plugins__examples (renamed from databases/firebird30-server/files/patch-builds-posix_Makefile.in.plugins_examples)3
-rw-r--r--databases/firebird30-server/files/patch-builds_posix_empty.vers3
-rw-r--r--databases/firebird30-server/files/patch-builds_posix_make.defaults16
-rw-r--r--databases/firebird30-server/files/patch-builds_posix_prefix.freebsd (renamed from databases/firebird30-server/files/patch-builds-posix-prefix.freebsd)3
-rw-r--r--databases/firebird30-server/files/patch-builds_posix_prefix.freebsd__amd64 (renamed from databases/firebird30-server/files/patch-builds-posix-prefix.freebsd_amd64)3
-rw-r--r--databases/firebird30-server/files/patch-extern_btyacc_Makefile3
-rw-r--r--databases/firebird30-server/files/patch-extern_cloop_Makefile5
-rw-r--r--databases/firebird30-server/files/patch-src_common_os_posix_SyncSignals.cpp3
-rw-r--r--databases/firebird30-server/files/patch-src_jrd_os_posix_unix.cpp (renamed from databases/firebird30-server/files/patch-src-jrd-os-posix_unix.cpp)6
-rw-r--r--databases/firebird30-server/files/patch-src_remote_inet.cpp7
13 files changed, 33 insertions, 55 deletions
diff --git a/databases/firebird30-server/Makefile b/databases/firebird30-server/Makefile
index a9765cd653cf..c8a7f2d0e647 100644
--- a/databases/firebird30-server/Makefile
+++ b/databases/firebird30-server/Makefile
@@ -1,6 +1,6 @@
PORTNAME= firebird
PORTVERSION= 3.0.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= databases
MASTER_SITES= https://github.com/FirebirdSQL/${PORTNAME}/releases/download/v${PORTVERSION}/
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}-server
@@ -96,7 +96,7 @@ CONFIGURE_ENV+= ac_cv_lib_edit_readline="yes"
USE_LDCONFIG= yes
CLIENT_BIN= gpre isql-fb qli
-CLIENT_HEADER= extlib/ib_util.h include/ibase.h include/iberror.h yvalve/perf.h
+CLIENT_HEADER= ib_util.h ibase.h iberror.h perf.h
OPTIONS_DEFINE= DOCS
@@ -120,7 +120,7 @@ CFLAGS+= -DAMD64
USERS= ${PORTNAME}
GROUPS= ${USERS}
-MAKE_ENV+= IsServer=Y
+#MAKE_ENV+= IsServer=Y
.endif
post-patch:
@@ -177,12 +177,12 @@ do-install:
${LN} -fs libfbclient.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfbclient.so
@${MKDIR} ${STAGEDIR}${PREFIX}/include/firebird
- ${INSTALL_DATA} ${CLIENT_HEADER:S!^!${WRKSRC}/src/!} ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${CLIENT_HEADER:S!^!${WRKSRC}/gen/Release/firebird/include/!} ${STAGEDIR}${PREFIX}/include
- @cd ${WRKSRC}/src/include/firebird && \
+ @cd ${WRKSRC}/gen/Release/firebird/include/firebird && \
${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${PREFIX}/include/firebird/{}" \;
- @cd ${WRKSRC}/src/include/firebird && \
+ @cd ${WRKSRC}/gen/Release/firebird/include/firebird && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${PREFIX}/include/firebird/{}" \;
@${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/databases/firebird30-server/files/patch-builds_install_misc_firebird.conf.in b/databases/firebird30-server/files/patch-builds_install_misc_firebird.conf.in
index 953e438de696..ac685450a0b5 100644
--- a/databases/firebird30-server/files/patch-builds_install_misc_firebird.conf.in
+++ b/databases/firebird30-server/files/patch-builds_install_misc_firebird.conf.in
@@ -1,12 +1,11 @@
---- builds/install/misc/firebird.conf.in.orig 2020-10-12 00:02:22 UTC
+--- builds/install/misc/firebird.conf.in.orig 2022-06-07 08:18:52 UTC
+++ builds/install/misc/firebird.conf.in
@@ -189,7 +189,7 @@
#
# Type: string (special format)
#
-#UdfAccess = Restrict UDF
-+UdfAccess = Restrict %%PREFIX%%/libexec/firebird/udf
++UdfAccess = Restrict /usr/local/libexec/firebird/udf
# ----------------------------
-
diff --git a/databases/firebird30-server/files/patch-builds-posix_Makefile.in b/databases/firebird30-server/files/patch-builds_posix_Makefile.in
index 3957c91179a9..8092243be081 100644
--- a/databases/firebird30-server/files/patch-builds-posix_Makefile.in
+++ b/databases/firebird30-server/files/patch-builds_posix_Makefile.in
@@ -1,6 +1,6 @@
---- builds/posix/Makefile.in 2020-10-20 03:40:05.000000000 -0500
-+++ builds/posix/Makefile.in 2021-06-25 00:25:25.389776000 -0500
-@@ -186,16 +186,18 @@
+--- builds/posix/Makefile.in.orig 2022-06-07 08:18:52 UTC
++++ builds/posix/Makefile.in
+@@ -191,16 +191,16 @@ master_process:
$(MAKE) preliminaryCheck
$(MAKE) boot
$(MAKE) yvalve
@@ -10,10 +10,8 @@
$(MAKE) ids
endif
- $(MAKE) engine
-+ifeq ($(IsServer), Y)
$(MAKE) fbintl
$(MAKE) utilities
-+endif
# Now having ready such useful tools as gbak and isql, we may restore / create
# required databases and switch to full-featured gpre
- $(MAKE) gpre
@@ -21,14 +19,3 @@
# Pay attention - after build force gpre_current to point to gpre
# even if gpre itself was not rebuilt
-$(RM) $(GPRE_CURRENT)
-@@ -204,8 +206,10 @@
- # In developer mode we must regenerate various files in include/gen
- $(MAKE) codes
- endif
-+ifeq ($(IsServer), Y)
- $(MAKE) plugins
- $(MAKE) examples
-+endif
- $(MAKE) rest
-
-
diff --git a/databases/firebird30-server/files/patch-builds-posix_Makefile.in.plugins_examples b/databases/firebird30-server/files/patch-builds_posix_Makefile.in.plugins__examples
index 4a58a2a2fe22..a3cd068de57b 100644
--- a/databases/firebird30-server/files/patch-builds-posix_Makefile.in.plugins_examples
+++ b/databases/firebird30-server/files/patch-builds_posix_Makefile.in.plugins__examples
@@ -1,4 +1,4 @@
---- builds/posix/Makefile.in.plugins_examples.orig 2021-03-27 11:14:37 UTC
+--- builds/posix/Makefile.in.plugins_examples.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/Makefile.in.plugins_examples
@@ -99,7 +99,7 @@ AllObjects += $(CA_Objects)
crypt_app: $(CRYPT_APP)
@@ -9,4 +9,3 @@
include $(ROOT)/gen/make.shared.targets
-
diff --git a/databases/firebird30-server/files/patch-builds_posix_empty.vers b/databases/firebird30-server/files/patch-builds_posix_empty.vers
index 598107119be9..8ca57ab7e436 100644
--- a/databases/firebird30-server/files/patch-builds_posix_empty.vers
+++ b/databases/firebird30-server/files/patch-builds_posix_empty.vers
@@ -1,4 +1,4 @@
---- builds/posix/empty.vers.orig 2020-10-12 00:02:22 UTC
+--- builds/posix/empty.vers.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/empty.vers
@@ -21,3 +21,5 @@
# Contributor(s): ______________________________________.
@@ -6,4 +6,3 @@
main
+__progname
+environ
-
diff --git a/databases/firebird30-server/files/patch-builds_posix_make.defaults b/databases/firebird30-server/files/patch-builds_posix_make.defaults
index b30b259a6848..79982d81f157 100644
--- a/databases/firebird30-server/files/patch-builds_posix_make.defaults
+++ b/databases/firebird30-server/files/patch-builds_posix_make.defaults
@@ -1,6 +1,6 @@
---- builds/posix/make.defaults 2020-10-20 03:40:05.000000000 -0500
-+++ builds/posix/make.defaults 2021-06-25 00:23:49.718147000 -0500
-@@ -134,7 +134,7 @@
+--- builds/posix/make.defaults.orig 2022-06-07 08:18:52 UTC
++++ builds/posix/make.defaults
+@@ -134,7 +134,7 @@ CAS_OPTIONS=@CAS_OPTIONS@
MATHLIB=@MATHLIB@
# switch to make sed edit files inplace
@@ -9,7 +9,7 @@
# Default programs and tools to be used in the build process
-@@ -144,7 +144,7 @@
+@@ -144,7 +144,7 @@ RM_R= rm -rf
CHMOD= chmod
CHMOD_6= chmod 666
CHMOD_7= chmod 777
@@ -18,7 +18,7 @@
MV= mv -f
TOUCH= touch
CP= cp
-@@ -219,7 +219,7 @@
+@@ -219,7 +219,7 @@ vpath %.dll $(LIB)
#LibraryFileName=libfbclient
LibraryFileName=libfbclient
LibraryFullName=$(LibraryFileName).${SHRLIB_EXT}.${FirebirdVersion}
@@ -27,7 +27,7 @@
LibraryBaseName=$(LibraryFileName).${SHRLIB_EXT}
LIBFIREBIRD_FULLNAME = $(LIB)/$(LibraryFullName)
-@@ -240,7 +240,7 @@
+@@ -240,7 +240,7 @@ LIBFBINTL_SO = $(FB_BUILD)/intl/$(LIB_PREFIX)fbintl.$(
ifeq ($(EDITLINE_FLG),Y)
ifeq ($(STD_EDITLINE), true)
@@ -36,7 +36,7 @@
else
LIBEDITLINE := $(LIB)/libedit.a
endif
-@@ -362,7 +362,7 @@
+@@ -362,7 +362,7 @@ CREATE_DB = $(RBIN)/create_db$(EXEC_EXT)
GDS_DROP = $(BIN)/gds_drop$(EXEC_EXT)
FBSVCMGR = $(BIN)/fbsvcmgr$(EXEC_EXT)
FBTRACEMGR = $(BIN)/fbtracemgr$(EXEC_EXT)
@@ -45,7 +45,7 @@
NBACKUP = $(BIN)/nbackup$(EXEC_EXT)
LOCKPRINT = $(BIN)/fb_lock_print$(EXEC_EXT)
GSEC = $(BIN)/gsec$(EXEC_EXT)
-@@ -383,13 +383,13 @@
+@@ -383,13 +383,13 @@ SECURITY_FDB = $(FIREBIRD)/security3.fdb
QLI = $(BIN)/qli$(EXEC_EXT)
# From isql
diff --git a/databases/firebird30-server/files/patch-builds-posix-prefix.freebsd b/databases/firebird30-server/files/patch-builds_posix_prefix.freebsd
index 3da3ac70283e..9734f4083aa3 100644
--- a/databases/firebird30-server/files/patch-builds-posix-prefix.freebsd
+++ b/databases/firebird30-server/files/patch-builds_posix_prefix.freebsd
@@ -1,4 +1,4 @@
---- builds/posix/prefix.freebsd.orig 2021-03-27 18:59:05 UTC
+--- builds/posix/prefix.freebsd.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/prefix.freebsd
@@ -20,5 +20,14 @@
@@ -17,4 +17,3 @@
+%/array.o %/blob.o %/alice_meta.o %/restore.o %/backup.o: COMMON_FLAGS += -Wno-narrowing
+%/OdsDetection.o %/dba.o: COMMON_FLAGS += -Wno-narrowing
+
-
diff --git a/databases/firebird30-server/files/patch-builds-posix-prefix.freebsd_amd64 b/databases/firebird30-server/files/patch-builds_posix_prefix.freebsd__amd64
index dd0f1ae39223..d51c1af1e2d6 100644
--- a/databases/firebird30-server/files/patch-builds-posix-prefix.freebsd_amd64
+++ b/databases/firebird30-server/files/patch-builds_posix_prefix.freebsd__amd64
@@ -1,4 +1,4 @@
---- builds/posix/prefix.freebsd_amd64.orig 2020-10-20 08:40:05 UTC
+--- builds/posix/prefix.freebsd_amd64.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/prefix.freebsd_amd64
@@ -20,5 +20,13 @@
@@ -16,4 +16,3 @@
+# These files are generated incorrectly (e.g. array.epp => array.cpp)
+%/array.o %/blob.o %/alice_meta.o %/restore.o %/backup.o: COMMON_FLAGS += -Wno-narrowing
+%/OdsDetection.o %/dba.o: COMMON_FLAGS += -Wno-narrowing
-
diff --git a/databases/firebird30-server/files/patch-extern_btyacc_Makefile b/databases/firebird30-server/files/patch-extern_btyacc_Makefile
index defaa3243e5b..24cb5ddee87a 100644
--- a/databases/firebird30-server/files/patch-extern_btyacc_Makefile
+++ b/databases/firebird30-server/files/patch-extern_btyacc_Makefile
@@ -1,4 +1,4 @@
---- extern/btyacc/Makefile.orig 2020-10-12 00:02:22 UTC
+--- extern/btyacc/Makefile.orig 2022-06-07 08:18:52 UTC
+++ extern/btyacc/Makefile
@@ -42,7 +42,7 @@ OTHERS = README README.BYACC \
all: $(PROGRAM)
@@ -9,4 +9,3 @@
clean:; rm -f $(OBJS)
-
diff --git a/databases/firebird30-server/files/patch-extern_cloop_Makefile b/databases/firebird30-server/files/patch-extern_cloop_Makefile
index 8c4b33ba7dac..4f1e65880bbd 100644
--- a/databases/firebird30-server/files/patch-extern_cloop_Makefile
+++ b/databases/firebird30-server/files/patch-extern_cloop_Makefile
@@ -1,4 +1,4 @@
---- extern/cloop/Makefile 2020-10-12 00:02:22 UTC
+--- extern/cloop/Makefile.orig 2022-06-07 08:18:52 UTC
+++ extern/cloop/Makefile
@@ -6,7 +6,7 @@ TARGET := release
@@ -9,7 +9,7 @@
SRC_DIR := src
BUILD_DIR := build
-@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$
+@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$(wildcard $(sd
OBJS_C := $(patsubst $(SRC_DIR)/%.c,$(OBJ_DIR)/%.o,$(SRCS_C))
OBJS_CPP := $(patsubst $(SRC_DIR)/%.cpp,$(OBJ_DIR)/%.o,$(SRCS_CPP))
@@ -21,4 +21,3 @@
FPC_FLAGS := -Mdelphi
ifeq ($(TARGET),release)
-
diff --git a/databases/firebird30-server/files/patch-src_common_os_posix_SyncSignals.cpp b/databases/firebird30-server/files/patch-src_common_os_posix_SyncSignals.cpp
index 159ee13a99c0..f24f4e93b82f 100644
--- a/databases/firebird30-server/files/patch-src_common_os_posix_SyncSignals.cpp
+++ b/databases/firebird30-server/files/patch-src_common_os_posix_SyncSignals.cpp
@@ -1,4 +1,4 @@
---- src/common/os/posix/SyncSignals.cpp.orig 2020-10-12 00:02:22 UTC
+--- src/common/os/posix/SyncSignals.cpp.orig 2022-06-07 08:18:52 UTC
+++ src/common/os/posix/SyncSignals.cpp
@@ -54,9 +54,6 @@
#include <errno.h>
@@ -10,4 +10,3 @@
namespace {
-
diff --git a/databases/firebird30-server/files/patch-src-jrd-os-posix_unix.cpp b/databases/firebird30-server/files/patch-src_jrd_os_posix_unix.cpp
index 6c9dc50ba31d..ffaecc74c81e 100644
--- a/databases/firebird30-server/files/patch-src-jrd-os-posix_unix.cpp
+++ b/databases/firebird30-server/files/patch-src_jrd_os_posix_unix.cpp
@@ -1,5 +1,5 @@
---- src/jrd/os/posix/unix.cpp 2021-06-22 00:38:07.434896000 -0500
-+++ src/jrd/os/posix/unix.cpp 2021-06-22 00:43:54.988645000 -0500
+--- src/jrd/os/posix/unix.cpp.orig 2022-06-07 08:18:52 UTC
++++ src/jrd/os/posix/unix.cpp
@@ -56,6 +56,13 @@
#include <linux/fs.h>
#endif
@@ -14,7 +14,7 @@
#endif //SUPPORT_RAW_DEVICES
#include "../jrd/jrd.h"
-@@ -495,7 +502,7 @@
+@@ -496,7 +503,7 @@ ULONG PIO_get_number_of_pages(const jrd_file* file, co
// Looks like any OS needs own ioctl() to determine raw device size
#undef HAS_RAW_SIZE
diff --git a/databases/firebird30-server/files/patch-src_remote_inet.cpp b/databases/firebird30-server/files/patch-src_remote_inet.cpp
index 6b45a4f61e75..269a80fd8457 100644
--- a/databases/firebird30-server/files/patch-src_remote_inet.cpp
+++ b/databases/firebird30-server/files/patch-src_remote_inet.cpp
@@ -1,6 +1,6 @@
---- src/remote/inet.cpp.orig 2020-10-20 08:40:05 UTC
+--- src/remote/inet.cpp.orig 2022-06-07 08:18:52 UTC
+++ src/remote/inet.cpp
-@@ -962,7 +962,7 @@ rem_port* INET_connect(const TEXT* name,
+@@ -960,7 +960,7 @@ rem_port* INET_connect(const TEXT* name,
gai_hints.ai_family = ((host.hasData() || !ipv6) ? AF_UNSPEC : AF_INET6);
gai_hints.ai_socktype = SOCK_STREAM;
@@ -9,7 +9,7 @@
gai_hints.ai_protocol = SOL_TCP;
#else
gai_hints.ai_protocol = IPPROTO_TCP;
-@@ -1176,6 +1176,12 @@ static rem_port* listener_socket(rem_port* port, USHOR
+@@ -1174,6 +1174,12 @@ static rem_port* listener_socket(rem_port* port, USHOR
setFastLoopbackOption(port);
inet_ports->registerPort(port);
@@ -22,4 +22,3 @@
if (flag & SRVR_multi_client)
{
-