aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-10-22 17:59:55 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-10-29 16:06:08 +0000
commit555e4a7a55f5813c605d89893dc6e2de798174a4 (patch)
tree8c82c8277951855b41443147f260857b15399077
parent19a4628adae91014865a9547c43627c3af834f31 (diff)
downloadports-555e4a7a55f5813c605d89893dc6e2de798174a4.tar.gz
ports-555e4a7a55f5813c605d89893dc6e2de798174a4.zip
lang/intel-compute-runtime: update to 21.43.21438
-rw-r--r--lang/intel-compute-runtime/Makefile4
-rw-r--r--lang/intel-compute-runtime/distinfo10
-rw-r--r--lang/intel-compute-runtime/files/patch-no-perf11
3 files changed, 13 insertions, 12 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index 5132716265ed..eb297e702226 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,11 +1,11 @@
PORTNAME= compute-runtime
-DISTVERSION= 21.42.21270
+DISTVERSION= 21.43.21438
CATEGORIES= lang
PKGNAMEPREFIX= intel-
PKGNAMESUFFIX= -${FLAVOR}
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= 2a74c265d6c5.patch:-p1 # https://github.com/intel/compute-runtime/pull/361
+PATCHFILES+= bb6ed003e8cd.patch:-p1 # https://github.com/intel/compute-runtime/pull/361
MAINTAINER= jbeich@FreeBSD.org
COMMENT= OpenCL implementation for Intel HD 5000 (Gen8) or newer
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 6bc16648a361..00c60ace7fd8 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1633955962
-SHA256 (intel-compute-runtime-21.42.21270_GH0.tar.gz) = cf7340e43a1574ad23a76034ae731b992a9430e09397a3376bb473a13ebdc33e
-SIZE (intel-compute-runtime-21.42.21270_GH0.tar.gz) = 4761371
-SHA256 (2a74c265d6c5.patch) = aa0aaa53a73bb03e9938878614c3f8eed7339869a6383602a2a574a151ab5f71
-SIZE (2a74c265d6c5.patch) = 1691
+TIMESTAMP = 1634925595
+SHA256 (intel-compute-runtime-21.43.21438_GH0.tar.gz) = 33a4626aeeb52444ec05e64cc16d3b97c878cfc5f7687f6380869a60f55376f3
+SIZE (intel-compute-runtime-21.43.21438_GH0.tar.gz) = 4840204
+SHA256 (bb6ed003e8cd.patch) = 4448bc9d85e0925325d4c38a9d07011f4bffc93518282b8c48c6e81b4a9ec384
+SIZE (bb6ed003e8cd.patch) = 1737
diff --git a/lang/intel-compute-runtime/files/patch-no-perf b/lang/intel-compute-runtime/files/patch-no-perf
index b41ffa6c4826..04729eaa066a 100644
--- a/lang/intel-compute-runtime/files/patch-no-perf
+++ b/lang/intel-compute-runtime/files/patch-no-perf
@@ -32,19 +32,20 @@ level_zero/tools/source/sysman/linux/pmu/pmu_imp.h:12:10: fatal error: 'linux/pe
}
LinuxEngineImp::LinuxEngineImp(OsSysman *pOsSysman, zes_engine_group_t type, uint32_t engineInstance) : engineGroup(type), engineInstance(engineInstance) {
---- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2021-10-01 16:31:56 UTC
+--- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2021-10-22 17:59:55 UTC
+++ level_zero/tools/source/sysman/linux/os_sysman_imp.cpp
-@@ -45,8 +45,10 @@ ze_result_t LinuxSysmanImp::init() {
+@@ -47,9 +47,11 @@ ze_result_t LinuxSysmanImp::init() {
auto rootPciPathOfGpuDevice = getPciRootPortDirectoryPath(realRootPath);
PlatformMonitoringTech::create(pParentSysmanDeviceImp->deviceHandles, pFsAccess, rootPciPathOfGpuDevice, mapOfSubDeviceIdToPmtObject);
+#ifdef __linux__
pPmuInterface = PmuInterface::create(this);
+
DEBUG_BREAK_IF(nullptr == pPmuInterface);
+#endif
-
- return ZE_RESULT_SUCCESS;
- }
+ auto loc = realRootPath.find_last_of('/');
+ std::string pciBDF = realRootPath.substr(loc + 1, std::string::npos);
+ pFwUtilInterface = FirmwareUtil::create(pciBDF);
--- level_zero/tools/source/sysman/linux/os_sysman_imp.h.orig 2021-10-01 16:31:56 UTC
+++ level_zero/tools/source/sysman/linux/os_sysman_imp.h
@@ -14,7 +14,9 @@