aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:27:24 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:59:03 +0000
commit5592c5ea0729b53697958bd1f1cc7054123196f1 (patch)
treeb359c35e1af8c38bb611efdd3a43d34c95c9366e
parent52ff75cf899658e870838bd3172b86ba1ea0a0a5 (diff)
downloadports-5592c5ea0729b53697958bd1f1cc7054123196f1.tar.gz
ports-5592c5ea0729b53697958bd1f1cc7054123196f1.zip
dns/libpsl: Change back to make
- Readd IDN and NLS options - Do not install psl-make-dafsa because it requires Python - Remove psl-make-dafsa.1 - Bump PORTREVISION for dependency and package change
-rw-r--r--dns/libpsl/Makefile51
-rw-r--r--dns/libpsl/pkg-plist2
2 files changed, 34 insertions, 19 deletions
diff --git a/dns/libpsl/Makefile b/dns/libpsl/Makefile
index b5a00b907c8a..a42da91d7eeb 100644
--- a/dns/libpsl/Makefile
+++ b/dns/libpsl/Makefile
@@ -1,7 +1,8 @@
PORTNAME= libpsl
-DISTVERSION= 0.21.2
+PORTVERSION= 0.21.2
+PORTREVISION= 1
CATEGORIES= dns
-MASTER_SITES= https://github.com/rockdaboot/${PORTNAME}/releases/download/${DISTVERSION}/
+MASTER_SITES= https://github.com/rockdaboot/libpsl/releases/download/${PORTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C library to handle the Public Suffix List
@@ -12,30 +13,46 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
-USES= localbase:ldflags meson pkgconfig python:build shebangfix tar:lz
-
+USES= libtool localbase:ldflags pathfix pkgconfig python:build shebangfix tar:lz
+
+CONFIGURE_ARGS= --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf \
+ --disable-man \
+ --enable-builtin \
+ --with-psl-file=${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat \
+ --with-psl-testfile=${LOCALBASE}/share/public_suffix_list/test_psl.txt
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USE_LOCALE= en_US.UTF-8
SHEBANG_FILES= src/psl-make-dafsa
TEST_TARGET= test
-MESON_ARGS= -Ddefault_library=both \
- -Dpsl_file=${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat \
- -Dpsl_testfile=${LOCALBASE}/share/public_suffix_list/test_psl.txt
-
-OPTIONS_SINGLE= IDNA
-OPTIONS_SINGLE_IDNA= ICU IDN2
-OPTIONS_DEFAULT= ICU
-
-ICU_DESC= Use devel/icu (IDNA2008 UTS\#46 library)
-IDN2_DESC= Use dns/libidn2 (IDNA2008 library)
+OPTIONS_DEFINE= NLS
+OPTIONS_SINGLE= IDNA
+OPTIONS_SINGLE_IDNA= ICU IDN IDN2
+OPTIONS_DEFAULT=IDN2
+ICU_DESC= Use devel/icu (IDNA2008 UTS\#46 library)
+IDN_DESC= Use dns/libidn (IDNA2003 library)
+IDN2_DESC= Use dns/libidn2 (IDNA2008 library)
+ICU_CONFIGURE_ON= --enable-runtime=libicu
ICU_LIB_DEPENDS= libicuuc.so:devel/icu
-ICU_MESON_ON= -Druntime=libicu
-IDN2_USES= iconv
+IDN_CONFIGURE_ON= --enable-runtime=libidn
+IDN_LIB_DEPENDS= libidn.so:dns/libidn \
+ libunistring.so:devel/libunistring
+IDN_USES= iconv
+IDN2_CONFIGURE_ON= --enable-runtime=libidn2
IDN2_LIB_DEPENDS= libidn2.so:dns/libidn2 \
libunistring.so:devel/libunistring
-IDN2_MESON_ON= -Druntime=libidn2
+IDN2_USES= iconv
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+NLS_USES_OFF= gettext-tools
+
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/man/man1/psl-make-dafsa.1
.include <bsd.port.mk>
diff --git a/dns/libpsl/pkg-plist b/dns/libpsl/pkg-plist
index c60f11d531df..f0e62dd59fe2 100644
--- a/dns/libpsl/pkg-plist
+++ b/dns/libpsl/pkg-plist
@@ -1,4 +1,3 @@
-bin/psl-make-dafsa
bin/psl
include/libpsl.h
lib/libpsl.a
@@ -6,5 +5,4 @@ lib/libpsl.so
lib/libpsl.so.5
lib/libpsl.so.5.3.4
libdata/pkgconfig/libpsl.pc
-man/man1/psl-make-dafsa.1.gz
man/man1/psl.1.gz