aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-11-15 15:28:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-11-15 15:38:14 +0000
commit55c3ad38e96d8c191029c6bd15920c7275bc851e (patch)
tree7eaa7d3404ed41f2029785012b2bec6a6dca5103
parent73e63bbeeb992f7b81bf0de8fa6aefe1e4159bae (diff)
downloadports-55c3ad38e96d8c191029c6bd15920c7275bc851e.tar.gz
ports-55c3ad38e96d8c191029c6bd15920c7275bc851e.zip
multimedia/mpv: expose rubberband audio filter
-rw-r--r--multimedia/mpv/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/multimedia/mpv/Makefile b/multimedia/mpv/Makefile
index 9398f2e7b306..b5cc60994e28 100644
--- a/multimedia/mpv/Makefile
+++ b/multimedia/mpv/Makefile
@@ -29,12 +29,11 @@ SHEBANG_FILES= *.py TOOLS/*.py
USE_GITHUB= yes
GH_ACCOUNT= mpv-player
MESON_ARGS= -Dpdf-build=disabled \
- -Drubberband=disabled \
-Dshaderc=disabled \
-Dvapoursynth=disabled \
-Dlibmpv=true
-OPTIONS_DEFINE= ARCHIVE DOCS LCMS2 MANPAGES MUJS TEST UCHARDET EXAMPLES ZIMG
+OPTIONS_DEFINE= ARCHIVE DOCS LCMS2 MANPAGES MUJS RUBBERBAND TEST UCHARDET EXAMPLES ZIMG
OPTIONS_DEFAULT= ARCHIVE DVDNAV LUAJIT MANPAGES NVDEC OPENGL UCHARDET \
V4L VAAPI VDPAU VULKAN WAYLAND X11 YTDLP
OPTIONS_GROUP= IN VO AO
@@ -53,6 +52,7 @@ LUAJIT_DESC= Use LuaJIT instead of Lua scripting language support
MUJS_DESC= Use MuJS for Javascript language support
NVDEC_DESC= NVIDIA decoder with CUDA support
PIPEWIRE_DESC= Pipewire sound server support
+RUBBERBAND_DESC= High quality pitch correction with librubberband
SIXEL_DESC= Sixel graphics support
UCHARDET_DESC= Guess subtitle encoding via uchardet
VULKAN_DESC= Vulkan output support
@@ -123,6 +123,9 @@ PIPEWIRE_MESON_ENABLED= pipewire
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_MESON_ENABLED= pulse
+RUBBERBAND_LIB_DEPENDS= librubberband.so:audio/rubberband
+RUBBERBAND_MESON_ENABLED= rubberband
+
SDL_USES= sdl
SDL_USE= SDL=sdl2
SDL_MESON_ENABLED= sdl2