aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2024-11-28 09:37:13 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2024-11-28 10:54:57 +0000
commit568882d1b82ef4bf8cbd18175f3c2ef41ce93399 (patch)
tree9208ab4a04f2028f1e0a3a588637cadbe7fef05e
parent2c87bf1deb36339194333ca8720483c0c8aa0ec4 (diff)
downloadports-568882d1b82ef4bf8cbd18175f3c2ef41ce93399.tar.gz
ports-568882d1b82ef4bf8cbd18175f3c2ef41ce93399.zip
security/gnupg: Stop running autoreconf and directly patch doc/Makefile.in
It turned out running autoreconf causes unexpected side effect that gpg displays message as following. gpg: NOTE: THIS IS A DEVELOPMENT VERSION! gpg: It is only intended for test purposes and should NOT be gpg: used in a production environment or with production keys! So stop running autoreconf to regenerate doc/Makefile.in from patched doc/Makefile.am, and directly patch doc/Makefile.in instead. This partially reverts commit dd1496c651a27f6327bf030f8671e7291012cc69. Reported by: gahr Approved by: portmgr (implicit, just fix it) Fixes: dd1496c651a2 security/gnupg: Update to 2.4.6
-rw-r--r--security/gnupg/Makefile6
-rw-r--r--security/gnupg/files/patch-configure (renamed from security/gnupg/files/patch-m4_gpg-error.m4)8
-rw-r--r--security/gnupg/files/patch-doc_Makefile.in (renamed from security/gnupg/files/patch-doc_Makefile.am)29
3 files changed, 20 insertions, 23 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index a285ea20c890..fbc1c3565982 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gnupg
DISTVERSION= 2.4.6
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= GNUPG
@@ -19,8 +20,8 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libnpth.so:devel/npth
RUN_DEPENDS= pinentry:security/pinentry
-USES= autoreconf compiler:c11 cpe gettext-tools gmake iconv makeinfo pkgconfig \
- readline sqlite tar:bzip2
+USES= compiler:c11 cpe gmake iconv makeinfo pkgconfig readline sqlite \
+ tar:bzip2
CPE_VENDOR= gnupg
@@ -76,6 +77,7 @@ pre-build:
${TOUCH} ${WRKSRC}/doc/*.texi
post-install:
+ ${RMDIR} ${STAGEDIR}${PREFIX}/share/man/manh
${MV} ${STAGEDIR}${PREFIX}/bin/gpgsplit ${STAGEDIR}${PREFIX}/bin/gpgsplit2
${MV} ${STAGEDIR}${DATADIR}/help*.txt ${STAGEDIR}${DOCSDIR}
diff --git a/security/gnupg/files/patch-m4_gpg-error.m4 b/security/gnupg/files/patch-configure
index 251a053014e3..20e250e38430 100644
--- a/security/gnupg/files/patch-m4_gpg-error.m4
+++ b/security/gnupg/files/patch-configure
@@ -1,6 +1,8 @@
---- m4/gpg-error.m4.orig 2024-05-15 10:33:38 UTC
-+++ m4/gpg-error.m4
-@@ -67,7 +67,7 @@ AC_DEFUN([_AM_PATH_GPGRT_CONFIG],[dnl
+Fix path of pkgconfig files passed to gpgrt-config.
+
+--- configure.orig 2024-01-25 10:09:44 UTC
++++ configure
+@@ -8428,7 +8428,7 @@ fi
# Get the prefix of gpgrt-config assuming it's something like:
# <PREFIX>/bin/gpgrt-config
gpgrt_prefix=${GPGRT_CONFIG%/*/*}
diff --git a/security/gnupg/files/patch-doc_Makefile.am b/security/gnupg/files/patch-doc_Makefile.in
index c0fda8df0e82..9149a0b4ab89 100644
--- a/security/gnupg/files/patch-doc_Makefile.am
+++ b/security/gnupg/files/patch-doc_Makefile.in
@@ -1,35 +1,28 @@
---- doc/Makefile.am.orig 2024-09-20 10:07:25 UTC
-+++ doc/Makefile.am
-@@ -79,13 +79,13 @@ myman_sources = gnupg7.texi gpg.texi gpgsm.texi gpg-ag
- myman_sources = gnupg7.texi gpg.texi gpgsm.texi gpg-agent.texi \
+--- doc/Makefile.in.orig 2024-10-29 12:52:23 UTC
++++ doc/Makefile.in
+@@ -521,14 +521,14 @@ myman_sources = gnupg7.texi gpg.texi gpgsm.texi gpg-ag
dirmngr.texi scdaemon.texi tools.texi wks.texi \
gpg-card.texi
--myman_pages = gpg.1 gpgv.1 gpgsm.1 gpg-agent.1 dirmngr.8 scdaemon.1 \
-+myman_pages = gpgsm.1 gpg-agent.1 dirmngr.8 scdaemon.1 \
+
+-myman_pages = gpg.1 gpgv.1 gpgsm.1 gpg-agent.1 dirmngr.8 scdaemon.1 \
++myman_pages = gpg2.1 gpgv2.1 gpgsm.1 gpg-agent.1 dirmngr.8 scdaemon.1 \
watchgnupg.1 gpgconf.1 addgnupghome.8 gpg-preset-passphrase.1 \
gpg-connect-agent.1 gpgparsemail.1 gpgtar.1 gpg-mail-tube.1 \
applygnupgdefaults.8 gpg-wks-client.1 gpg-wks-server.1 \
dirmngr-client.1 gpg-card.1 gpg-check-pattern.1
+
myhtmlman_pages = \
- gpg.1.html gpgv.1.html gpgsm.1.html \
-+ gpgsm.1.html \
++ gpg2.1.html gpgv2.1.html gpgsm.1.html \
gpg-agent.1.html dirmngr.8.html scdaemon.1.html \
watchgnupg.1.html gpgconf.1.html addgnupghome.8.html \
gpg-preset-passphrase.1.html \
-@@ -95,7 +95,15 @@ myhtmlman_pages = \
+@@ -538,7 +538,7 @@ myhtmlman_pages = \
gpg-wks-server.1.html \
dirmngr-client.1.html gpg-card.1.html gpg-check-pattern.1.html
-man_MANS = $(myman_pages) gnupg.7 gnupg.7.html
-+if USE_GPG2_HACK
-+myman_pages += gpg2.1 gpgv2.1
-+myhtmlman_pages += gpg2.1.html gpgv2.1.html
-+else
-+myman_pages += gpg.1 gpgv.1
-+myhtmlman_pages += gpg.1.html gpgv.1.html
-+endif
-+
+man_MANS = $(myman_pages) gnupg.7
-
watchgnupg_SOURCE = gnupg.texi
-
+ CLEANFILES = yat2m mkdefsinc defs.inc
+ DISTCLEANFILES = gnupg.tmp gnupg.ops yat2m-stamp.tmp yat2m-stamp \