aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2021-10-10 17:38:17 +0000
committerBernard Spil <brnrd@FreeBSD.org>2021-10-10 17:38:17 +0000
commit56bd131288651e46e53ab3eb0e2ad5d2cda68745 (patch)
tree90a67f9c8d1eacecdf8bf925faf6b0d45ea4017b
parent4f16386b7d8ee34dae7c6de81684ff98f828b9e5 (diff)
downloadports-56bd131288651e46e53ab3eb0e2ad5d2cda68745.tar.gz
ports-56bd131288651e46e53ab3eb0e2ad5d2cda68745.zip
security/nextcloud-twofactor_admin: Add new port
-rw-r--r--security/Makefile1
-rw-r--r--security/nextcloud-twofactor_admin/Makefile41
-rw-r--r--security/nextcloud-twofactor_admin/distinfo3
-rw-r--r--security/nextcloud-twofactor_admin/pkg-descr3
4 files changed, 48 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2f57f3214a31..9bd8afc59f0b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -387,6 +387,7 @@
SUBDIR += nettle
SUBDIR += nextcloud-end_to_end_encryption
SUBDIR += nextcloud-passman
+ SUBDIR += nextcloud-twofactor_admin
SUBDIR += nextcloud-twofactor_totp
SUBDIR += nextcloud-twofactor_u2f
SUBDIR += nextcloud-twofactor_webauthn
diff --git a/security/nextcloud-twofactor_admin/Makefile b/security/nextcloud-twofactor_admin/Makefile
new file mode 100644
index 000000000000..4465d89a9ead
--- /dev/null
+++ b/security/nextcloud-twofactor_admin/Makefile
@@ -0,0 +1,41 @@
+# Created by: Bernard Spil <brnrd@freebsd.org>
+
+PORTNAME= twofactor_admin
+PORTVERSION= 3.1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+MASTER_SITES= https://github.com/ChristophWurst/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
+#https://github.com/ChristophWurst/twofactor_admin/releases/download/v3.1.0/twofactor_admin.tar.gz
+PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}/${DISTNAME}-${DISTVERSIONPREFIX}${PORTVERSION}
+
+MAINTAINER= brnrd@FreeBSD.org
+COMMENT= Admin create one-time TOTP app for Nextcloud
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=17:www/nextcloud@${PHP_FLAVOR}
+
+USES= php:flavors
+NO_BUILD= yes
+NO_ARCH= yes
+
+NEXTCLOUD_USERNAME?= ${WWWOWN}
+NEXTCLOUD_GROUPNAME?= ${WWWGRP}
+
+PLIST_SUB= NEXTCLOUD_USERNAME=${NEXTCLOUD_USERNAME} \
+ NEXTCLOUD_GROUPNAME=${NEXTCLOUD_GROUPNAME}
+
+WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+ @(cd ${WRKSRC}; ${FIND} . -not -type d) | ${SORT} | \
+ ${SED} -e 's,^\.,${WWWDIR_REL},' >> ${TMPPLIST}
+
+
+.include <bsd.port.mk>
diff --git a/security/nextcloud-twofactor_admin/distinfo b/security/nextcloud-twofactor_admin/distinfo
new file mode 100644
index 000000000000..e213ce8022e1
--- /dev/null
+++ b/security/nextcloud-twofactor_admin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633886669
+SHA256 (nextcloud/twofactor_admin-v3.1.0/twofactor_admin.tar.gz) = cf5b5be558359d78f60d246193c5426cc397094a4ca5b9e52a770290cb50b83b
+SIZE (nextcloud/twofactor_admin-v3.1.0/twofactor_admin.tar.gz) = 373694
diff --git a/security/nextcloud-twofactor_admin/pkg-descr b/security/nextcloud-twofactor_admin/pkg-descr
new file mode 100644
index 000000000000..059e2137e23b
--- /dev/null
+++ b/security/nextcloud-twofactor_admin/pkg-descr
@@ -0,0 +1,3 @@
+A Two-Factor-Auth Provider for TOTP (RFC 6238)
+
+WWW: https://apps.nextcloud.com/apps/twofactor_totp