aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2021-12-22 10:16:53 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2021-12-22 10:21:37 +0000
commit56c987b2740352c159589f4c54ea7241c1ad5593 (patch)
tree0135faca00d6ea72a1f35c03b8632e6957edfde8
parentcf0b7b7e25e0c2382d7f468bb4eabcc2d1e6265b (diff)
downloadports-56c987b2740352c159589f4c54ea7241c1ad5593.tar.gz
ports-56c987b2740352c159589f4c54ea7241c1ad5593.zip
net/haproxy: fix build for i386.
Patch from PR 260232 by diizzy. PR: 260555
-rw-r--r--net/haproxy/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index d9bfbc01405e..0f00495d5009 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -26,7 +26,9 @@ USE_RC_SUBR= haproxy
ALL_TARGET= all admin/halog/halog
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_ACCEPT4=1 \
- CC="${CC}" DEBUG_CFLAGS="" CPU_CFLAGS="${CFLAGS}"
+ CC="${CC}" DEBUG_CFLAGS="" CPU_CFLAGS="${CFLAGS}" \
+ ${MAKE_ARGS_${ARCH}}
+MAKE_ARGS_i386= USE_LIBATOMIC=
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS PROMEX
OPTIONS_RADIO= PCRE