aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-06-30 19:54:06 +0000
committerRene Ladan <rene@FreeBSD.org>2022-06-30 19:54:06 +0000
commit56dc1089a7bfede88ce1ac34cf4cf49cd3e8d455 (patch)
tree4b804190b723505e2ee4155222e0828928cbd36a
parentff89f3f090b355f83ae3a7eb30f408fb9d72924e (diff)
downloadports-56dc1089a7bfede88ce1ac34cf4cf49cd3e8d455.tar.gz
ports-56dc1089a7bfede88ce1ac34cf4cf49cd3e8d455.zip
cleanup: Remove expired ports:
2022-06-30 www/py-django22: Django 2.2 is now in Extended Support, receives security fixes only and will reach End-Of-Life on 2022-04-01. Upgrade to a later Django version. See https://www.djangoproject.com/download/ 2022-06-30 www/py-jsonfield2: Obsolete, please use www/py-jsonfield instead
-rw-r--r--MOVED2
-rw-r--r--www/Makefile2
-rw-r--r--www/py-django22/Makefile73
-rw-r--r--www/py-django22/distinfo3
-rw-r--r--www/py-django22/pkg-descr10
-rw-r--r--www/py-jsonfield2/Makefile27
-rw-r--r--www/py-jsonfield2/distinfo3
-rw-r--r--www/py-jsonfield2/pkg-descr5
8 files changed, 2 insertions, 123 deletions
diff --git a/MOVED b/MOVED
index abfef4052df8..c45e03304f1f 100644
--- a/MOVED
+++ b/MOVED
@@ -17377,3 +17377,5 @@ www/py-django-bulk-update||2022-06-30|Has expired: No longer maintained, not com
www/py-django-happenings-update||2022-06-30|Has expired: Upstream no longer maintained, not compatible with newer versions of Django
www/py-django-compat||2022-06-30|Has expired: No longer maintained, doesn't work with newer versions of Django
www/py-django-modern-rpc||2022-06-30|Has expired: Not compatible with newer versions of Django
+www/py-django22||2022-06-30|Has expired: Django 2.2 is now in Extended Support, receives security fixes only and will reach End-Of-Life on 2022-04-01. Upgrade to a later Django version. See https://www.djangoproject.com/download/
+www/py-jsonfield2|www/py-jsonfield|2022-06-30|Has expired: Obsolete, please use www/py-jsonfield instead
diff --git a/www/Makefile b/www/Makefile
index 1925753e0f32..bb1289d74983 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1575,7 +1575,6 @@
SUBDIR += py-django-voting
SUBDIR += py-django-webpack-loader
SUBDIR += py-django-widget-tweaks
- SUBDIR += py-django22
SUBDIR += py-django32
SUBDIR += py-django40
SUBDIR += py-django_compressor
@@ -1687,7 +1686,6 @@
SUBDIR += py-internetarchive
SUBDIR += py-jonpy
SUBDIR += py-jsonfield
- SUBDIR += py-jsonfield2
SUBDIR += py-lektor
SUBDIR += py-lesscpy
SUBDIR += py-libsass
diff --git a/www/py-django22/Makefile b/www/py-django22/Makefile
deleted file mode 100644
index f47cceb7af83..000000000000
--- a/www/py-django22/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-
-PORTNAME= django
-PORTVERSION= 2.2.28
-CATEGORIES= www python
-MASTER_SITES= CHEESESHOP \
- https://www.djangoproject.com/m/releases/${PORTVERSION}/
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-PKGNAMESUFFIX= 22
-DISTNAME= Django-${PORTVERSION}
-DIST_SUBDIR= python
-
-MAINTAINER= python@FreeBSD.org
-COMMENT= High-level Python Web Framework
-
-LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-DEPRECATED= Django 2.2 is now in Extended Support, receives security fixes only and will reach End-Of-Life on 2022-04-01. Upgrade to a later Django version. See https://www.djangoproject.com/download/
-EXPIRATION_DATE= 2022-06-30
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlparse>=0:databases/py-sqlparse@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tblib>0:devel/py-tblib@${PY_FLAVOR}
-
-USES= cpe python:3.5+ shebangfix
-USE_PYTHON= autoplist distutils
-
-NO_ARCH= yes
-
-DOCSDIR= ${PREFIX}/share/doc/py-django
-PLIST_FILES= man/man1/django-admin.1.gz
-PORTDOCS= *
-
-SHEBANG_FILES= django/bin/django-admin.py \
- django/conf/project_template/manage.py-tpl
-
-CONFLICTS_INSTALL= py*-django* # bin/django-admin
-
-CPE_VENDOR= djangoproject
-
-# Upstream archive contains files with UTF-8 names
-EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
-
-OPTIONS_DEFINE= DOCS HTMLDOCS
-OPTIONS_GROUP= DATABASE
-OPTIONS_GROUP_DATABASE= PGSQL MYSQL SQLITE
-OPTIONS_DEFAULT=SQLITE
-HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
-
-HTMLDOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
-HTMLDOCS_IMPLIES= DOCS
-PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2@${PY_FLAVOR}
-MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mysqlclient>=1.3.13:databases/py-mysqlclient@${PY_FLAVOR}
-SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-
-post-build-HTMLDOCS-on:
- cd ${WRKSRC}/docs && ${MAKE} html SPHINXBUILD=sphinx-build-${PYTHON_VER}
-
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${MAN1PREFIX}/man/man1
- @${ECHO_MSG} ""
- @${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
- @${ECHO_MSG} ""
-
-post-install-HTMLDOCS-on:
- ${MKDIR} ${STAGEDIR}/${DOCSDIR}
- ${CP} -R ${WRKSRC}/docs/_build/html ${STAGEDIR}/${DOCSDIR}
-
-do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} tests/runtests.py --settings=test_sqlite
-
-.include <bsd.port.mk>
diff --git a/www/py-django22/distinfo b/www/py-django22/distinfo
deleted file mode 100644
index 80f15a229bb8..000000000000
--- a/www/py-django22/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1649721195
-SHA256 (python/Django-2.2.28.tar.gz) = 0200b657afbf1bc08003845ddda053c7641b9b24951e52acd51f6abda33a7413
-SIZE (python/Django-2.2.28.tar.gz) = 9187543
diff --git a/www/py-django22/pkg-descr b/www/py-django22/pkg-descr
deleted file mode 100644
index 0ea493b87ab6..000000000000
--- a/www/py-django22/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-Django is a high-level Python Web framework that encourages rapid development
-and clean, pragmatic design.
-
-Developed and used over the past two years by a fast-moving online-news
-operation, Django was designed from scratch to handle two challenges: the
-intensive deadlines of a newsroom and the stringent requirements of experienced
-Web developers. It has convenient niceties for developing content-management
-systems, but it's an excellent tool for building any Web site.
-
-WWW: https://www.djangoproject.com/
diff --git a/www/py-jsonfield2/Makefile b/www/py-jsonfield2/Makefile
deleted file mode 100644
index e70036e3aae1..000000000000
--- a/www/py-jsonfield2/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-
-PORTNAME= jsonfield2
-PORTVERSION= 4.0.0.post0
-CATEGORIES= www python
-MASTER_SITES= CHEESESHOP
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= Reusable Django field to store validated JSON in your model
-
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-DEPRECATED= Obsolete, please use www/py-jsonfield instead
-EXPIRATION_DATE= 2022-06-30
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django22>=2.2:www/py-django22@${PY_FLAVOR}
-
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
-
-NO_ARCH= yes
-
-CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}dj22-jsonfield2
-
-.include <bsd.port.mk>
diff --git a/www/py-jsonfield2/distinfo b/www/py-jsonfield2/distinfo
deleted file mode 100644
index a71d45eced01..000000000000
--- a/www/py-jsonfield2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1605426493
-SHA256 (jsonfield2-4.0.0.post0.tar.gz) = cbce2d7c52563550cd2048fcf3a57631019d3547f5ed142f42141d1d2dc53283
-SIZE (jsonfield2-4.0.0.post0.tar.gz) = 12632
diff --git a/www/py-jsonfield2/pkg-descr b/www/py-jsonfield2/pkg-descr
deleted file mode 100644
index 3275152cec31..000000000000
--- a/www/py-jsonfield2/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-jsonfield2 is a reusable model field that allows you to store validated JSON,
-automatically handling serialization to and from the database. To use, add
-jsonfield.JSONField to one of your models.
-
-WWW: https://github.com/rpkilby/jsonfield2