aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2025-02-04 07:34:04 +0000
committerJason E. Hale <jhale@FreeBSD.org>2025-02-04 07:49:41 +0000
commit575006e026437d5d5a084fc0af6c1551d1ecba80 (patch)
treea3cff3827ef06bbd44551a9269785954986cd2de
parent2169ecb6c77cb0e6cc9287917f17ab25567abc1c (diff)
x11-toolkits/qml-box2d: Unflavorize
The qt5 flavor is no longer needed with the update of games/gcompris-qt, its only consumer, in the following commit.
-rw-r--r--MOVED2
-rw-r--r--x11-toolkits/qml-box2d/Makefile20
2 files changed, 7 insertions, 15 deletions
diff --git a/MOVED b/MOVED
index 445fb27a9f99..688a484bcb81 100644
--- a/MOVED
+++ b/MOVED
@@ -4119,3 +4119,5 @@ x11/plasma5-plasma-integration|x11/plasma6-plasma-integration|2025-02-03|Moved t
x11/plasma5-plasma-workspace|x11/plasma6-plasma-workspace|2025-02-03|Moved to Plasma 6
www/falkon@default|www/falkon@kf6|2025-02-03|Flavor was renamed to use a more standard PKGNAMESUFFIX
www/falkon@qtonly|www/falkon@qt6|2025-02-03|Flavor was renamed to use a more standard PKGNAMESUFFIX
+x11-toolkits/qml-box2d@qt5||2025-02-03|Unflavorize port, qt5 flavor is no longer used in ports tree
+x11-toolkits/qml-box2d@qt6|x11-toolkits/qml-box2d|2025-02-03|Unflavorize port, as it is now qt6 only
diff --git a/x11-toolkits/qml-box2d/Makefile b/x11-toolkits/qml-box2d/Makefile
index 8d8c3a6545d5..d1f7ded43403 100644
--- a/x11-toolkits/qml-box2d/Makefile
+++ b/x11-toolkits/qml-box2d/Makefile
@@ -1,7 +1,7 @@
PORTNAME= qml-box2d
DISTVERSION= 2.0.20240415
CATEGORIES= x11-toolkits
-PKGNAMESUFFIX= -${FLAVOR}
+PKGNAMESUFFIX= -qt6
MAINTAINER= kde@FreeBSD.org
COMMENT= QML Box2D plugin
@@ -10,23 +10,13 @@ WWW= https://github.com/qml-box2d/qml-box2d
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/COPYING
-FLAVORS= qt5 qt6
-FLAVOR?= qt5
-
-USES= cmake compiler:c++11-lang gl qt:${FLAVOR:S/qt//}
+USES= cmake compiler:c++17-lang gl qt:6
USE_GITHUB= yes
GH_TAGNAME= 3a85439
-_USE_GL=qt5= # empty
-_USE_GL_qt6= gl opengl # glx
-USE_GL= ${_USE_GL_${FLAVOR}}
-_USE_QT_qt5= core declarative gui network \
- buildtools:build qmake:build
-_USE_QT_qt6= base declarative
-USE_QT= ${_USE_QT_${FLAVOR}}
+USE_GL= gl opengl # glx
+USE_QT= base declarative
CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR:STRING="${QT_QMLDIR}"
-_CMAKE_OFF_qt5= USE_QT6
-CMAKE_OFF= BUILD_EXAMPLES \
- ${_CMAKE_OFF_${FLAVOR}}
+CMAKE_OFF= BUILD_EXAMPLES
.include <bsd.port.mk>