aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-13 08:55:02 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-13 10:06:14 +0000
commit57561a2ccb23ed19fac5feb1f2b8f414da2eb27a (patch)
tree5c26114b5b0d2015cbf068094c4581afe38bf2c2
parente9b6b65e68d0da5877223cea728bb2cd5d3ac358 (diff)
math/rubygem-rb-gsl: Fix build with llvm15
Approved by: portmgr (blanket)
-rw-r--r--math/rubygem-rb-gsl/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/math/rubygem-rb-gsl/Makefile b/math/rubygem-rb-gsl/Makefile
index f0967a1947c9..2eb3167a140b 100644
--- a/math/rubygem-rb-gsl/Makefile
+++ b/math/rubygem-rb-gsl/Makefile
@@ -16,4 +16,10 @@ RUN_DEPENDS= rubygem-narray>=0.5.9:math/rubygem-narray
USES= gem
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CONFIGURE_ARGS+= --with-cflags="-Wno-error=int-conversion"
+.endif
+
.include <bsd.port.mk>