aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <dizzy@FreeBSD.org>2022-02-21 19:58:15 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2022-02-21 19:58:15 +0000
commit575930ac731f8f9c3122cc9b6aa321561fec544b (patch)
treeb2e4cd8fd75ab9095e976598a81290009fbdc101
parentc33aae9e6a5c66516f3759f507a6d4a4543f10b4 (diff)
downloadports-575930ac731f8f9c3122cc9b6aa321561fec544b.tar.gz
ports-575930ac731f8f9c3122cc9b6aa321561fec544b.zip
net/wireshark: Update MASTER_SITES, fix RTP option, adjust Makefile
- Update MASTER_SITES with official mirrors and add main site as last resort Reference: https://www.wireshark.org/mirror.html - Remove unnecessary definitions and switch to DISTVERSION while at it - Fix RTP option PR: 262076
-rw-r--r--net/wireshark/Makefile19
-rw-r--r--net/wireshark/pkg-plist2
2 files changed, 10 insertions, 11 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index b79ce8dc8361..79f477a26bbe 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -1,17 +1,17 @@
# Created by: Bill Fumerola <billf@chc-chimes.com>
PORTNAME?= wireshark
-PORTVERSION= 3.6.2
+DISTVERSION= 3.6.2
CATEGORIES= net
-MASTER_SITES= http://www.wireshark.org/download/src/ \
+MASTER_SITES= https://1.na.dl.wireshark.org/src/ \
+ https://1.eu.dl.wireshark.org/src/ \
+ https://1.as.dl.wireshark.org/src/ \
+ https://2.na.dl.wireshark.org/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
- http://wireshark.askapache.com/download/src/all-versions/ \
- ftp://ftp.uni-kl.de/pub/wireshark/src/ \
- http://prdownloads.sourceforge.net/wireshark/ \
http://ftp.yz.yamagata-u.ac.jp/pub/network/security/wireshark/src/ \
- ftp://ftp.yz.yamagata-u.ac.jp/pub/network/security/wireshark/src/ \
- http://wireshark.zing.org/download/src/
-DISTNAME= ${DATADIR_NAME}-${PORTVERSION}
+ https://wireshark.marwan.ma/download/src/ \
+ https://www.wireshark.org/download/src/
+DISTNAME= ${DATADIR_NAME}-${DISTVERSION}
MAINTAINER= marcus@FreeBSD.org
COMMENT?= Powerful network analyzer/capture tool
@@ -41,7 +41,6 @@ LIB_DEPENDS+= libgpg-error.so:security/libgpg-error \
libzstd.so:archivers/zstd
#CFLAGS+= -funit-at-a-time
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
reordercap captype randpktdump udpdump sharkd etwdump
@@ -92,7 +91,6 @@ GSSAPI_HEIMDAL_USES= gssapi:heimdal
GSSAPI_MIT_USES= gssapi:mit
RTP_LIB_DEPENDS= libspandsp.so:comms/spandsp
-RTP_CPPFLAGS= -I${LOCALBASE}/include
MAXMIND_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
SNMP_LIB_DEPENDS= libsmi.so:net-mgmt/libsmi
DECRYPT_LIB_DEPENDS= libgnutls.so:security/gnutls \
@@ -100,7 +98,6 @@ DECRYPT_LIB_DEPENDS= libgnutls.so:security/gnutls \
SSHDUMP_LIB_DEPENDS= libssh.so:security/libssh
CISCODUMP_LIB_DEPENDS= libssh.so:security/libssh
OPUS_LIB_DEPENDS= libopus.so:audio/opus
-OPUS_CPPFLAGS= -I${LOCALBASE}/include
GSSAPI_NONE_CMAKE_ON= -DENABLE_KERBEROS=OFF
GSSAPI_NONE_CMAKE_OFF= -DENABLE_KERBEROS=ON
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index 31eb70e674a9..1f1b1c91c0c5 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -665,6 +665,8 @@ lib/wireshark/cmake/WiresharkTargets.cmake
%%SSHDUMP_LIB%%lib/wireshark/extcap/sshdump
%%UDPDUMP_LIB%%lib/wireshark/extcap/udpdump
lib/wireshark/plugins/3.6/codecs/g711.so
+%%RTP%%lib/wireshark/plugins/3.6/codecs/g722.so
+%%RTP%%lib/wireshark/plugins/3.6/codecs/g726.so
lib/wireshark/plugins/3.6/codecs/l16mono.so
%%OPUS%%lib/wireshark/plugins/3.6/codecs/opus_dec.so
lib/wireshark/plugins/3.6/epan/ethercat.so