aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-08-13 13:34:09 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-08-13 13:34:09 +0000
commit5797d6a3298ebfe3990db73084f34ed935911efa (patch)
tree31cdb05fd87b21fd1171d903f16ea674470018a3
parent6aeff2e8d145527738a0fc5cec87c9e2e122ef81 (diff)
downloadports-5797d6a3298ebfe3990db73084f34ed935911efa.tar.gz
ports-5797d6a3298ebfe3990db73084f34ed935911efa.zip
biology/py-ont-fast5-api: Interface to Oxford Nanopore .fast5 files
The ont_fast5_api is a simple interface to HDF5 files of the Oxford Nanopore .fast5 file format. It provides: o Implementation of the fast5 file schema using h5py library o Methods to interact with and reflect the fast5 file schema o Tools to convert between multi_read and single_read formats o Tools to compress/decompress raw data in files
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-ont-fast5-api/Makefile42
-rw-r--r--biology/py-ont-fast5-api/distinfo3
-rw-r--r--biology/py-ont-fast5-api/pkg-descr9
4 files changed, 55 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 60ab10072e29..13f0cd294ee5 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -144,6 +144,7 @@
SUBDIR += py-loompy
SUBDIR += py-macs2
SUBDIR += py-multiqc
+ SUBDIR += py-ont-fast5-api
SUBDIR += py-orange3-bioinformatics
SUBDIR += py-orange3-single-cell
SUBDIR += py-pandas-charm
diff --git a/biology/py-ont-fast5-api/Makefile b/biology/py-ont-fast5-api/Makefile
new file mode 100644
index 000000000000..d998d68a0e04
--- /dev/null
+++ b/biology/py-ont-fast5-api/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= ont-fast5-api
+DISTVERSIONPREFIX= release_
+DISTVERSION= 4.0.0
+CATEGORIES= biology python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Interface to HDF5 files in Oxford Nanopore .fast5 format
+
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libvbz_hdf_plugin.so:archivers/vbz-compression
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>=2.2.0:science/py-h5py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}progressbar>0:misc/py-progressbar@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>=0:devel/py-pip@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+USE_GITHUB= yes
+
+GH_ACCOUNT= nanoporetech
+GH_PROJECT= ont_fast5_api
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+post-patch:
+ ${RM} ${WRKSRC}/ont_fast5_api/vbz_plugin/*
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|progressbar33|progressbar|g' \
+ ${WRKSRC}/setup.py \
+ ${WRKSRC}/README.rst \
+ ${WRKSRC}/ont_fast5_api/conversion_tools/conversion_utils.py
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/biology/py-ont-fast5-api/distinfo b/biology/py-ont-fast5-api/distinfo
new file mode 100644
index 000000000000..9156cd8912ef
--- /dev/null
+++ b/biology/py-ont-fast5-api/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1628770827
+SHA256 (nanoporetech-ont_fast5_api-release_4.0.0_GH0.tar.gz) = 7f9b3fa0f814ff38c30e9cb21971ec61e2b3fd52fb166a8404c21bf25679e0ab
+SIZE (nanoporetech-ont_fast5_api-release_4.0.0_GH0.tar.gz) = 4081125
diff --git a/biology/py-ont-fast5-api/pkg-descr b/biology/py-ont-fast5-api/pkg-descr
new file mode 100644
index 000000000000..e8482d387fa0
--- /dev/null
+++ b/biology/py-ont-fast5-api/pkg-descr
@@ -0,0 +1,9 @@
+The ont_fast5_api is a simple interface to HDF5 files of the Oxford
+Nanopore .fast5 file format. It provides:
+
+ o Implementation of the fast5 file schema using h5py library
+ o Methods to interact with and reflect the fast5 file schema
+ o Tools to convert between multi_read and single_read formats
+ o Tools to compress/decompress raw data in files
+
+WWW: https://pypi.python.org/pypi/ont_fast5_api