aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-11-19 18:31:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-11-19 18:33:55 +0000
commit57a397e0a279cdb6e73a29d23e233051441d179c (patch)
treef82e76cc576fdec4329935f6458e365d1aee08a2
parent75e6e3c90fc50020151736fbdd6eac5209b20a03 (diff)
downloadports-57a397e0a279cdb6e73a29d23e233051441d179c.tar.gz
ports-57a397e0a279cdb6e73a29d23e233051441d179c.zip
www/yt-dlp: Make py-SecretStorage an optional port dependency
py-SecretStorage pulls a lot of dependencies for a small optional feature in yt-dlp. The upstream merged the PR that also makes SecretStorage optional: https://github.com/yt-dlp/yt-dlp/pull/8585 PR: 275196 Submitted by: Helge Oldach <freebsd@oldach.net> (initial version)
-rw-r--r--www/yt-dlp/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/www/yt-dlp/Makefile b/www/yt-dlp/Makefile
index e1960cc8a121..f45781c2159f 100644
--- a/www/yt-dlp/Makefile
+++ b/www/yt-dlp/Makefile
@@ -1,5 +1,6 @@
PORTNAME= yt-dlp
DISTVERSION= 2023.11.16
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${DISTVERSION}/
DISTNAME= ${PORTNAME}
@@ -17,7 +18,6 @@ PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}brotli>0:archivers/py-brotli@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycryptodomex>0:security/py-pycryptodomex@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.31.0:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}SecretStorage>0:security/py-SecretStorage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>=1.26.17:net/py-urllib3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}websockets>0:devel/py-websockets@${PY_FLAVOR}
@@ -32,17 +32,21 @@ MAKE_ARGS= PYTHON=${PYTHON_CMD}
NO_ARCH= yes
-OPTIONS_DEFINE= FFMPEG RTMPDUMP SYMLINK
-OPTIONS_DEFAULT= FFMPEG RTMPDUMP SYMLINK
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= FFMPEG RTMPDUMP SECRETSTORAGE SYMLINK
+OPTIONS_DEFAULT= FFMPEG RTMPDUMP SYMLINK
+OPTIONS_SUB= yes
-FFMPEG_RUN_DEPENDS= ffprobe:multimedia/ffmpeg
+FFMPEG_RUN_DEPENDS= ffprobe:multimedia/ffmpeg
-RTMPDUMP_DESC= Use rtmpdump to download rtmp video streams
-RTMPDUMP_RUN_DEPENDS= rtmpdump:multimedia/rtmpdump
+RTMPDUMP_DESC= Use rtmpdump to download rtmp video streams
+RTMPDUMP_RUN_DEPENDS= rtmpdump:multimedia/rtmpdump
-SYMLINK_DESC= Install youtube-dl symbolic link for executable
-SYMLINK_CONFLICTS= youtube_dl
+SECRETSTORAGE_DESC= Build with ${PYTHON_PKGNAMEPREFIX}SecretStorage for secretstorage option
+SECRETSTORAGE_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}SecretStorage>0:security/py-SecretStorage@${PY_FLAVOR}
+SECRETSTORAGE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}SecretStorage>0:security/py-SecretStorage@${PY_FLAVOR}
+
+SYMLINK_DESC= Install youtube-dl symbolic link for executable
+SYMLINK_CONFLICTS= youtube_dl
post-install-SYMLINK-on:
@${RLN} ${STAGEDIR}${PREFIX}/bin/yt-dlp ${STAGEDIR}${PREFIX}/bin/youtube-dl