aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-08-23 01:36:22 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-08-23 01:36:22 +0000
commit57e20159644154da14b3a40ce278cce01c13f25c (patch)
tree76e6c7f2839b8e81235df6469b69c16995e0bc68
parente30ce086a7a37fae1179cced3cda8e2696029b3f (diff)
downloadports-57e20159644154da14b3a40ce278cce01c13f25c.tar.gz
ports-57e20159644154da14b3a40ce278cce01c13f25c.zip
misc/wego: Weather client for the terminal
-rw-r--r--misc/Makefile1
-rw-r--r--misc/wego/Makefile25
-rw-r--r--misc/wego/distinfo15
-rw-r--r--misc/wego/pkg-descr3
4 files changed, 44 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index e2c15c34bbe7..ba2ac493049a 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -537,6 +537,7 @@
SUBDIR += visp
SUBDIR += viz
SUBDIR += vxl
+ SUBDIR += wego
SUBDIR += whichman
SUBDIR += window
SUBDIR += with
diff --git a/misc/wego/Makefile b/misc/wego/Makefile
new file mode 100644
index 000000000000..990b9e79bb09
--- /dev/null
+++ b/misc/wego/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= wego
+DISTVERSION= 2.1
+CATEGORIES= misc
+
+MAINTAINER= pkubaj@FreeBSD.org
+COMMENT= Weather client for the terminal
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= schachmat
+GH_TUPLE= \
+ mattn:go-colorable:v0.1.12:mattn_gocolorable/vendor/github.com/mattn/go-colorable \
+ mattn:go-runewidth:v0.0.13:mattn_gorunewidth/vendor/github.com/mattn/go-runewidth \
+ schachmat:ingo:a4bdc0729a3f:schachmat_ingo/vendor/github.com/schachmat/ingo \
+ mattn:go-isatty:v0.0.14:mattn_goisatty/vendor/github.com/mattn/go-isatty \
+ rivo:uniseg:v0.2.0:rivo_uniseg/vendor/github.com/rivo/uniseg \
+ golang:sys:39ccf1dd6fa6:golang_sys/vendor/golang.org/x/sys
+GO_TARGET= wego
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/misc/wego/distinfo b/misc/wego/distinfo
new file mode 100644
index 000000000000..634565ce5cbf
--- /dev/null
+++ b/misc/wego/distinfo
@@ -0,0 +1,15 @@
+TIMESTAMP = 1661218227
+SHA256 (schachmat-wego-2.1_GH0.tar.gz) = cebfa622789aa8e7045657d81754cb502ba189f4b4bebd1a95192528e06969a6
+SIZE (schachmat-wego-2.1_GH0.tar.gz) = 16499
+SHA256 (mattn-go-colorable-v0.1.12_GH0.tar.gz) = 32493594aee411896ffe13aaed14df4a23c3006866c46c1a908af79eacd102b2
+SIZE (mattn-go-colorable-v0.1.12_GH0.tar.gz) = 9801
+SHA256 (mattn-go-runewidth-v0.0.13_GH0.tar.gz) = 9b2aeafa5d95a40b32067ba22accdf42cc83414ec5b433ea7de330791beaa196
+SIZE (mattn-go-runewidth-v0.0.13_GH0.tar.gz) = 17353
+SHA256 (schachmat-ingo-a4bdc0729a3f_GH0.tar.gz) = 2bfcf26de06c432ea4e2e61973d6a3b093efcf7b0f720506893589e332c5e0b4
+SIZE (schachmat-ingo-a4bdc0729a3f_GH0.tar.gz) = 5341
+SHA256 (mattn-go-isatty-v0.0.14_GH0.tar.gz) = e6460325edf600297cf2ef68834938fb1c5b8d5f234b3b24ec7c0a29a2d70b39
+SIZE (mattn-go-isatty-v0.0.14_GH0.tar.gz) = 4710
+SHA256 (rivo-uniseg-v0.2.0_GH0.tar.gz) = 3ad738b5c9162ede110d75b23564b6e40e52dd9150ebbced402f4f70be106197
+SIZE (rivo-uniseg-v0.2.0_GH0.tar.gz) = 44036
+SHA256 (golang-sys-39ccf1dd6fa6_GH0.tar.gz) = 91b6b5c8e7793ebdcbdf014bc1695bbcf1ea171abdcdb56ca0b3f4a9bc3f60ee
+SIZE (golang-sys-39ccf1dd6fa6_GH0.tar.gz) = 1211355
diff --git a/misc/wego/pkg-descr b/misc/wego/pkg-descr
new file mode 100644
index 000000000000..9fb785822c5d
--- /dev/null
+++ b/misc/wego/pkg-descr
@@ -0,0 +1,3 @@
+wego is a weather client for the terminal.
+
+WWW: https://github.com/schachmat/wego