aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2024-05-29 13:35:40 +0000
committerRene Ladan <rene@FreeBSD.org>2024-05-29 13:35:40 +0000
commit59327c25953ca2a7e708bacfeee2c499c577a240 (patch)
tree4756a01711b2d6da61bbdfa002ffdd6c3f71bec0
parentf3a63acd1fc29164e5d5b1d8e0dd3a2153a12264 (diff)
devel/libopkele: Remove expired port
2024-04-24 devel/libopkele: Last upstream release was in 2009
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libopkele/Makefile45
-rw-r--r--devel/libopkele/distinfo5
-rw-r--r--devel/libopkele/files/patch-include_opkele_discovery.h11
-rw-r--r--devel/libopkele/files/patch-lib_curl.cc11
-rw-r--r--devel/libopkele/files/patch-test_idiscover.cc10
-rw-r--r--devel/libopkele/files/patch-test_test.cc9
-rw-r--r--devel/libopkele/pkg-descr3
-rw-r--r--devel/libopkele/pkg-plist23
10 files changed, 1 insertions, 118 deletions
diff --git a/MOVED b/MOVED
index a0e74492f0a4..9e929f0cb806 100644
--- a/MOVED
+++ b/MOVED
@@ -3270,3 +3270,4 @@ devel/rubygem-flipper025|devel/rubygem-flipper|2024-05-28|Remove obsoleted port.
www/rubygem-rqrcode2|www/rubygem-rqrcode|2024-05-28|Remove obsoleted port. Use www/rubygem-rqrcode instead
net/iaxmodem||2024-05-29|Has expired: outdated and uses end-of-life version of GCC
www/mod_auth_openid||2024-05-29|Has expired: Depends on expired devel/libopkele
+devel/libopkele||2024-05-29|Has expired: Last upstream release was in 2009
diff --git a/devel/Makefile b/devel/Makefile
index 062b51865b97..04d8f3ab8c29 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1360,7 +1360,6 @@
SUBDIR += libopenbsd
SUBDIR += libopencm3
SUBDIR += libopentracing
- SUBDIR += libopkele
SUBDIR += liborcus
SUBDIR += libosinfo
SUBDIR += libowfat
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
deleted file mode 100644
index 773e03867e47..000000000000
--- a/devel/libopkele/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-PORTNAME= libopkele
-PORTVERSION= 2.0.4
-PORTREVISION= 21
-CATEGORIES= devel
-MASTER_SITES= http://kin.klever.net/dist/
-
-PATCH_SITES= https://github.com/hacker/libopkele/commit/
-PATCHFILES= 62f3ba4ecb92.diff:-p1
-
-MAINTAINER= zhoushuqun@gmail.com
-COMMENT= C++ implementation of an OpenID decentralized identity system
-WWW= https://kin.klever.net/libopkele/
-
-DEPRECATED= Last upstream release was in 2009
-EXPIRATION_DATE=2024-04-24
-
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-RUN_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-LIB_DEPENDS= libcurl.so:ftp/curl \
- libpcre.so:devel/pcre \
- libexpat.so:textproc/expat2 \
- libtidy5.so:www/tidy-html5 \
- libxslt.so:textproc/libxslt
-
-USES= gmake libtool localbase:ldflags pathfix \
- pkgconfig ssl
-USE_CXXSTD= c++14
-USE_LDCONFIG= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
-
-post-patch:
- @${REINPLACE_CMD} -e "/^Requires:/s,openssl ,," \
- ${WRKSRC}/libopkele.pc.in
- @${REINPLACE_CMD} -e "s/-ltidy/-ltidy5/g" \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e "s/buffio.h/tidybuffio.h/g" \
- ${WRKSRC}/include/opkele/tidy.h
-
-.include <bsd.port.mk>
diff --git a/devel/libopkele/distinfo b/devel/libopkele/distinfo
deleted file mode 100644
index d08722783ee8..000000000000
--- a/devel/libopkele/distinfo
+++ /dev/null
@@ -1,5 +0,0 @@
-TIMESTAMP = 1298297231
-SHA256 (libopkele-2.0.4.tar.gz) = 57a5bc753b7e80c5ece1e5968b2051b0ce7ed9ce4329d17122c61575a9ea7648
-SIZE (libopkele-2.0.4.tar.gz) = 391054
-SHA256 (62f3ba4ecb92.diff) = 0a2d255f3f040de1fed6e1ac39c836f45217cd8e24a4ea6b965d1b2ec3d591c5
-SIZE (62f3ba4ecb92.diff) = 3354
diff --git a/devel/libopkele/files/patch-include_opkele_discovery.h b/devel/libopkele/files/patch-include_opkele_discovery.h
deleted file mode 100644
index 03af6a81da90..000000000000
--- a/devel/libopkele/files/patch-include_opkele_discovery.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/opkele/discovery.h.orig 2008-06-25 20:50:26.000000000 +0000
-+++ include/opkele/discovery.h
-@@ -21,7 +21,7 @@ namespace opkele {
- public:
-
- inline _DT& add(long priority,const _DT& d) {
-- return insert(typename map_type::value_type(priority,d))->second;
-+ return this->insert(typename map_type::value_type(priority,d))->second;
- }
-
- bool has_value(const _DT& d) const {
diff --git a/devel/libopkele/files/patch-lib_curl.cc b/devel/libopkele/files/patch-lib_curl.cc
deleted file mode 100644
index 496c7aafc860..000000000000
--- a/devel/libopkele/files/patch-lib_curl.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/curl.cc.orig 2018-07-07 18:25:16 UTC
-+++ lib/curl.cc
-@@ -45,7 +45,7 @@ namespace opkele {
- || (r=easy_setopt(CURLOPT_MAXREDIRS,5))
- || (r=easy_setopt(CURLOPT_DNS_CACHE_TIMEOUT,120))
- || (r=easy_setopt(CURLOPT_DNS_USE_GLOBAL_CACHE,1))
-- || (r=easy_setopt(CURLOPT_USERAGENT,PACKAGE_NAME"/"PACKAGE_SRC_VERSION))
-+ || (r=easy_setopt(CURLOPT_USERAGENT,PACKAGE_NAME "/" PACKAGE_SRC_VERSION))
- || (r=easy_setopt(CURLOPT_TIMEOUT,20))
- #ifdef DISABLE_CURL_SSL_VERIFYHOST
- || (r=easy_setopt(CURLOPT_SSL_VERIFYHOST,0))
diff --git a/devel/libopkele/files/patch-test_idiscover.cc b/devel/libopkele/files/patch-test_idiscover.cc
deleted file mode 100644
index 713881ad3831..000000000000
--- a/devel/libopkele/files/patch-test_idiscover.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- test/idiscover.cc.orig 2008-06-25 20:50:26.000000000 +0000
-+++ test/idiscover.cc
-@@ -2,6 +2,7 @@
- #include <stdexcept>
- #include <iterator>
- #include <algorithm>
-+#include <unistd.h>
- using namespace std;
- #include <opkele/exception.h>
- #include <opkele/discovery.h>
diff --git a/devel/libopkele/files/patch-test_test.cc b/devel/libopkele/files/patch-test_test.cc
deleted file mode 100644
index d000ebc907c4..000000000000
--- a/devel/libopkele/files/patch-test_test.cc
+++ /dev/null
@@ -1,9 +0,0 @@
---- test/test.cc.orig 2009-12-12 20:22:34.000000000 +0000
-+++ test/test.cc
-@@ -1,5 +1,6 @@
- #include <iostream>
- #include <stdexcept>
-+#include <unistd.h>
- using namespace std;
- #include <opkele/exception.h>
- #include <opkele/util.h>
diff --git a/devel/libopkele/pkg-descr b/devel/libopkele/pkg-descr
deleted file mode 100644
index ab0b2e1f816a..000000000000
--- a/devel/libopkele/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-libopkele is a c++ implementation of an OpenID decentralized identity
-system. It provides OpenID protocol handling, leaving authentication
-and user interaction to the implementor.
diff --git a/devel/libopkele/pkg-plist b/devel/libopkele/pkg-plist
deleted file mode 100644
index eebac7b12b54..000000000000
--- a/devel/libopkele/pkg-plist
+++ /dev/null
@@ -1,23 +0,0 @@
-include/opkele/acconfig.h
-include/opkele/association.h
-include/opkele/ax.h
-include/opkele/basic_op.h
-include/opkele/basic_rp.h
-include/opkele/exception.h
-include/opkele/extension.h
-include/opkele/extension_chain.h
-include/opkele/iterator.h
-include/opkele/oauth_ext.h
-include/opkele/opkele-config.h
-include/opkele/prequeue_rp.h
-include/opkele/sreg.h
-include/opkele/tr1-mem.h
-include/opkele/types.h
-include/opkele/uris.h
-include/opkele/util.h
-include/opkele/verify_op.h
-lib/libopkele.a
-lib/libopkele.so
-lib/libopkele.so.3
-lib/libopkele.so.3.0.0
-libdata/pkgconfig/libopkele.pc