aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-01-02 16:45:30 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-01-02 17:31:24 +0000
commit59a8ef603d053f64e4067f3723feeeb60610bedb (patch)
treee24d1618092a11dfe0462b9492319524b8ad556f
parent0375fc8f10e7ebcee63258c57abcd80e3c84333f (diff)
biology/phyml: update to 3.3.20211231
ChangeLog: https://github.com/stephaneguindon/phyml/compare/v3.3.20211118...v3.3.20211231 Remove patches already merged into upstream. Reported by: portscout
-rw-r--r--biology/phyml/Makefile4
-rw-r--r--biology/phyml/distinfo6
-rw-r--r--biology/phyml/files/patch-configure.ac15
-rw-r--r--biology/phyml/files/patch-src_io.c20
-rw-r--r--biology/phyml/files/patch-src_phyrex.c11
-rw-r--r--biology/phyml/files/patch-src_utilities.c30
-rw-r--r--biology/phyml/files/patch-src_utilities.h13
7 files changed, 12 insertions, 87 deletions
diff --git a/biology/phyml/Makefile b/biology/phyml/Makefile
index 0881c57ced44..4c659132117e 100644
--- a/biology/phyml/Makefile
+++ b/biology/phyml/Makefile
@@ -2,7 +2,7 @@
PORTNAME= phyml
DISTVERSIONPREFIX= v
-DISTVERSION= 3.3.20200621
+DISTVERSION= 3.3.20211231
PORTEPOCH= 1
CATEGORIES= biology
@@ -44,8 +44,6 @@ BIN_SUFFIX= # none
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|-O2 .* $${ARCH_flag}|$${CFLAGS}|' ${WRKSRC}/configure.ac
.if ${ARCH} != amd64 && ${ARCH} != i386
@${REINPLACE_CMD} -e 's|VECTOR_FLAG=-march=native|dnl &|' ${WRKSRC}/configure.ac
.endif
diff --git a/biology/phyml/distinfo b/biology/phyml/distinfo
index bb7619ad9861..1e98ab22af49 100644
--- a/biology/phyml/distinfo
+++ b/biology/phyml/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594372740
-SHA256 (stephaneguindon-phyml-v3.3.20200621_GH0.tar.gz) = ffbecbc716fe7dd3e25493d2ebc1aab42ff3c33fc6fffca0920a950d38d74e22
-SIZE (stephaneguindon-phyml-v3.3.20200621_GH0.tar.gz) = 2234125
+TIMESTAMP = 1641139689
+SHA256 (stephaneguindon-phyml-v3.3.20211231_GH0.tar.gz) = 5822c04f1b8ad7f9ef5aecaacc124f736b78344eb8cf459a230c727152734d99
+SIZE (stephaneguindon-phyml-v3.3.20211231_GH0.tar.gz) = 1802113
diff --git a/biology/phyml/files/patch-configure.ac b/biology/phyml/files/patch-configure.ac
index c96d56cf91bc..ea8e872962a0 100644
--- a/biology/phyml/files/patch-configure.ac
+++ b/biology/phyml/files/patch-configure.ac
@@ -1,10 +1,11 @@
---- configure.ac.orig 2020-07-09 11:49:16 UTC
+--- configure.ac.orig 2022-01-02 16:39:46 UTC
+++ configure.ac
-@@ -10,7 +10,6 @@ AC_CONFIG_HEADERS([config.h])
- AC_DEFINE([UNIX],[1],[Unix tag on])
- AC_DEFINE([DEBUG],[1],[Debug tag on])
+@@ -67,7 +67,7 @@ dnl AC_PROG_LIBTOOL
--AM_INIT_AUTOMAKE
- AC_CANONICAL_HOST
- AC_PROG_CC([gcc])
+ dnl DEFAULT_C_FLAG="-fno-inline-functions -fno-inline-functions-called-once -fno-optimize-sibling-calls -O2 -fno-omit-frame-pointer -g ${VECTOR_FLAG}"
+-DEFAULT_C_FLAG="-std=c99 -O3 -fomit-frame-pointer -funroll-loops -Wall -Winline -finline ${VECTOR_FLAG}"
++DEFAULT_C_FLAG="-std=c99 -O3 -fomit-frame-pointer -funroll-loops -msse3 -Wall -Winline -finline ${VECTOR_FLAG}"
+ dnl DEFAULT_C_FLAG="-O2 ${VECTOR_FLAG}"
+ dnl DEFAULT_C_FLAG="${VECTOR_FLAG}"
+ dnl DEFAULT_C_FLAG="-pthread -O3 -g -ffunction-sections -fdata-sections"
diff --git a/biology/phyml/files/patch-src_io.c b/biology/phyml/files/patch-src_io.c
deleted file mode 100644
index 00fdcf48030f..000000000000
--- a/biology/phyml/files/patch-src_io.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/io.c.orig 2020-07-09 11:49:16 UTC
-+++ src/io.c
-@@ -39,8 +39,6 @@ t_tree *Read_Tree(char **s_tree)
- if((*s_tree)[i] == ',') n_otu++;
- }
- n_otu+=1;
--
--
-
- tree = Make_Tree_From_Scratch(n_otu,NULL);
- subs = Sub_Trees((*s_tree),&degree);
-@@ -2312,7 +2310,7 @@ void Print_Fp_Out(FILE *fp_out, time_t t_beg, time_t t
- div_t hour,min;
- int i, j;
-
-- if (precision > 0) snprintf (format, 8, "%%.%df", precision);
-+ if (precision > 0) snprintf(format,8,"%%.%huf",(unsigned short)precision);
-
- if(n_data_set == 1)
- {
diff --git a/biology/phyml/files/patch-src_phyrex.c b/biology/phyml/files/patch-src_phyrex.c
deleted file mode 100644
index 661ee785dd32..000000000000
--- a/biology/phyml/files/patch-src_phyrex.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/phyrex.c.orig 2020-07-09 11:49:16 UTC
-+++ src/phyrex.c
-@@ -958,7 +958,7 @@ phydbl *PHYREX_MCMC(t_tree *tree)
- PHYREX_Label_Nodes_With_Locations(tree);
- PHYREX_Label_Edges(tree);
- char *s = Write_Tree(tree);
-- PhyML_Fprintf(fp_tree,"\ntree %d [&lnP=%f,precision={1.e-1,1e-02,1e-01}] = [&R] %s",tree->mcmc->sample_num,tree->c_lnL,s);
-+ PhyML_Fprintf(fp_tree,"\ntree %d [&lnP=%f,precision={1.e-1,1e-02,1e-01}] = [&R] %s",tree->mcmc->run,tree->c_lnL,s);
- PhyML_Fprintf(fp_tree,"\nend;");
- fseek(fp_tree,-5,SEEK_END);
- tree->write_tax_names = YES;
diff --git a/biology/phyml/files/patch-src_utilities.c b/biology/phyml/files/patch-src_utilities.c
deleted file mode 100644
index 99740e857571..000000000000
--- a/biology/phyml/files/patch-src_utilities.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/utilities.c.orig 2020-07-09 11:49:16 UTC
-+++ src/utilities.c
-@@ -17,6 +17,9 @@ the GNU public licence. See http://www.opensource.org
- #include "beagle_utils.h"
- #endif
-
-+int CALL;
-+int TIME;
-+
- //////////////////////////////////////////////////////////////
- //////////////////////////////////////////////////////////////
-
-@@ -3066,7 +3069,7 @@ int Assign_State_With_Ambiguity(char *c, int datatype,
- if(Is_Ambigu(c,GENERIC,stepsize)) state[0] = T_MAX_ALPHABET-1;
- else
- {
-- char format[6];
-+ char format[20];
- sprintf(format,"%%%dd",stepsize);
- if(!sscanf(c,format,state))
- {
-@@ -4891,7 +4894,7 @@ int Are_Compatible(char *statea, char *stateb, int ste
- else
- {
- int a,b;
-- char format[6];
-+ char format[20];
-
- sprintf(format,"%%%dd",stepsize);
-
diff --git a/biology/phyml/files/patch-src_utilities.h b/biology/phyml/files/patch-src_utilities.h
deleted file mode 100644
index 14b65b1fff53..000000000000
--- a/biology/phyml/files/patch-src_utilities.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/utilities.h.orig 2020-08-29 08:31:23 UTC
-+++ src/utilities.h
-@@ -94,8 +94,8 @@ static inline int isinf_ld (long double x) { return is
- #endif
-
-
--int CALL;
--int TIME;
-+extern int CALL;
-+extern int TIME;
-
- #define SLFV_GAUSSIAN 0 /* Spatial Lambda-Fleming-Viot model (Gaussian) */
- #define SLFV_UNIFORM 1 /* Spatial Lambda-Fleming-Viot model (Uniform) */