aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-06-07 05:32:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-06-07 15:50:59 +0000
commit59dd7eeaf68be352ec636445c4432c49009cefa1 (patch)
treeda51a5a82137ff07d9e722e7692390a61ed19647
parent8978bebb13b9bbc79ec70f5b1744f720c43355f0 (diff)
devel/subprocess: New port: C++ subprocess library similar in design to Python subprocess library
-rw-r--r--devel/Makefile1
-rw-r--r--devel/subprocess/Makefile35
-rw-r--r--devel/subprocess/distinfo7
-rw-r--r--devel/subprocess/pkg-descr2
-rw-r--r--devel/subprocess/pkg-plist8
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c3c6149e500a..0fdb539d9d00 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7911,6 +7911,7 @@
SUBDIR += stxxl
SUBDIR += stylua
SUBDIR += styx
+ SUBDIR += subprocess
SUBDIR += subversion
SUBDIR += subversion-book
SUBDIR += subversion-lts
diff --git a/devel/subprocess/Makefile b/devel/subprocess/Makefile
new file mode 100644
index 000000000000..5e73db8ffa2c
--- /dev/null
+++ b/devel/subprocess/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= subprocess
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.0-6
+DISTVERSIONSUFFIX= -g29d01c7
+CATEGORIES= devel
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 2caf8c1e119d5f14f4ae31316ddfd03126e101ac.patch:-p1 # https://github.com/benman64/subprocess/pull/17
+PATCHFILES+= cef6823e5834053a20144b790945f7ed1808c28c.patch:-p1 # https://github.com/benman64/subprocess/pull/18
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ subprocess library similar in design to Python subprocess library
+WWW= https://github.com/benman64/subprocess
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:testing python:build
+
+USE_GITHUB= yes
+GH_ACCOUNT= benman64
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+BINARY_ALIAS= python3=${PYTHON_CMD}
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/cpp/subprocess.hpp ${STAGEDIR}${PREFIX}/include
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/subprocess
+.for inc in basic_types.hpp pipe.hpp PipeVar.hpp ProcessBuilder.hpp shell_utils.hpp environ.hpp
+ ${INSTALL_DATA} ${WRKSRC}/src/cpp/subprocess/${inc} ${STAGEDIR}${PREFIX}/include/subprocess
+.endfor
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/subprocess/libsubprocess.so ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/subprocess/distinfo b/devel/subprocess/distinfo
new file mode 100644
index 000000000000..3d0c6a8b7bf1
--- /dev/null
+++ b/devel/subprocess/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1717738163
+SHA256 (benman64-subprocess-v0.4.0-6-g29d01c7_GH0.tar.gz) = d52f6c578048de03aac10b100eeef42ef06677b5c1cc0816eae2e0906d2745df
+SIZE (benman64-subprocess-v0.4.0-6-g29d01c7_GH0.tar.gz) = 717218
+SHA256 (2caf8c1e119d5f14f4ae31316ddfd03126e101ac.patch) = e6ed70cf42f7e43db6bfaea58c8c9eb1e0b5b83b0fb10fbae0f98a3e0d326259
+SIZE (2caf8c1e119d5f14f4ae31316ddfd03126e101ac.patch) = 677
+SHA256 (cef6823e5834053a20144b790945f7ed1808c28c.patch) = 9f82743ba74894497327f23d54a048a2fdf49ec82ee48bc5d10ed951bdabaa15
+SIZE (cef6823e5834053a20144b790945f7ed1808c28c.patch) = 1309
diff --git a/devel/subprocess/pkg-descr b/devel/subprocess/pkg-descr
new file mode 100644
index 000000000000..ac43b4447e69
--- /dev/null
+++ b/devel/subprocess/pkg-descr
@@ -0,0 +1,2 @@
+subprocess is a cross platform subprocess library for c++ similar to design
+of python subprocess.
diff --git a/devel/subprocess/pkg-plist b/devel/subprocess/pkg-plist
new file mode 100644
index 000000000000..9174964b3da8
--- /dev/null
+++ b/devel/subprocess/pkg-plist
@@ -0,0 +1,8 @@
+include/subprocess.hpp
+include/subprocess/PipeVar.hpp
+include/subprocess/ProcessBuilder.hpp
+include/subprocess/basic_types.hpp
+include/subprocess/environ.hpp
+include/subprocess/pipe.hpp
+include/subprocess/shell_utils.hpp
+lib/libsubprocess.so