aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-01-15 21:30:11 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-01-15 21:30:11 +0000
commit5a4d9e71b86f13b22721c7d48e3a8005b29c13fd (patch)
tree3ab6e30888f7dc90da23c9e83b258ba95e9cadec
parentb3396d4e01447bf156debd1d51184491aa7f097f (diff)
downloadports-5a4d9e71b86f13b22721c7d48e3a8005b29c13fd.tar.gz
ports-5a4d9e71b86f13b22721c7d48e3a8005b29c13fd.zip
Pass variables to make(1), rather than patching
Notes
Notes: svn path=/head/; revision=490429
-rw-r--r--net/geoipupdate/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/net/geoipupdate/Makefile b/net/geoipupdate/Makefile
index d7b6645aede3..99ca1292c89c 100644
--- a/net/geoipupdate/Makefile
+++ b/net/geoipupdate/Makefile
@@ -21,7 +21,9 @@ USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= maxmind
-MAKE_ENV+= GOPATH=${WRKSRC}
+MAKE_ENV+= GOPATH=${WRKSRC} \
+ CONFFILE=${PREFIX}/etc/GeoIP.conf \
+ DATADIR=${PREFIX}/share/GeoIP
OPTIONS_DEFINE= DOCS
@@ -30,9 +32,6 @@ PLIST_FILES= bin/geoipupdate \
'@dir share/GeoIP'
PORTDOCS= GeoIP.conf.md geoipupdate.md
-post-patch:
- ${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/Makefile
-
do-build:
${MV} ${WRKSRC}/vendor ${WRKSRC}/src
${DO_MAKE_BUILD} -C ${WRKSRC}