aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-16 19:36:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-16 19:37:33 +0000
commit5a5cab3eaa7d0072b8589a88842b922c4b0aac29 (patch)
tree1a4d774719184dc89902b47a244cb1f29e1323c6
parentb422449c1fc559bc231f64b6237d7b6913c94132 (diff)
downloadports-5a5cab3eaa7d0072b8589a88842b922c4b0aac29.tar.gz
ports-5a5cab3eaa7d0072b8589a88842b922c4b0aac29.zip
devel/juce: Add BSD-related patches
-rw-r--r--devel/juce/Makefile3
-rw-r--r--devel/juce/distinfo6
-rw-r--r--devel/juce/files/patch-modules_juce__core_native_juce__linux__Files.cpp13
3 files changed, 18 insertions, 4 deletions
diff --git a/devel/juce/Makefile b/devel/juce/Makefile
index fe16186bf4d6..77cbb3a7987b 100644
--- a/devel/juce/Makefile
+++ b/devel/juce/Makefile
@@ -1,9 +1,10 @@
PORTNAME= juce
DISTVERSION= 7.0.2
+PORTREVISION= 1
CATEGORIES= devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES= 27d6e8388c620bf32be0c86c66ff8c403f4c1d71.diff:-p1
+PATCHFILES= e819560ff09502af2a4e567b9cf9a9f90f9a3da1.diff:-p1
MAINTAINER= yuri@FreeBSD.org
COMMENT= C++ application framework to develop desktop and mobile applications
diff --git a/devel/juce/distinfo b/devel/juce/distinfo
index fabbd0b9af44..e38d15bb7f46 100644
--- a/devel/juce/distinfo
+++ b/devel/juce/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1660750815
+TIMESTAMP = 1665947063
SHA256 (juce-framework-JUCE-7.0.2_GH0.tar.gz) = bcbf9e3a58ab26cf91f28fde13bf13e8c81cd34f3269d92ca69175b89fbb5ba3
SIZE (juce-framework-JUCE-7.0.2_GH0.tar.gz) = 18931117
-SHA256 (27d6e8388c620bf32be0c86c66ff8c403f4c1d71.diff) = d347469053a397be59eb3ae6173f99ec22af8837b1537e5c61f8d94a8d45f97e
-SIZE (27d6e8388c620bf32be0c86c66ff8c403f4c1d71.diff) = 1365
+SHA256 (e819560ff09502af2a4e567b9cf9a9f90f9a3da1.diff) = ef0c1d13848a3f21a55004a1443b8e87397bc5fc501b6429d923ba8433ac4bc7
+SIZE (e819560ff09502af2a4e567b9cf9a9f90f9a3da1.diff) = 2037
diff --git a/devel/juce/files/patch-modules_juce__core_native_juce__linux__Files.cpp b/devel/juce/files/patch-modules_juce__core_native_juce__linux__Files.cpp
new file mode 100644
index 000000000000..707d077e2b20
--- /dev/null
+++ b/devel/juce/files/patch-modules_juce__core_native_juce__linux__Files.cpp
@@ -0,0 +1,13 @@
+- workaround for https://reviews.freebsd.org/D30842
+
+--- modules/juce_core/native/juce_linux_Files.cpp.orig 2022-10-16 19:17:29 UTC
++++ modules/juce_core/native/juce_linux_Files.cpp
+@@ -229,7 +229,7 @@ bool Process::openDocument (const String& fileName, co
+ setsid();
+
+ // Child process
+- execve (argv[0], (char**) argv, environ);
++ execv (argv[0], (char**) argv);
+ exit (0);
+ }
+