aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2023-01-03 21:32:08 +0000
committerHiroki Sato <hrs@FreeBSD.org>2023-01-03 21:32:08 +0000
commit5c042d5680ab40667f1689b7b600a423be1214d8 (patch)
tree58ebb36dd92fa0b935084eee262f478a89647207
parent4e4d098c81a21050668b6660d88cda2c243434c1 (diff)
www/p5-OpenAPI-Client: Add a new port: Client for talking to an OpenAPI-powered server
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-OpenAPI-Client/Makefile21
-rw-r--r--www/p5-OpenAPI-Client/distinfo3
-rw-r--r--www/p5-OpenAPI-Client/pkg-descr6
-rw-r--r--www/p5-OpenAPI-Client/pkg-plist4
5 files changed, 35 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 489bfe64d64d..373624b311e1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1041,6 +1041,7 @@
SUBDIR += p5-Newsletter
SUBDIR += p5-Nginx-ReadBody
SUBDIR += p5-Nginx-Simple
+ SUBDIR += p5-OpenAPI-Client
SUBDIR += p5-PHP-Session
SUBDIR += p5-POE-Component-Client-HTTP
SUBDIR += p5-POE-Component-Client-UserAgent
diff --git a/www/p5-OpenAPI-Client/Makefile b/www/p5-OpenAPI-Client/Makefile
new file mode 100644
index 000000000000..2cb8b514af8c
--- /dev/null
+++ b/www/p5-OpenAPI-Client/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= OpenAPI-Client
+PORTVERSION= 1.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN/Mojolicious
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Client for talking to an OpenAPI-powered server
+WWW= https://metacpan.org/pod/OpenAPI::Client
+
+LICENSE= ART20
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Mojolicious>=1:www/p5-Mojolicious \
+ p5-JSON-Validator>=0:textproc/p5-JSON-Validator
+
+NO_ARCH= yes
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-OpenAPI-Client/distinfo b/www/p5-OpenAPI-Client/distinfo
new file mode 100644
index 000000000000..4943858fe1e4
--- /dev/null
+++ b/www/p5-OpenAPI-Client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672780782
+SHA256 (OpenAPI-Client-1.07.tar.gz) = 51ed641d283b8f4bbbc06d01c156739bd2b9a88b4ef84b7b84f950fa0ee14db3
+SIZE (OpenAPI-Client-1.07.tar.gz) = 15604
diff --git a/www/p5-OpenAPI-Client/pkg-descr b/www/p5-OpenAPI-Client/pkg-descr
new file mode 100644
index 000000000000..4b1cd888f8d9
--- /dev/null
+++ b/www/p5-OpenAPI-Client/pkg-descr
@@ -0,0 +1,6 @@
+OpenAPI::Client can generate classes that can talk to an Open API
+server. This is done by generating a custom class, based on a Open API
+specification, with methods that transform parameters into a HTTP request.
+
+The generated class will perform input validation, so invalid data
+won't be sent to the server.
diff --git a/www/p5-OpenAPI-Client/pkg-plist b/www/p5-OpenAPI-Client/pkg-plist
new file mode 100644
index 000000000000..866611b407a7
--- /dev/null
+++ b/www/p5-OpenAPI-Client/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Mojolicious/Command/openapi.pm
+%%SITE_PERL%%/OpenAPI/Client.pm
+%%PERL5_MAN3%%/OpenAPI::Client.3.gz
+%%PERL5_MAN3%%/Mojolicious::Command::openapi.3.gz