aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-05-25 17:45:54 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-05-25 17:56:28 +0000
commit5c3c7e39eaa4c27c59d712556a48179bcaf233ec (patch)
tree8bb63569416d8724b5cdabd6d514d35489ae7366
parent7c01038fb2d7748c537692ee61263b8ac494a6eb (diff)
downloadports-5c3c7e39eaa4c27c59d712556a48179bcaf233ec.tar.gz
ports-5c3c7e39eaa4c27c59d712556a48179bcaf233ec.zip
astro/qmapshack: Update version 1.15.2=>1.16.0
-rw-r--r--astro/qmapshack/Makefile3
-rw-r--r--astro/qmapshack/distinfo6
-rw-r--r--astro/qmapshack/files/patch-CMakeLists.txt20
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt24
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp4
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp8
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_gis_wpt_CGisItemWpt.cpp6
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_helpers_CDraw.cpp6
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_map_CMapIMG.cpp6
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_mouse_IMouseSelect.cpp8
-rw-r--r--astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt8
-rw-r--r--astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt16
-rw-r--r--astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt6
13 files changed, 51 insertions, 70 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index eab4870bd078..d73e2e89fdab 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -1,8 +1,7 @@
# Created by: Muhammad Moinur Rahman <bofh@FreeBSD.org>
PORTNAME= qmapshack
-PORTVERSION= 1.15.2
-PORTREVISION= 1
+PORTVERSION= 1.16.0
DISTVERSIONPREFIX= V_
CATEGORIES= astro
diff --git a/astro/qmapshack/distinfo b/astro/qmapshack/distinfo
index f21353897b96..eaa4493d31d9 100644
--- a/astro/qmapshack/distinfo
+++ b/astro/qmapshack/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1610218166
-SHA256 (Maproom-qmapshack-V_1.15.2_GH0.tar.gz) = 35831d703ef3decc83f168a020144ec89907f484485b242be24fd2e094898857
-SIZE (Maproom-qmapshack-V_1.15.2_GH0.tar.gz) = 46899954
+TIMESTAMP = 1621864013
+SHA256 (Maproom-qmapshack-V_1.16.0_GH0.tar.gz) = 0beae1063fc17c033e6084ea71bc0cc95de505f6fc04da9cf8b70f8003df4302
+SIZE (Maproom-qmapshack-V_1.16.0_GH0.tar.gz) = 54233332
diff --git a/astro/qmapshack/files/patch-CMakeLists.txt b/astro/qmapshack/files/patch-CMakeLists.txt
index f281d11e1dbb..a7ddfc23540e 100644
--- a/astro/qmapshack/files/patch-CMakeLists.txt
+++ b/astro/qmapshack/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2020-06-14 10:22:49 UTC
+--- CMakeLists.txt.orig 2021-05-24 09:18:08 UTC
+++ CMakeLists.txt
-@@ -65,6 +65,7 @@ include(TranslateDesktop)
+@@ -47,6 +47,7 @@ include(TranslateDesktop)
include(DefineCMakeDefaults)
include(DefineCompilerFlags)
include(DefineInstallationPaths)
@@ -8,19 +8,15 @@
include(CPackConfig.cmake)
include(ConfigureChecks.cmake)
-@@ -167,10 +168,13 @@ find_package(Qt5WebEngineWidgets REQUIRED)
+@@ -151,7 +152,10 @@ find_package(Qt5WebEngineWidgets REQUIRED)
find_package(Qt5Qml REQUIRED)
find_package(Qt5Help REQUIRED)
find_package(GDAL REQUIRED)
--find_package(PROJ4 REQUIRED)
-+find_package(PROJ4)
-+if (NOT PROJ4_FOUND)
-+ pkg_search_module(PROJ4 REQUIRED proj)
+-find_package(PROJ REQUIRED)
++find_package(PROJ)
++if (NOT PROJ_FOUND)
++ pkg_search_module(PROJ REQUIRED proj)
+endif()
find_package(JPEG REQUIRED)
find_package(ROUTINO REQUIRED)
--find_package(QuaZip5 REQUIRED)
-+find_package(QuaZip-Qt5 REQUIRED)
- find_package(ALGLIB ) # optional as we can use our local version
-
-
+ find_package(QuaZip-Qt5 REQUIRED)
diff --git a/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
index d4d35b223ec6..7a8e1fbaaac0 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmapshack_CMakeLists.txt
@@ -1,25 +1,11 @@
---- src/qmapshack/CMakeLists.txt.orig 2020-06-14 10:22:49 UTC
+--- src/qmapshack/CMakeLists.txt.orig 2021-05-24 14:06:57 UTC
+++ src/qmapshack/CMakeLists.txt
-@@ -897,7 +897,6 @@ include_directories(
- ${PROJ4_INCLUDE_DIRS}
- ${ROUTINO_INCLUDE_DIRS}
- ${ALGLIB_INCLUDE_DIRS}
-- ${QUAZIP_INCLUDE_DIRS}
- )
-
- if(APPLE)
-@@ -941,12 +940,12 @@ target_link_libraries(${APPLICATION_NAME}
- Qt5::Qml
- Qt5::Positioning
+@@ -971,7 +971,7 @@ target_link_libraries(${APPLICATION_NAME}
Qt5::Help
-+ QuaZip::QuaZip
${DBUS_LIB}
${GDAL_LIBRARIES}
-- ${PROJ4_LIBRARIES}
-+ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES}
+- ${PROJ_LIBRARIES}
++ ${PROJ_LDFLAGS} ${PROJ_LIBRARIES}
${ROUTINO_LIBRARIES}
${ALGLIB_LIBRARIES}
-- ${QUAZIP_LIBRARIES}
- )
-
- if(APPLE)
+ QuaZip::QuaZip
diff --git a/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp b/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
index 83b6f7053f8b..551da113e187 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
+++ b/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
@@ -1,8 +1,8 @@
---- src/qmapshack/device/CDeviceWatcherLinux.cpp.orig 2019-11-01 16:47:46 UTC
+--- src/qmapshack/device/CDeviceWatcherLinux.cpp.orig 2021-05-24 09:18:08 UTC
+++ src/qmapshack/device/CDeviceWatcherLinux.cpp
@@ -58,6 +58,10 @@ void CDeviceWatcherLinux::slotDeviceAdded(const QDBusO
// create path of to drive the block device belongs to
- QDBusInterface * blockIface = new QDBusInterface("org.freedesktop.UDisks2", path.path(), "org.freedesktop.UDisks2.Block", QDBusConnection::systemBus(), this);
+ QDBusInterface* blockIface = new QDBusInterface("org.freedesktop.UDisks2", path.path(), "org.freedesktop.UDisks2.Block", QDBusConnection::systemBus(), this);
QDBusObjectPath drive_object = blockIface->property("Drive").value<QDBusObjectPath>();
+ if(drive_object.path() == nullptr)
+ {
diff --git a/astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp b/astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp
index 46b6910b8604..1848e32dd13e 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp
+++ b/astro/qmapshack/files/patch-src_qmapshack_gis_rte_router_brouter_CRouterBRouterSetupWizard.cpp
@@ -1,11 +1,11 @@
---- src/qmapshack/gis/rte/router/brouter/CRouterBRouterSetupWizard.cpp.orig 2020-11-08 17:59:37 UTC
+--- src/qmapshack/gis/rte/router/brouter/CRouterBRouterSetupWizard.cpp.orig 2021-05-24 09:18:08 UTC
+++ src/qmapshack/gis/rte/router/brouter/CRouterBRouterSetupWizard.cpp
-@@ -22,7 +22,7 @@
- #include "gis/rte/router/brouter/CRouterBRouterSetupWizard.h"
+@@ -24,7 +24,7 @@
#include "helpers/CWebPage.h"
#include "setup/IAppSetup.h"
+
-#include <JlCompress.h>
+#include <quazip/JlCompress.h>
- #include <proj_api.h>
#include <QFileDialog>
#include <QMessageBox>
+ #include <QNetworkReply>
diff --git a/astro/qmapshack/files/patch-src_qmapshack_gis_wpt_CGisItemWpt.cpp b/astro/qmapshack/files/patch-src_qmapshack_gis_wpt_CGisItemWpt.cpp
index 56f3cad0f012..536f6ccbaefd 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_gis_wpt_CGisItemWpt.cpp
+++ b/astro/qmapshack/files/patch-src_qmapshack_gis_wpt_CGisItemWpt.cpp
@@ -1,7 +1,7 @@
---- src/qmapshack/gis/wpt/CGisItemWpt.cpp.orig 2020-05-21 11:11:11 UTC
+--- src/qmapshack/gis/wpt/CGisItemWpt.cpp.orig 2021-05-24 09:18:08 UTC
+++ src/qmapshack/gis/wpt/CGisItemWpt.cpp
-@@ -38,6 +38,7 @@
-
+@@ -40,6 +40,7 @@
+ #include <QPainterPath>
#include <QtWidgets>
#include <QtXml>
+#include <QPainterPath>
diff --git a/astro/qmapshack/files/patch-src_qmapshack_helpers_CDraw.cpp b/astro/qmapshack/files/patch-src_qmapshack_helpers_CDraw.cpp
index e4c437f50024..5f8fe0f14ee3 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_helpers_CDraw.cpp
+++ b/astro/qmapshack/files/patch-src_qmapshack_helpers_CDraw.cpp
@@ -1,7 +1,7 @@
---- src/qmapshack/helpers/CDraw.cpp.orig 2020-05-21 11:11:11 UTC
+--- src/qmapshack/helpers/CDraw.cpp.orig 2021-05-24 09:18:08 UTC
+++ src/qmapshack/helpers/CDraw.cpp
-@@ -24,6 +24,7 @@
- #include <QImage>
+@@ -25,6 +25,7 @@
+ #include <QPainterPath>
#include <QPointF>
#include <QtMath>
+#include <QPainterPath>
diff --git a/astro/qmapshack/files/patch-src_qmapshack_map_CMapIMG.cpp b/astro/qmapshack/files/patch-src_qmapshack_map_CMapIMG.cpp
index 154fb7db186e..1fa864a24aa5 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_map_CMapIMG.cpp
+++ b/astro/qmapshack/files/patch-src_qmapshack_map_CMapIMG.cpp
@@ -1,8 +1,8 @@
---- src/qmapshack/map/CMapIMG.cpp.orig 2020-05-21 11:11:11 UTC
+--- src/qmapshack/map/CMapIMG.cpp.orig 2021-05-24 09:18:08 UTC
+++ src/qmapshack/map/CMapIMG.cpp
-@@ -33,6 +33,7 @@
- #include "units/IUnit.h"
+@@ -34,6 +34,7 @@
+ #include <QPainterPath>
#include <QtWidgets>
+#include <QPainterPath>
diff --git a/astro/qmapshack/files/patch-src_qmapshack_mouse_IMouseSelect.cpp b/astro/qmapshack/files/patch-src_qmapshack_mouse_IMouseSelect.cpp
index e3886f7749f5..4a1bb4396314 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_mouse_IMouseSelect.cpp
+++ b/astro/qmapshack/files/patch-src_qmapshack_mouse_IMouseSelect.cpp
@@ -1,10 +1,10 @@
---- src/qmapshack/mouse/IMouseSelect.cpp.orig 2020-05-21 11:11:11 UTC
+--- src/qmapshack/mouse/IMouseSelect.cpp.orig 2021-05-24 09:18:08 UTC
+++ src/qmapshack/mouse/IMouseSelect.cpp
-@@ -23,6 +23,7 @@
- #include "mouse/IScrOpt.h"
+@@ -24,6 +24,7 @@
+ #include <QPainterPath>
#include <QtWidgets>
+#include <QPainterPath>
- IMouseSelect::IMouseSelect(CGisDraw *gis, CCanvas *canvas, CMouseAdapter *mouse)
+ IMouseSelect::IMouseSelect(CGisDraw* gis, CCanvas* canvas, CMouseAdapter* mouse)
: IMouse(gis, canvas, mouse)
diff --git a/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt
index 2e65464897a6..5578f1b4081b 100644
--- a/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmaptool_CMakeLists.txt
@@ -1,11 +1,11 @@
---- src/qmaptool/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+--- src/qmaptool/CMakeLists.txt.orig 2021-05-24 09:18:08 UTC
+++ src/qmaptool/CMakeLists.txt
-@@ -254,7 +254,7 @@ target_link_libraries(${APPLICATION_NAME}
+@@ -259,7 +259,7 @@ target_link_libraries(${APPLICATION_NAME}
Qt5::Network
Qt5::Help
${GDAL_LIBRARIES}
-- ${PROJ4_LIBRARIES}
-+ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES}
+- ${PROJ_LIBRARIES}
++ ${PROJ_LDFLAGS} ${PROJ_LIBRARIES}
)
if(APPLE)
diff --git a/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
index c23a15cd3cf3..50f04b2be82d 100644
--- a/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmt__map2jnx_CMakeLists.txt
@@ -1,11 +1,11 @@
---- src/qmt_map2jnx/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+--- src/qmt_map2jnx/CMakeLists.txt.orig 2021-05-24 09:18:08 UTC
+++ src/qmt_map2jnx/CMakeLists.txt
-@@ -48,7 +48,7 @@ IF(WIN32)
- ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
- ENDIF(WIN32)
-
--TARGET_LINK_LIBRARIES(${APPLICATION_NAME} ${GDAL_LIBRARIES} ${PROJ4_LIBRARIES} ${JPEG_LIBRARIES})
-+TARGET_LINK_LIBRARIES(${APPLICATION_NAME} ${GDAL_LIBRARIES} ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES} ${JPEG_LIBRARIES})
+@@ -53,7 +53,7 @@ TARGET_LINK_LIBRARIES(${APPLICATION_NAME}
+ Qt5::Core
+ Qt5::Gui
+ ${GDAL_LIBRARIES}
+- ${PROJ_LIBRARIES}
++ ${PROJ_LDFLAGS} ${PROJ_LIBRARIES}
+ ${JPEG_LIBRARIES})
install(
- TARGETS ${APPLICATION_NAME} DESTINATION ${BIN_INSTALL_DIR}
diff --git a/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt b/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt
index 4ec858ca803c..8afed710c6e0 100644
--- a/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt
+++ b/astro/qmapshack/files/patch-src_qmt__rgb2pct_CMakeLists.txt
@@ -1,11 +1,11 @@
---- src/qmt_rgb2pct/CMakeLists.txt.orig 2020-03-27 08:07:31 UTC
+--- src/qmt_rgb2pct/CMakeLists.txt.orig 2021-05-24 09:18:08 UTC
+++ src/qmt_rgb2pct/CMakeLists.txt
@@ -92,7 +92,7 @@ target_compile_definitions(${APPLICATION_NAME} PUBLIC
target_link_libraries(${APPLICATION_NAME}
Qt5::Core
${GDAL_LIBRARIES}
-- ${PROJ4_LIBRARIES}
-+ ${PROJ4_LDFLAGS} ${PROJ4_LIBRARIES}
+- ${PROJ_LIBRARIES}
++ ${PROJ_LDFLAGS} ${PROJ_LIBRARIES}
)
if(APPLE)