aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-12-13 12:24:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-12-13 12:27:46 +0000
commit5c5b6e94234f1d3e4b8ac29e05934d1e30da3893 (patch)
tree3e8296b8facdda5cc449f414b7b713b62c4a6ea7
parentdb70f7d7b329c1b429363e3541204ae3096ce8ce (diff)
downloadports-5c5b6e94234f1d3e4b8ac29e05934d1e30da3893.tar.gz
ports-5c5b6e94234f1d3e4b8ac29e05934d1e30da3893.zip
games/warzone2100: replace vk::throwResultException fix with upstream
-rw-r--r--games/warzone2100/Makefile3
-rw-r--r--games/warzone2100/distinfo2
-rw-r--r--games/warzone2100/files/patch-vulkan-headers-1.2.19767
3 files changed, 5 insertions, 67 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index c3b1e1026a28..a21f4cccc585 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -6,6 +6,9 @@ MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}_src
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}/commit/
+PATCHFILES+= 5e6fdab3feac.patch:-p1 # https://github.com/Warzone2100/warzone2100/pull/2479
+
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Innovative 3D real-time strategy game
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
index ea2ee87491e0..0911f8249158 100644
--- a/games/warzone2100/distinfo
+++ b/games/warzone2100/distinfo
@@ -1,3 +1,5 @@
TIMESTAMP = 1618939913
SHA256 (warzone2100-4.0.1/warzone2100_src.tar.xz) = 337622d5f813bbc1f9a3b4fee0874fcc074806781cfa9c25a252534ddd240ab9
SIZE (warzone2100-4.0.1/warzone2100_src.tar.xz) = 337713608
+SHA256 (warzone2100-4.0.1/5e6fdab3feac.patch) = 579ffd85c09ffca615a9c90cb07d1021d7dc58fe12dffed8c7e5602cdaa8ca7d
+SIZE (warzone2100-4.0.1/5e6fdab3feac.patch) = 1737
diff --git a/games/warzone2100/files/patch-vulkan-headers-1.2.197 b/games/warzone2100/files/patch-vulkan-headers-1.2.197
deleted file mode 100644
index 700428327986..000000000000
--- a/games/warzone2100/files/patch-vulkan-headers-1.2.197
+++ /dev/null
@@ -1,67 +0,0 @@
-lib/ivis_opengl/gfx_api_vk.cpp:480:3: error: use of undeclared identifier 'throwResultException'; did you mean 'vk::throwResultException'?
- throwResultException( result, "vmaCreateBuffer" );
- ^~~~~~~~~~~~~~~~~~~~
- vk::throwResultException
-/usr/local/include/vulkan/vulkan.hpp:6315:23: note: 'vk::throwResultException' declared here
- [[noreturn]] void throwResultException( Result result, char const * message )
- ^
-lib/ivis_opengl/gfx_api_vk.cpp:1293:4: error: use of undeclared identifier 'throwResultException'; did you mean 'vk::throwResultException'?
- throwResultException(result.result, "createGraphicsPipeline");
- ^~~~~~~~~~~~~~~~~~~~
- vk::throwResultException
-/usr/local/include/vulkan/vulkan.hpp:6315:23: note: 'vk::throwResultException' declared here
- [[noreturn]] void throwResultException( Result result, char const * message )
- ^
-lib/ivis_opengl/gfx_api_vk.cpp:1353:3: error: use of undeclared identifier 'throwResultException'; did you mean 'vk::throwResultException'?
- throwResultException( result, "vmaCreateBuffer" );
- ^~~~~~~~~~~~~~~~~~~~
- vk::throwResultException
-/usr/local/include/vulkan/vulkan.hpp:6315:23: note: 'vk::throwResultException' declared here
- [[noreturn]] void throwResultException( Result result, char const * message )
- ^
-lib/ivis_opengl/gfx_api_vk.cpp:1460:3: error: use of undeclared identifier 'throwResultException'; did you mean 'vk::throwResultException'?
- throwResultException( result, "vmaCreateImage" );
- ^~~~~~~~~~~~~~~~~~~~
- vk::throwResultException
-/usr/local/include/vulkan/vulkan.hpp:6315:23: note: 'vk::throwResultException' declared here
- [[noreturn]] void throwResultException( Result result, char const * message )
- ^
-
---- lib/ivis_opengl/gfx_api_vk.cpp.orig 2021-04-18 18:28:41 UTC
-+++ lib/ivis_opengl/gfx_api_vk.cpp
-@@ -477,7 +477,7 @@ void BlockBufferAllocator::allocateNewBlock(uint32_t m
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- throwResultException( result, "vmaCreateBuffer" );
-+ vk::throwResultException( result, "vmaCreateBuffer" );
- }
-
- if (autoMap)
-@@ -1290,7 +1290,7 @@ VkPSO::VkPSO(vk::Device _dev,
- object = std::move(result.value);
- break;
- default:
-- throwResultException(result.result, "createGraphicsPipeline");
-+ vk::throwResultException(result.result, "createGraphicsPipeline");
- }
- }
-
-@@ -1350,7 +1350,7 @@ void VkBuf::allocateBufferObject(const std::size_t& si
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- throwResultException( result, "vmaCreateBuffer" );
-+ vk::throwResultException( result, "vmaCreateBuffer" );
- }
-
- buffer_size = size;
-@@ -1457,7 +1457,7 @@ VkTexture::VkTexture(const VkRoot& root, const std::si
- if (result != vk::Result::eSuccess)
- {
- // Failed to allocate memory!
-- throwResultException( result, "vmaCreateImage" );
-+ vk::throwResultException( result, "vmaCreateImage" );
- }
-
- const auto imageViewCreateInfo = vk::ImageViewCreateInfo()