aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-07 21:54:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-07 21:54:19 +0000
commit5c8ec9d29fd58e9b8a8d023f9a5be95647c0f7dc (patch)
tree1371bfd37def2098b7c24ca3c160b72cb5d34302
parenta39b855f80f3976f5b310dae99161b7df4b60deb (diff)
downloadports-5c8ec9d29fd58e9b8a8d023f9a5be95647c0f7dc.tar.gz
ports-5c8ec9d29fd58e9b8a8d023f9a5be95647c0f7dc.zip
New port: science/molgif: Tool to create GIF animations of molecules
Notes
Notes: svn path=/head/; revision=481495
-rw-r--r--science/Makefile1
-rw-r--r--science/molgif/Makefile29
-rw-r--r--science/molgif/distinfo3
-rw-r--r--science/molgif/pkg-descr5
4 files changed, 38 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index de11a7a9bf7d..677d062c9a8f 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -139,6 +139,7 @@
SUBDIR += minc2
SUBDIR += mmdb2
SUBDIR += mol2ps
+ SUBDIR += molgif
SUBDIR += mpb
SUBDIR += mpqc
SUBDIR += msms
diff --git a/science/molgif/Makefile b/science/molgif/Makefile
new file mode 100644
index 000000000000..7ae074f06d82
--- /dev/null
+++ b/science/molgif/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= molgif
+DISTVERSION= g20180108
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Tool to create GIF animations of molecules
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= go:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= ilyak
+GH_TAGNAME= a7df9e4
+GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-build:
+ @cd ${WRKSRC}/${GH_SUBDIR} && \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/science/molgif/distinfo b/science/molgif/distinfo
new file mode 100644
index 000000000000..38740d3c3049
--- /dev/null
+++ b/science/molgif/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538947291
+SHA256 (ilyak-molgif-g20180108-a7df9e4_GH0.tar.gz) = 62873f4b10cad999d68b24027313b84861e7788426b22a5951dd3d405598f91e
+SIZE (ilyak-molgif-g20180108-a7df9e4_GH0.tar.gz) = 11076976
diff --git a/science/molgif/pkg-descr b/science/molgif/pkg-descr
new file mode 100644
index 000000000000..2d1a3bf215b1
--- /dev/null
+++ b/science/molgif/pkg-descr
@@ -0,0 +1,5 @@
+Molgif is an easy-to-use tool for creating GIF animations of molecules. Thanks
+to the widespread support of GIF file format, animations can be easily embedded
+into presentations, websites, wikipedia, and so forth.
+
+WWW: https://github.com/ilyak/molgif